]> git.pld-linux.org Git - packages/glib.git/blob - glib.spec
a543d0233d270eb7550a5e5a63cf970927221522
[packages/glib.git] / glib.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Useful routines for 'C' programming
6 Summary(cs.UTF-8):      Šikovná knihovna s funkcemi pro pomocné programy
7 Summary(da.UTF-8):      Nyttige biblioteksfunktioner
8 Summary(de.UTF-8):      Eine nützliche Library von Dienstprogramm-Funktionen
9 Summary(fi.UTF-8):      Kirjasto, jossa on työkalufunktioita
10 Summary(fr.UTF-8):      Bibliothèque de fonctions utilitaires
11 Summary(pl.UTF-8):      Biblioteka zawierająca wiele użytecznych funkcji C
12 Summary(tr.UTF-8):      Yararlı ufak yordamlar kitaplığı
13 Name:           glib
14 Version:        1.2.10
15 Release:        21
16 Epoch:          1
17 License:        LGPL v2+
18 Group:          Libraries
19 Source0:        ftp://ftp.gtk.org/pub/gtk/v1.2/%{name}-%{version}.tar.gz
20 #Source0-md5:   6fe30dad87c77b91b632def29dd69ef9
21 Source1:        http://developer.gnome.org/doc/API/%{name}-docs.tar.gz
22 #Source1-md5:   cae06bf952176ab008100b7b954242f8
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-ac25.patch
25 Patch2:         %{name}-am18.patch
26 Patch3:         %{name}-link.patch
27 Patch4:         %{name}-gcc34.patch
28 Patch5:         %{name}-slist_remove.patch
29 Patch6:         format-security.patch
30 Patch7:         texi-subsection.patch
31 Patch8:         inline.patch
32 Patch9:         %{name}-libdir.patch
33 URL:            http://www.gtk.org/
34 BuildRequires:  autoconf >= 2.13
35 BuildRequires:  automake >= 1.4
36 BuildRequires:  libtool >= 1:1.4.2-9
37 BuildRequires:  texinfo
38 Obsoletes:      libglib1.2
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         specflags       -fno-strict-aliasing
42
43 %description
44 GLib, is a library which includes support routines for C such as
45 lists, trees, hashes, memory allocation, and many other things. GLIB
46 includes also generally useful data structures used by GIMP and many
47 other.
48
49 %description -l cs.UTF-8
50 Šikovná knihovna s funkcemi pro pomocné programy. Vývojové knihovny a
51 hlavičky jsou v balíčku glib-devel.
52
53 %description -l da.UTF-8
54 Nyttigt bibliotek med forskellige funktioner. Udviklings- biblioteker
55 og headerfiler er i glib-devel pakken.
56
57 %description -l de.UTF-8
58 Eine nützliche Library von Dienstprogramm-Funktionen.
59 Entwicklungs-Libraries und Header befinden sich in glib-devel.
60
61 %description -l fi.UTF-8
62 Kirjasto, jossa on työkalufunktioita. Kehitysversiot ja
63 header-tiedostot ovat glib-devel-paketissa.
64
65 %description -l pl.UTF-8
66 Glib jest zestawem bibliotek zawierających funkcje do obsługi list,
67 drzewek, funkcji mieszających, funkcji do alokacji pamięci i wielu
68 innych podstawowych funkcji i różnych struktur danych używanych przez
69 program GIMP i wiele innych.
70
71 %description -l tr.UTF-8
72 Yararlı yordamlar kitaplığı. Geliştirme kitaplıkları ve başlık
73 dosyaları glib-devel paketinde yer almaktadır.
74
75 %package devel
76 Summary:        Glib heades files, documentation
77 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do glib
78 Group:          Development/Libraries
79 Requires:       %{name} = %{epoch}:%{version}-%{release}
80 Obsoletes:      libglib1.2-devel
81
82 %description devel
83 Header files for the support library for the GIMP's X libraries, which
84 are available as public libraries. GLIB includes generally useful data
85 structures.
86
87 %description devel -l pl.UTF-8
88 Pliki nagłówkowe i dokumentacja do glib przydatna przy pisaniu
89 programów wykorzystujących tę bibliotekę.
90
91 %package static
92 Summary:        Static glib libraries
93 Summary(pl.UTF-8):      Biblioteki statyczne do glib
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
96
97 %description static
98 Static glib libraries.
99
100 %description static -l pl.UTF-8
101 Biblioteki statyczne do glib.
102
103 %prep
104 %setup -q -a1
105 %patch0 -p1
106 %patch1 -p1
107 %patch2 -p1
108 %patch3 -p1
109 %patch4 -p1
110 %patch5 -p1
111 %patch6 -p1
112 %patch7 -p1
113 %patch8 -p1
114 %patch9 -p1
115
116 %build
117 %{__rm} acinclude.m4
118 %{__libtoolize}
119 %{__aclocal}
120 %{__autoconf}
121 %{__automake}
122 %configure \
123         --enable-debug=%{?debug:yes}%{!?debug:minimum} \
124         --enable-threads \
125         %{!?with_static_libs:--disable-static}
126
127 %{__make} -j1 all check
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT \
134         m4datadir=%{_aclocaldir} \
135         pkgconfigdir=%{_pkgconfigdir}
136
137 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %post   devel -p /sbin/postshell
146 -/usr/sbin/fix-info-dir -c %{_infodir}
147
148 %postun devel -p /sbin/postshell
149 -/usr/sbin/fix-info-dir -c %{_infodir}
150
151 %files
152 %defattr(644,root,root,755)
153 %doc AUTHORS ChangeLog NEWS README
154 %attr(755,root,root) %{_libdir}/libglib-1.2.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libglib-1.2.so.0
156 %attr(755,root,root) %{_libdir}/libgmodule-1.2.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libgmodule-1.2.so.0
158 %attr(755,root,root) %{_libdir}/libgthread-1.2.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libgthread-1.2.so.0
160
161 %files devel
162 %defattr(644,root,root,755)
163 %doc glib/*.html
164 %attr(755,root,root) %{_bindir}/glib-config
165 %attr(755,root,root) %{_libdir}/libglib.so
166 %attr(755,root,root) %{_libdir}/libgmodule.so
167 %attr(755,root,root) %{_libdir}/libgthread.so
168 %{_libdir}/libglib.la
169 %{_libdir}/libgmodule.la
170 %{_libdir}/libgthread.la
171 %{_libdir}/glib
172 %{_includedir}/glib-1.2
173 %{_pkgconfigdir}/glib.pc
174 %{_pkgconfigdir}/gmodule.pc
175 %{_pkgconfigdir}/gthread.pc
176 %{_aclocaldir}/glib.m4
177 %{_infodir}/glib.info*
178 %{_mandir}/man1/glib-config.1*
179
180 %if %{with static_libs}
181 %files static
182 %defattr(644,root,root,755)
183 %{_libdir}/libglib.a
184 %{_libdir}/libgmodule.a
185 %{_libdir}/libgthread.a
186 %endif
This page took 0.05244 seconds and 2 git commands to generate.