]> git.pld-linux.org Git - packages/glade.git/blob - glade.spec
dcebee2bd70e7891701202ac61359014cd23ee07
[packages/glade.git] / glade.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        User interface builder for GTK+ and GNOME
7 Summary(pl.UTF-8):      Budowniczy interfejsów użytkownika dla GTK+ i GNOME
8 Name:           glade
9 Version:        3.22.2
10 Release:        1
11 License:        GPL v2+ and LGPL v2.1+
12 Group:          X11/Applications
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/glade/3.22/%{name}-%{version}.tar.xz
14 # Source0-md5:  c074fa378c8f1ad80d20133c4ae6f42d
15 URL:            https://glade.gnome.org/
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  glib2-devel >= 1:2.54.0
20 BuildRequires:  gnome-common
21 BuildRequires:  gobject-introspection-devel >= 1.32.0
22 BuildRequires:  gtk+3-devel >= 3.20.0
23 BuildRequires:  gtk-doc >= 1.13
24 BuildRequires:  gtk-webkit4-devel >= 2.12.0
25 BuildRequires:  intltool >= 0.41.0
26 BuildRequires:  libtool >= 2:2.2.6
27 BuildRequires:  libxml2-devel >= 2.4.0
28 BuildRequires:  libxslt-progs
29 BuildRequires:  pkgconfig
30 BuildRequires:  python-devel >= 2
31 BuildRequires:  python-pygobject3-devel >= 3.8.0
32 BuildRequires:  rpmbuild(find_lang) >= 1.23
33 BuildRequires:  rpmbuild(macros) >= 1.311
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  xz
36 BuildRequires:  yelp-tools
37 Requires(post,postun):  gtk-update-icon-cache
38 Requires(post,postun):  desktop-file-utils
39 Requires:       %{name}-libs = %{version}-%{release}
40 Requires:       hicolor-icon-theme
41 Conflicts:      glade3 < 3.8.2
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Glade is a RAD tool to enable quick & easy development of user
46 interfaces for the GTK+ toolkit and the GNOME desktop environment.
47
48 The user interfaces designed in Glade are saved as XML, and by using
49 the GtkBuilder GTK+ object these can be loaded by applications
50 dynamically as needed.
51
52 By using GtkBuilder, Glade XML files can be used in numerous
53 programming languages including C, C++, C#, Vala, Java, Perl, Python
54 and others.
55
56 %description -l pl.UTF-8
57 Glade jest narzędziem typu RAD (Rapid Application Development) do
58 szybkiego i wygodnego tworzenia interfejsów użytkownika opartych o
59 bibliotekę GTK+ i środowisko GNOME.
60
61 Interfejsy użytkownika zaprojektowane w Glade są zapisywane w formacie
62 XML i poprzez użycie obiektu GtkBuilder, z biblioteki GTK+, mogą być
63 dynamicznie ładowane przez aplikacje.
64
65 Poprzez użycie GtkBuilder, pliki XML Glade mogą być używane w licznych
66 językach programowania, włączając C, C++, C#, Vala, Java, Perl, Python
67 i inne.
68
69 %package libs
70 Summary:        Glade library
71 Summary(pl.UTF-8):      Biblioteka Glade
72 Group:          X11/Libraries
73 Requires:       glib2 >= 1:2.54.0
74 Requires:       gtk+3 >= 3.20.0
75 Requires:       libxml2 >= 2.4.0
76
77 %description libs
78 Glade library.
79
80 %description libs -l pl.UTF-8
81 Biblioteka Glade.
82
83 %package devel
84 Summary:        Header files for Glade library
85 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Glade
86 Group:          X11/Development/Libraries
87 Requires:       %{name}-libs = %{version}-%{release}
88 Requires:       gtk+3-devel >= 3.20.0
89 Requires:       libxml2-devel >= 2.4.0
90
91 %description devel
92 Header files for Glade library.
93
94 %description devel -l pl.UTF-8
95 Pliki nagłówkowe biblioteki Glade.
96
97 %package static
98 Summary:        Static Glade library
99 Summary(pl.UTF-8):      Statyczna biblioteka Glade
100 Group:          X11/Development/Libraries
101 Requires:       %{name}-devel = %{version}-%{release}
102
103 %description static
104 Static Glade library.
105
106 %description static -l pl.UTF-8
107 Statyczna biblioteka Glade.
108
109 %package apidocs
110 Summary:        Glade API documentation
111 Summary(pl.UTF-8):      Dokumentacja API biblioteki Glade
112 Group:          Documentation
113 Requires:       gtk-doc-common
114 %if "%{_rpmversion}" >= "5"
115 BuildArch:      noarch
116 %endif
117
118 %description apidocs
119 Glade API documentation.
120
121 %description apidocs -l pl.UTF-8
122 Dokumentacja API biblioteki Glade.
123
124 %prep
125 %setup -q
126
127 %build
128 %{__intltoolize}
129 %{__libtoolize}
130 %{__aclocal} -I m4
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 %configure \
135         --disable-silent-rules \
136         %{__enable_disable apidocs gtk-doc} \
137         %{__enable_disable static_libs static} \
138         --with-html-dir=%{_gtkdocdir}
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 %{__rm} $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.{a,la}
148
149 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
150
151 %find_lang %{name} --with-gnome
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post
157 %update_icon_cache hicolor
158 %update_desktop_database_post
159
160 %postun
161 %update_icon_cache hicolor
162 %update_desktop_database_postun
163
164 %post   libs -p /sbin/ldconfig
165 %postun libs -p /sbin/ldconfig
166
167 %files -f %{name}.lang
168 %defattr(644,root,root,755)
169 # NOTE: COPYING contains general notes; full GPL and LGPL texts are in COPYING.{GPL,LGPL}
170 %doc AUTHORS COPYING ChangeLog NEWS README TODO
171 %attr(755,root,root) %{_bindir}/glade
172 %attr(755,root,root) %{_bindir}/glade-previewer
173 %dir %{_libdir}/glade
174 %dir %{_libdir}/glade/modules
175 %attr(755,root,root) %{_libdir}/glade/modules/libgladegtk.so
176 %attr(755,root,root) %{_libdir}/glade/modules/libgladepython.so
177 %attr(755,root,root) %{_libdir}/glade/modules/libgladewebkit2gtk.so
178 %{_datadir}/glade
179 %{_desktopdir}/glade.desktop
180 %{_iconsdir}/hicolor/*x*/apps/glade.png
181 %{_iconsdir}/hicolor/scalable/apps/*.svg
182 %{_datadir}/metainfo/glade.appdata.xml
183 %{_mandir}/man1/glade-previewer.1*
184 %{_mandir}/man1/glade.1*
185
186 %files libs
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/libgladeui-2.so.*.*.*
189 %attr(755,root,root) %ghost %{_libdir}/libgladeui-2.so.6
190 %{_libdir}/girepository-1.0/Gladeui-2.0.typelib
191
192 %files devel
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/libgladeui-2.so
195 %{_datadir}/gir-1.0/Gladeui-2.0.gir
196 %{_includedir}/libgladeui-2.0
197 %{_pkgconfigdir}/gladeui-2.0.pc
198
199 %if %{with static_libs}
200 %files static
201 %defattr(644,root,root,755)
202 %{_libdir}/libgladeui-2.a
203 %endif
204
205 %if %{with apidocs}
206 %files apidocs
207 %defattr(644,root,root,755)
208 %{_gtkdocdir}/gladeui-2
209 %endif
This page took 0.360943 seconds and 2 git commands to generate.