]> git.pld-linux.org Git - packages/glade.git/blob - glade.spec
c5479ef0a5d8f8d848051fb87d43a30ee89a97c6
[packages/glade.git] / glade.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        User interface builder for GTK+ and GNOME
7 Summary(pl.UTF-8):      Budowniczy interfejsów użytkownika dla GTK+ i GNOME
8 Name:           glade
9 Version:        3.40.0
10 Release:        1
11 License:        GPL v2+ and LGPL v2.1+
12 Group:          X11/Applications
13 Source0:        https://download.gnome.org/sources/glade/3.40/%{name}-%{version}.tar.xz
14 # Source0-md5:  39393a82949a945d09105d35421c29ce
15 URL:            https://glade.gnome.org/
16 BuildRequires:  gettext-devel >= 0.19.8
17 BuildRequires:  gjs-devel >= 1.64.0
18 BuildRequires:  glib2-devel >= 1:2.64.0
19 BuildRequires:  gobject-introspection-devel >= 1.32.0
20 BuildRequires:  gtk+3-devel >= 3.24.0
21 BuildRequires:  gtk-doc >= 1.13
22 BuildRequires:  gtk-webkit4-devel >= 2.28
23 BuildRequires:  libxml2-devel >= 2.4.0
24 BuildRequires:  libxslt-progs
25 BuildRequires:  meson >= 0.49.0
26 BuildRequires:  ninja >= 1.5
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-devel >= 2
29 BuildRequires:  python-pygobject3-devel >= 3.8.0
30 BuildRequires:  rpm-build >= 4.6
31 BuildRequires:  rpmbuild(find_lang) >= 1.23
32 BuildRequires:  rpmbuild(macros) >= 1.752
33 BuildRequires:  sed >= 4.0
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  xz
36 BuildRequires:  yelp-tools
37 Requires(post,postun):  gtk-update-icon-cache
38 Requires(post,postun):  desktop-file-utils
39 Requires:       %{name}-libs = %{version}-%{release}
40 Requires:       gjs >= 1.64.0
41 Requires:       gtk-webkit4 >= 2.28
42 Requires:       hicolor-icon-theme
43 Conflicts:      glade3 < 3.8.2
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Glade is a RAD tool to enable quick & easy development of user
48 interfaces for the GTK+ toolkit and the GNOME desktop environment.
49
50 The user interfaces designed in Glade are saved as XML, and by using
51 the GtkBuilder GTK+ object these can be loaded by applications
52 dynamically as needed.
53
54 By using GtkBuilder, Glade XML files can be used in numerous
55 programming languages including C, C++, C#, Vala, Java, Perl, Python
56 and others.
57
58 %description -l pl.UTF-8
59 Glade jest narzędziem typu RAD (Rapid Application Development) do
60 szybkiego i wygodnego tworzenia interfejsów użytkownika opartych o
61 bibliotekę GTK+ i środowisko GNOME.
62
63 Interfejsy użytkownika zaprojektowane w Glade są zapisywane w formacie
64 XML i poprzez użycie obiektu GtkBuilder, z biblioteki GTK+, mogą być
65 dynamicznie ładowane przez aplikacje.
66
67 Poprzez użycie GtkBuilder, pliki XML Glade mogą być używane w licznych
68 językach programowania, włączając C, C++, C#, Vala, Java, Perl, Python
69 i inne.
70
71 %package libs
72 Summary:        Glade library
73 Summary(pl.UTF-8):      Biblioteka Glade
74 Group:          X11/Libraries
75 Requires:       glib2 >= 1:2.64.0
76 Requires:       gtk+3 >= 3.24.0
77 Requires:       libxml2 >= 2.4.0
78
79 %description libs
80 Glade library.
81
82 %description libs -l pl.UTF-8
83 Biblioteka Glade.
84
85 %package devel
86 Summary:        Header files for Glade library
87 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Glade
88 Group:          X11/Development/Libraries
89 Requires:       %{name}-libs = %{version}-%{release}
90 Requires:       glib2-devel >= 1:2.64.0
91 Requires:       gtk+3-devel >= 3.24.0
92 Requires:       libxml2-devel >= 2.4.0
93
94 %description devel
95 Header files for Glade library.
96
97 %description devel -l pl.UTF-8
98 Pliki nagłówkowe biblioteki Glade.
99
100 %package static
101 Summary:        Static Glade library
102 Summary(pl.UTF-8):      Statyczna biblioteka Glade
103 Group:          X11/Development/Libraries
104 Requires:       %{name}-devel = %{version}-%{release}
105
106 %description static
107 Static Glade library.
108
109 %description static -l pl.UTF-8
110 Statyczna biblioteka Glade.
111
112 %package apidocs
113 Summary:        Glade API documentation
114 Summary(pl.UTF-8):      Dokumentacja API biblioteki Glade
115 Group:          Documentation
116 Requires:       gtk-doc-common
117 BuildArch:      noarch
118
119 %description apidocs
120 Glade API documentation.
121
122 %description apidocs -l pl.UTF-8
123 Dokumentacja API biblioteki Glade.
124
125 %prep
126 %setup -q
127
128 %if %{with static_libs}
129 %{__sed} -i -e '/^libgladeui = / s/shared_library/library/' gladeui/meson.build
130 %endif
131
132 %build
133 %meson build \
134         -Dgladeui=true \
135         %{?with_apidocs:-Dgtk_doc=true}
136
137 %ninja_build -C build
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %ninja_install -C build
143
144 %find_lang %{name} --with-gnome
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 %update_icon_cache hicolor
151 %update_desktop_database_post
152
153 %postun
154 %update_icon_cache hicolor
155 %update_desktop_database_postun
156
157 %post   libs -p /sbin/ldconfig
158 %postun libs -p /sbin/ldconfig
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 # NOTE: COPYING contains general notes; full GPL and LGPL texts are in COPYING.{GPL,LGPL}
163 %doc AUTHORS COPYING MAINTAINERS NEWS TODO
164 %attr(755,root,root) %{_bindir}/glade
165 %attr(755,root,root) %{_bindir}/glade-previewer
166 %dir %{_libdir}/glade
167 %dir %{_libdir}/glade/modules
168 %attr(755,root,root) %{_libdir}/glade/modules/libgladegjs.so
169 %attr(755,root,root) %{_libdir}/glade/modules/libgladeglade.so
170 %attr(755,root,root) %{_libdir}/glade/modules/libgladegtk.so
171 %attr(755,root,root) %{_libdir}/glade/modules/libgladepython.so
172 %attr(755,root,root) %{_libdir}/glade/modules/libgladewebkit2gtk.so
173 %{_datadir}/glade
174 %{_datadir}/gettext/its/glade-catalog.its
175 %{_datadir}/gettext/its/glade-catalog.loc
176 %{_desktopdir}/org.gnome.Glade.desktop
177 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Glade.svg
178 %{_iconsdir}/hicolor/symbolic/apps/glade-brand-symbolic.svg
179 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Glade-symbolic.svg
180 %{_datadir}/metainfo/org.gnome.Glade.appdata.xml
181 %{_mandir}/man1/glade-previewer.1*
182 %{_mandir}/man1/glade.1*
183
184 %files libs
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/libgladeui-2.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libgladeui-2.so.13
188 %{_libdir}/girepository-1.0/Gladeui-2.0.typelib
189
190 %files devel
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/libgladeui-2.so
193 %{_datadir}/gir-1.0/Gladeui-2.0.gir
194 %{_includedir}/libgladeui-2.0
195 %{_pkgconfigdir}/gladeui-2.0.pc
196
197 %if %{with static_libs}
198 %files static
199 %defattr(644,root,root,755)
200 %{_libdir}/libgladeui-2.a
201 %endif
202
203 %if %{with apidocs}
204 %files apidocs
205 %defattr(644,root,root,755)
206 %{_gtkdocdir}/gladeui-2
207 %endif
This page took 0.089976 seconds and 2 git commands to generate.