]> git.pld-linux.org Git - packages/glade.git/blob - glade.spec
7e16f24431469fd4eaa0a9ba278d79b816ffa718
[packages/glade.git] / glade.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        User interface builder for GTK+ and GNOME
7 Summary(pl.UTF-8):      Budowniczy interfejsów użytkownika dla GTK+ i GNOME
8 Name:           glade
9 Version:        3.38.2
10 Release:        5
11 License:        GPL v2+ and LGPL v2.1+
12 Group:          X11/Applications
13 Source0:        https://download.gnome.org/sources/glade/3.38/%{name}-%{version}.tar.xz
14 # Source0-md5:  f1ac9d9b6404308efb74adc548289455
15 Patch0:         meson0.61.patch
16 URL:            https://glade.gnome.org/
17 BuildRequires:  gettext-devel >= 0.19.8
18 BuildRequires:  gjs-devel >= 1.64.0
19 BuildRequires:  glib2-devel >= 1:2.64.0
20 BuildRequires:  gobject-introspection-devel >= 1.32.0
21 BuildRequires:  gtk+3-devel >= 3.24.0
22 BuildRequires:  gtk-doc >= 1.13
23 BuildRequires:  gtk-webkit4-devel >= 2.28
24 BuildRequires:  libxml2-devel >= 2.4.0
25 BuildRequires:  libxslt-progs
26 BuildRequires:  meson >= 0.49.0
27 BuildRequires:  ninja >= 1.5
28 BuildRequires:  pkgconfig
29 BuildRequires:  python-devel >= 2
30 BuildRequires:  python-pygobject3-devel >= 3.8.0
31 BuildRequires:  rpm-build >= 4.6
32 BuildRequires:  rpmbuild(find_lang) >= 1.23
33 BuildRequires:  rpmbuild(macros) >= 1.752
34 BuildRequires:  sed >= 4.0
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 BuildRequires:  yelp-tools
38 Requires(post,postun):  gtk-update-icon-cache
39 Requires(post,postun):  desktop-file-utils
40 Requires:       %{name}-libs = %{version}-%{release}
41 Requires:       gjs >= 1.64.0
42 Requires:       gtk-webkit4 >= 2.28
43 Requires:       hicolor-icon-theme
44 Conflicts:      glade3 < 3.8.2
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Glade is a RAD tool to enable quick & easy development of user
49 interfaces for the GTK+ toolkit and the GNOME desktop environment.
50
51 The user interfaces designed in Glade are saved as XML, and by using
52 the GtkBuilder GTK+ object these can be loaded by applications
53 dynamically as needed.
54
55 By using GtkBuilder, Glade XML files can be used in numerous
56 programming languages including C, C++, C#, Vala, Java, Perl, Python
57 and others.
58
59 %description -l pl.UTF-8
60 Glade jest narzędziem typu RAD (Rapid Application Development) do
61 szybkiego i wygodnego tworzenia interfejsów użytkownika opartych o
62 bibliotekę GTK+ i środowisko GNOME.
63
64 Interfejsy użytkownika zaprojektowane w Glade są zapisywane w formacie
65 XML i poprzez użycie obiektu GtkBuilder, z biblioteki GTK+, mogą być
66 dynamicznie ładowane przez aplikacje.
67
68 Poprzez użycie GtkBuilder, pliki XML Glade mogą być używane w licznych
69 językach programowania, włączając C, C++, C#, Vala, Java, Perl, Python
70 i inne.
71
72 %package libs
73 Summary:        Glade library
74 Summary(pl.UTF-8):      Biblioteka Glade
75 Group:          X11/Libraries
76 Requires:       glib2 >= 1:2.64.0
77 Requires:       gtk+3 >= 3.24.0
78 Requires:       libxml2 >= 2.4.0
79
80 %description libs
81 Glade library.
82
83 %description libs -l pl.UTF-8
84 Biblioteka Glade.
85
86 %package devel
87 Summary:        Header files for Glade library
88 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Glade
89 Group:          X11/Development/Libraries
90 Requires:       %{name}-libs = %{version}-%{release}
91 Requires:       glib2-devel >= 1:2.64.0
92 Requires:       gtk+3-devel >= 3.24.0
93 Requires:       libxml2-devel >= 2.4.0
94
95 %description devel
96 Header files for Glade library.
97
98 %description devel -l pl.UTF-8
99 Pliki nagłówkowe biblioteki Glade.
100
101 %package static
102 Summary:        Static Glade library
103 Summary(pl.UTF-8):      Statyczna biblioteka Glade
104 Group:          X11/Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106
107 %description static
108 Static Glade library.
109
110 %description static -l pl.UTF-8
111 Statyczna biblioteka Glade.
112
113 %package apidocs
114 Summary:        Glade API documentation
115 Summary(pl.UTF-8):      Dokumentacja API biblioteki Glade
116 Group:          Documentation
117 Requires:       gtk-doc-common
118 BuildArch:      noarch
119
120 %description apidocs
121 Glade API documentation.
122
123 %description apidocs -l pl.UTF-8
124 Dokumentacja API biblioteki Glade.
125
126 %prep
127 %setup -q
128 %patch0 -p1
129
130 %if %{with static_libs}
131 %{__sed} -i -e '/^libgladeui = / s/shared_library/library/' gladeui/meson.build
132 %endif
133
134 %build
135 %meson build \
136         -Dgladeui=true \
137         %{?with_apidocs:-Dgtk_doc=true}
138
139 %ninja_build -C build
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %ninja_install -C build
145
146 %find_lang %{name} --with-gnome
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post
152 %update_icon_cache hicolor
153 %update_desktop_database_post
154
155 %postun
156 %update_icon_cache hicolor
157 %update_desktop_database_postun
158
159 %post   libs -p /sbin/ldconfig
160 %postun libs -p /sbin/ldconfig
161
162 %files -f %{name}.lang
163 %defattr(644,root,root,755)
164 # NOTE: COPYING contains general notes; full GPL and LGPL texts are in COPYING.{GPL,LGPL}
165 %doc AUTHORS COPYING MAINTAINERS NEWS TODO
166 %attr(755,root,root) %{_bindir}/glade
167 %attr(755,root,root) %{_bindir}/glade-previewer
168 %dir %{_libdir}/glade
169 %dir %{_libdir}/glade/modules
170 %attr(755,root,root) %{_libdir}/glade/modules/libgladegjs.so
171 %attr(755,root,root) %{_libdir}/glade/modules/libgladeglade.so
172 %attr(755,root,root) %{_libdir}/glade/modules/libgladegtk.so
173 %attr(755,root,root) %{_libdir}/glade/modules/libgladepython.so
174 %attr(755,root,root) %{_libdir}/glade/modules/libgladewebkit2gtk.so
175 %{_datadir}/glade
176 %{_datadir}/gettext/its/glade-catalog.its
177 %{_datadir}/gettext/its/glade-catalog.loc
178 %{_desktopdir}/org.gnome.Glade.desktop
179 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Glade.svg
180 %{_iconsdir}/hicolor/symbolic/apps/glade-brand-symbolic.svg
181 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Glade-symbolic.svg
182 %{_datadir}/metainfo/org.gnome.Glade.appdata.xml
183 %{_mandir}/man1/glade-previewer.1*
184 %{_mandir}/man1/glade.1*
185
186 %files libs
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/libgladeui-2.so.*.*.*
189 %attr(755,root,root) %ghost %{_libdir}/libgladeui-2.so.13
190 %{_libdir}/girepository-1.0/Gladeui-2.0.typelib
191
192 %files devel
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/libgladeui-2.so
195 %{_datadir}/gir-1.0/Gladeui-2.0.gir
196 %{_includedir}/libgladeui-2.0
197 %{_pkgconfigdir}/gladeui-2.0.pc
198
199 %if %{with static_libs}
200 %files static
201 %defattr(644,root,root,755)
202 %{_libdir}/libgladeui-2.a
203 %endif
204
205 %if %{with apidocs}
206 %files apidocs
207 %defattr(644,root,root,755)
208 %{_gtkdocdir}/gladeui-2
209 %endif
This page took 0.036604 seconds and 2 git commands to generate.