]> git.pld-linux.org Git - packages/gjs.git/blob - gjs.spec
- up to 1.65.1
[packages/gjs.git] / gjs.spec
1 #
2 # Conditional build:
3 %bcond_without  sysprof         # sysprof profiling
4 %bcond_without  systemtap       # systemtap/dtrace trace support
5 #
6 Summary:        JavaScript bindings for GNOME
7 Summary(pl.UTF-8):      Wiązania JavaScriptu dla GNOME
8 Name:           gjs
9 Version:        1.65.1
10 Release:        1
11 License:        MIT and (MPL v1.1 or GPL v2+ or LGPL v2+)
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gjs/1.65/%{name}-%{version}.tar.xz
14 # Source0-md5:  5f002a489eb2bd6ad39b07294f7142ae
15 URL:            https://wiki.gnome.org/Projects/Gjs
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11.1
18 BuildRequires:  cairo-devel
19 BuildRequires:  cairo-gobject-devel
20 BuildRequires:  gettext-tools
21 BuildRequires:  glib2-devel >= 1:2.58.0
22 BuildRequires:  gobject-introspection-devel >= 1.41.4
23 BuildRequires:  libffi-devel
24 BuildRequires:  libstdc++-devel >= 6:5.0
25 BuildRequires:  libtool >= 2:2.2.0
26 BuildRequires:  mozjs68-devel >= 68
27 BuildRequires:  pkgconfig
28 BuildRequires:  readline-devel
29 # pkgconfig(sysprof-capture-3)
30 %{?with_sysprof:BuildRequires:  sysprof-devel >= 3.34}
31 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 Requires:       glib2 >= 1:2.58.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Gjs allows using GNOME libraries from JavaScript. It is mainly based
39 on Spidermonkey JavaScript engine and the GObject introspection
40 framework.
41
42 %description -l pl.UTF-8
43 Gjs pozwala używać bibliotek GNOME z JavaScriptem. Jest oparty głównie
44 na silniku JavaScriptu Spidermonkey i systemie GObject introspection.
45
46 %package devel
47 Summary:        Header files for gjs library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gjs
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       cairo-devel
52 Requires:       cairo-gobject-devel
53 Requires:       glib2-devel >= 1:2.58.0
54 Requires:       gobject-introspection-devel >= 1.41.4
55 Requires:       libffi-devel
56 Requires:       mozjs60-devel >= 60
57
58 %description devel
59 Header files for gjs library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki gjs.
63
64 %package -n systemtap-gjs
65 Summary:        systemtap/dtrace probes for gjs
66 Summary(pl.UTF-8):      Sondy systemtap/dtrace dla gjs
67 Group:          Development/Tools
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       systemtap-client
70
71 %description -n systemtap-gjs
72 systemtap/dtrace probes for gjs.
73
74 %description -n systemtap-gjs -l pl.UTF-8
75 Sondy systemtap/dtrace dla gjs.
76
77 %prep
78 %setup -q
79
80 %build
81 %meson build \
82         -Dprofiler=%{?with_sysprof:enabled}%{!?with_sysprof:disabled} \
83         -Dsystemtap=%{__true_false systemtap} \
84         -Ddtrace=%{__true_false systemtap}
85
86 %ninja_build -C build
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
91
92 %ninja_install -C build
93
94 cp -p examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
95
96 # belongs to installed-tests
97 %{__rm} $RPM_BUILD_ROOT%{_datadir}/glib-2.0/schemas/org.gnome.GjsTest.gschema.xml
98 %{__rm} -r $RPM_BUILD_ROOT{%{_datadir},%{_libexecdir}/gjs}/installed-tests
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc COPYING NEWS README.md
109 %attr(755,root,root) %{_bindir}/gjs
110 %attr(755,root,root) %{_bindir}/gjs-console
111 %attr(755,root,root) %{_libdir}/libgjs.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libgjs.so.0
113 %dir %{_libdir}/gjs
114 %dir %{_libdir}/gjs/girepository-1.0
115 %{_libdir}/gjs/girepository-1.0/GjsPrivate-1.0.typelib
116 %{_datadir}/gjs-1.0
117
118 %files devel
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_libdir}/libgjs.so
121 %{_includedir}/gjs-1.0
122 %{_pkgconfigdir}/gjs-1.0.pc
123 %{_examplesdir}/%{name}-%{version}
124
125 %files -n systemtap-gjs
126 %defattr(644,root,root,755)
127 %{_datadir}/systemtap/tapset/gjs.stp
This page took 0.061029 seconds and 3 git commands to generate.