]> git.pld-linux.org Git - packages/git-annex.git/blob - git-annex.spec
Work on BR/R
[packages/git-annex.git] / git-annex.spec
1 Summary:        Manage files with git, without checking in their contents
2 Name:           git-annex
3 Version:        4.20130501.1
4 Release:        0.1
5 License:        GPL v3
6 Group:          Applications/Archiving
7 URL:            http://git-annex.branchable.com/
8 Source0:        http://hackage.haskell.org/packages/archive/git-annex/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  59026597f8ef9575998cbab0fafe8416
10 BuildRequires:  ghc >= 7.4
11 BuildRequires:  ghc-IfElse
12 BuildRequires:  ghc-extensible-exceptions
13 BuildRequires:  ghc-MissingH
14 BuildRequires:  ghc-QuickCheck
15 BuildRequires:  ghc-dataenc
16 BuildRequires:  ghc-monad-control
17 #BuildRequires: ghc-pcre-light
18 BuildRequires:  ghc-utf8-string
19 BuildRequires:  libuuid
20 Requires:       findutils
21 Requires:       findutils
22 Requires:       git-core
23 Requires:       git-core
24 Requires:       libuuid
25 Requires:       rsync
26 Requires:       rsync
27 Suggests:       curl
28 Suggests:       gnu-gpg
29 Suggests:       lsof
30 Suggests:       nss-mdns
31 Suggests:       sha1sum
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 git-annex allows managing files with git, without checking the file
36 contents into git. While that may seem paradoxical, it is useful when
37 dealing with files larger than git can currently easily handle,
38 whether due to limitations in memory, checksumming time, or disk
39 space.
40
41 Even without file content tracking, being able to manage files with
42 git, move files around and delete files with versioned directory
43 trees, and use branches and distributed clones, are all very handy
44 reasons to use git. And annexed files can co-exist in the same git
45 repository with regularly versioned files, which is convenient for
46 maintaining documents, Makefiles, etc that are associated with annexed
47 files but that benefit from full revision control.
48
49 When a file is annexed, its content is moved into a key-value store,
50 and a symlink is made that points to the content. These symlinks are
51 checked into git and versioned like regular files. You can move them
52 around, delete them, and so on. Pushing to another git repository will
53 make git-annex there aware of the annexed file, and it can be used to
54 retrieve its content from the key-value store.
55
56 %prep
57 %setup -q
58 #%setup -qc
59 #mv %{name}-*/* .
60
61 %build
62 %{__make}
63 #%{__make} docs
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %attr(755,root,root) %{_bindir}/%{name}
76 %attr(755,root,root) %{_bindir}/%{name}-shell
77 %{_mandir}/man1/%{name}.1*
78 %{_mandir}/man1/%{name}-shell.1*
This page took 0.064651 seconds and 3 git commands to generate.