]> git.pld-linux.org Git - packages/gi-docgen.git/blob - gi-docgen.spec
ebdeb9a25199db67789493538413cb79a14277ce
[packages/gi-docgen.git] / gi-docgen.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4
5 Summary:        Documentation tool for GObject-based libraries
6 Summary(pl.UTF-8):      Narzędzie do dokumentowania bibliotek opartych na GObject
7 Name:           gi-docgen
8 Version:        2022.2
9 Release:        1
10 License:        Apache v2.0 or GPL v3+
11 Group:          Development/Tools
12 Source0:        https://download.gnome.org/sources/gi-docgen/2022/%{name}-%{version}.tar.xz
13 # Source0-md5:  577c24a2cb1dcc47ce78db310eb4769c
14 URL:            https://gitlab.gnome.org/GNOME/gi-docgen
15 BuildRequires:  python3-modules >= 1:3.6
16 BuildRequires:  python3-setuptools
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 BuildRequires:  sed >= 4.0
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 %if %{with doc}
23 BuildRequires:  python3-Sphinx
24 BuildRequires:  python3-jinja2
25 BuildRequires:  python3-markdown >= 3.2
26 BuildRequires:  python3-markupsafe
27 BuildRequires:  python3-pygments
28 BuildRequires:  python3-sphinx_rtd_theme
29 BuildRequires:  python3-toml
30 BuildRequires:  python3-typogrify
31 %endif
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 GI-Docgen is a document generator for GObject-based libraries. GObject
37 is the base type system of the GNOME project. GI-Docgen reuses the
38 introspection data generated by GObject-based libraries to generate
39 the API reference of these libraries, as well as other ancillary
40 documentation.
41
42 %description -l pl.UTF-8
43 GI-Docgen to generator dokumentacji do bibliotek opartych na
44 bibliotece GObject. GObject to bazowy system typów projektu GNOME.
45 GI-Docgen wykorzystuje dane introspekcji wygenerowane przez biblioteki
46 oparte na GObject w celu wygenerowania dokumentacji API bibliotek, a
47 także innej, dodatkowej dokumentacji.
48
49 %package doc
50 Summary:        Documentation for GI-Docgen tool
51 Summary(pl.UTF-8):      Dokumentacja do narzędzia GI-Docgen
52 Group:          Documentation
53
54 %description doc
55 Documentation for GI-Docgen tool.
56
57 %description doc -l pl.UTF-8
58 Dokumentacja do narzędzia GI-Docgen.
59
60 %prep
61 %setup -q
62
63 %build
64 %py3_build
65
66 %if %{with doc}
67 %{__make} -C docs
68 %endif
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %py3_install
74
75 install -d $RPM_BUILD_ROOT%{_npkgconfigdir}
76 cat >$RPM_BUILD_ROOT%{_npkgconfigdir}/gi-docgen.pc <<EOF
77 prefix=%{_prefix}
78 bindir=%{_bindir}
79
80 EOF
81
82 sed -e 's/@VERSION@/%{version}/' gi-docgen.pc.in >>$RPM_BUILD_ROOT%{_npkgconfigdir}/gi-docgen.pc
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc README.md
90 %attr(755,root,root) %{_bindir}/gi-docgen
91 %{py3_sitescriptdir}/gidocgen
92 %{py3_sitescriptdir}/gi_docgen-%{version}-py*.egg-info
93 %{_npkgconfigdir}/gi-docgen.pc
94 %{_mandir}/man1/gi-docgen.1*
95
96 %if %{with doc}
97 %files doc
98 %defattr(644,root,root,755)
99 %doc docs/_build/{_static,tools,*.html,*.js}
100 %endif
This page took 0.054209 seconds and 2 git commands to generate.