]> git.pld-linux.org Git - packages/gi-docgen.git/blob - gi-docgen.spec
- added main patch (fix execution via egg entry_point)
[packages/gi-docgen.git] / gi-docgen.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4
5 Summary:        Documentation tool for GObject-based libraries
6 Summary(pl.UTF-8):      Narzędzie do dokumentowania bibliotek opartych na GObject
7 Name:           gi-docgen
8 Version:        2021.2
9 Release:        1
10 License:        Apache v2.0 or GPL v3+
11 Group:          Development/Tools
12 #Source0Download: https://gitlab.gnome.org/ebassi/gi-docgen/-/tags
13 Source0:        https://gitlab.gnome.org/ebassi/gi-docgen/-/archive/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  d8c01aacbaefe8df4ffc9f8c67e51f21
15 Patch0:         %{name}-main.patch
16 URL:            https://gitlab.gnome.org/ebassi/gi-docgen
17 BuildRequires:  python3-modules >= 1:3.6
18 BuildRequires:  python3-setuptools
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 BuildRequires:  sed >= 4.0
22 %if %{with doc}
23 BuildRequires:  python3-Sphinx
24 BuildRequires:  python3-jinja2
25 BuildRequires:  python3-markdown
26 BuildRequires:  python3-markupsafe
27 BuildRequires:  python3-pygments
28 BuildRequires:  python3-sphinx_rtd_theme
29 BuildRequires:  python3-toml
30 BuildRequires:  python3-typogrify
31 %endif
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 GI-Docgen is a document generator for GObject-based libraries. GObject
37 is the base type system of the GNOME project. GI-Docgen reuses the
38 introspection data generated by GObject-based libraries to generate
39 the API reference of these libraries, as well as other ancillary
40 documentation.
41
42 %description -l pl.UTF-8
43 GI-Docgen to generator dokumentacji do bibliotek opartych na
44 bibliotece GObject. GObject to bazowy system typów projektu GNOME.
45 GI-Docgen wykorzystuje dane introspekcji wygenerowane przez biblioteki
46 oparte na GObject w celu wygenerowania dokumentacji API bibliotek, a
47 także innej, dodatkowej dokumentacji.
48
49 %package doc
50 Summary:        Documentation for GI-Docgen tool
51 Summary(pl.UTF-8):      Dokumentacja do narzędzia GI-Docgen
52 Group:          Documentation
53
54 %description doc
55 Documentation for GI-Docgen tool.
56
57 %description doc -l pl.UTF-8
58 Dokumentacja do narzędzia GI-Docgen.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63
64 %{__sed} -i -e '/^ *wheel$/d' setup.cfg
65
66 %build
67 %py3_build
68
69 %if %{with doc}
70 %{__make} -C docs
71 %endif
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %py3_install
77
78 install -d $RPM_BUILD_ROOT%{_npkgconfigdir}
79 cat >$RPM_BUILD_ROOT%{_npkgconfigdir}/gi-docgen.pc <<EOF
80 prefix=%{_prefix}
81 bindir=%{_bindir}
82
83 Name: gi-docgen
84 Description: Documentation tool for GObject-based libraries
85 Version: %{version}
86 EOF
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc README.md
94 %attr(755,root,root) %{_bindir}/gi-docgen
95 %{py3_sitescriptdir}/gidocgen
96 %{py3_sitescriptdir}/gi_docgen-%{version}-py*.egg-info
97 %{_npkgconfigdir}/gi-docgen.pc
98
99 %files doc
100 %defattr(644,root,root,755)
101 %doc docs/_build/{_static,tools,*.html,*.js}
This page took 0.026994 seconds and 3 git commands to generate.