]> git.pld-linux.org Git - packages/ghc-xmonad-contrib.git/blob - ghc-xmonad-contrib.spec
ff905b8affcebe39df86f08df169f2817b8fd1d9
[packages/ghc-xmonad-contrib.git] / ghc-xmonad-contrib.spec
1 %define         pkgname xmonad-contrib
2 Summary:        Third party extensions for xmonad
3 Name:           ghc-%{pkgname}
4 Version:        0.11.4
5 Release:        1
6 License:        BSD
7 Group:          Development/Languages
8 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
9 # Source0-md5:  a41c886280a5414105c1cf241f0fd2f4
10 Patch0:         applicative.patch
11 URL:            http://www.xmonad.org
12 BuildRequires:  ghc >= 6.12.3
13 BuildRequires:  ghc-X11 >= 1.6
14 BuildRequires:  ghc-extensible-exceptions
15 BuildRequires:  ghc-mtl
16 BuildRequires:  ghc-random
17 BuildRequires:  ghc-utf8-string
18 BuildRequires:  rpmbuild(macros) >= 1.608
19 BuildRequires:  xmonad >= 0.11
20 %requires_eq    ghc
21 Requires:       ghc-X11 >= 1.6
22 Requires:       ghc-extensible-exceptions
23 Requires:       ghc-mtl
24 Requires:       ghc-random
25 Requires:       ghc-utf8-string
26 Requires:       xmonad >= 0.11
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # debuginfo is not useful for ghc
30 %define         _enable_debug_packages  0
31
32 %description
33 Third party extensions for xmonad.
34
35 %package doc
36 Summary:        HTML documentation for %{pkgname}
37 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
38 Group:          Documentation
39
40 %description doc
41 HTML documentation for %{pkgname}.
42
43 %description doc -l pl.UTF-8
44 Dokumentacja w formacie HTML dla %{pkgname}.
45
46 %prep
47 %setup -q -n %{pkgname}-%{version}
48 %patch0 -p1
49
50 %build
51 runhaskell Setup.lhs configure -v2 \
52         --prefix=%{_prefix} \
53         --libdir=%{_libdir} \
54         --libexecdir=%{_libexecdir} \
55         --docdir=%{_docdir}/%{name}-%{version}
56
57 runhaskell Setup.lhs build
58 runhaskell Setup.lhs haddock --executables
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
63
64 runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
65
66 # work around automatic haddock docs installation
67 rm -rf %{name}-%{version}-doc
68 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
69 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
70
71 runhaskell Setup.lhs register \
72         --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 %ghc_pkg_recache
79
80 %postun
81 %ghc_pkg_recache
82
83 %files
84 %defattr(644,root,root,755)
85 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
86 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
87
88 %files doc
89 %defattr(644,root,root,755)
90 %doc %{name}-%{version}-doc/*
This page took 0.065818 seconds and 2 git commands to generate.