]> git.pld-linux.org Git - packages/ghc-x509-validation.git/blob - ghc-x509-validation.spec
rebuild with ghc 8.10.7
[packages/ghc-x509-validation.git] / ghc-x509-validation.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname x509-validation
6 Summary:        X.509 Certificate and CRL validation
7 Name:           ghc-%{pkgname}
8 Version:        1.6.11
9 Release:        2
10 License:        BSD
11 Group:          Development/Languages
12 #Source0Download: http://hackage.haskell.org/package/x509-validation
13 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14 # Source0-md5:  e63bf32c356ee351348dc5e727bae6e7
15 URL:            http://hackage.haskell.org/package/x509-validation
16 BuildRequires:  ghc >= 6.12.3
17 BuildRequires:  ghc-asn1-encoding
18 BuildRequires:  ghc-asn1-types
19 BuildRequires:  ghc-cryptonite >= 0.24
20 BuildRequires:  ghc-data-default-class
21 BuildRequires:  ghc-hourglass
22 BuildRequires:  ghc-memory
23 BuildRequires:  ghc-pem >= 0.1
24 BuildRequires:  ghc-x509 >= 1.7.5
25 BuildRequires:  ghc-x509-store >= 1.6
26 %if %{with prof}
27 BuildRequires:  ghc-prof
28 BuildRequires:  ghc-asn1-encoding-prof
29 BuildRequires:  ghc-asn1-types-prof
30 BuildRequires:  ghc-cryptonite-prof >= 0.24
31 BuildRequires:  ghc-data-default-class-prof
32 BuildRequires:  ghc-hourglass-prof
33 BuildRequires:  ghc-memory-prof
34 BuildRequires:  ghc-pem-prof >= 0.1
35 BuildRequires:  ghc-x509-prof >= 1.7.5
36 BuildRequires:  ghc-x509-store-prof >= 1.6
37 %endif
38 BuildRequires:  rpmbuild(macros) >= 1.608
39 %requires_eq    ghc
40 Requires(post,postun):  /usr/bin/ghc-pkg
41 Requires:       ghc-asn1-encoding
42 Requires:       ghc-asn1-types
43 Requires:       ghc-cryptonite >= 0.24
44 Requires:       ghc-data-default-class
45 Requires:       ghc-hourglass
46 Requires:       ghc-memory
47 Requires:       ghc-pem >= 0.1
48 Requires:       ghc-x509 >= 1.7.5
49 Requires:       ghc-x509-store >= 1.6
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 # debuginfo is not useful for ghc
53 %define         _enable_debug_packages  0
54
55 # don't compress haddock files
56 %define         _noautocompressdoc      *.haddock
57
58 %description
59
60 %package prof
61 Summary:        Profiling %{pkgname} library for GHC
62 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       ghc-asn1-encoding-prof
66 Requires:       ghc-asn1-types-prof
67 Requires:       ghc-cryptonite-prof >= 0.24
68 Requires:       ghc-data-default-class-prof
69 Requires:       ghc-hourglass-prof
70 Requires:       ghc-memory-prof
71 Requires:       ghc-pem-prof >= 0.1
72 Requires:       ghc-x509-prof >= 1.7.5
73 Requires:       ghc-x509-store-prof >= 1.6
74
75 %description prof
76 Profiling %{pkgname} library for GHC.  Should be installed when
77 GHC's profiling subsystem is needed.
78
79 %description prof -l pl.UTF-8
80 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
81 kiedy potrzebujemy systemu profilującego z GHC.
82
83 %prep
84 %setup -q -n %{pkgname}-%{version}
85
86 %build
87 runhaskell Setup.hs configure -v2 \
88         %{?with_prof:--enable-library-profiling} \
89         --prefix=%{_prefix} \
90         --libdir=%{_libdir} \
91         --libexecdir=%{_libexecdir} \
92         --docdir=%{_docdir}/%{name}-%{version}
93
94 runhaskell Setup.hs build
95 runhaskell Setup.hs haddock --executables
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
100
101 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
102
103 # work around automatic haddock docs installation
104 %{__rm} -rf %{name}-%{version}-doc
105 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
106 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
107
108 runhaskell Setup.hs register \
109         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 %ghc_pkg_recache
116
117 %postun
118 %ghc_pkg_recache
119
120 %files
121 %defattr(644,root,root,755)
122 %doc %{name}-%{version}-doc/*
123 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
124 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
125 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
126 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
127 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
128
129 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
130 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/X509
131 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/X509/*.hi
132 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/X509/*.dyn_hi
133 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/X509/Validation
134 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/X509/Validation/*.hi
135 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/X509/Validation/*.dyn_hi
136
137 %if %{with prof}
138 %files prof
139 %defattr(644,root,root,755)
140 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
141 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/X509/*.p_hi
142 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/X509/Validation/*.p_hi
143 %endif
This page took 0.094691 seconds and 3 git commands to generate.