]> git.pld-linux.org Git - packages/ghc-x509-store.git/blob - ghc-x509-store.spec
- new
[packages/ghc-x509-store.git] / ghc-x509-store.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname x509-store
6 Summary:        X.509 collection accessing and storing methods
7 Name:           ghc-%{pkgname}
8 Version:        1.6.7
9 Release:        1
10 License:        BSD
11 Group:          Development/Languages
12 #Source0Download: http://hackage.haskell.org/package/x509-store
13 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14 # Source0-md5:  e314e8ac48dc5a67e952be8194577225
15 URL:            http://hackage.haskell.org/package/x509-store
16 BuildRequires:  ghc >= 6.12.3
17 BuildRequires:  ghc-asn1-encoding
18 BuildRequires:  ghc-asn1-types
19 BuildRequires:  ghc-cryptonite
20 BuildRequires:  ghc-pem >= 0.1
21 BuildRequires:  ghc-x509 >= 1.7.5
22 %if %{with prof}
23 BuildRequires:  ghc-prof
24 BuildRequires:  ghc-asn1-encoding-prof
25 BuildRequires:  ghc-asn1-types-prof
26 BuildRequires:  ghc-cryptonite-prof
27 BuildRequires:  ghc-pem-prof >= 0.1
28 BuildRequires:  ghc-x509-prof >= 1.7.5
29 %endif
30 BuildRequires:  rpmbuild(macros) >= 1.608
31 %requires_eq    ghc
32 Requires(post,postun):  /usr/bin/ghc-pkg
33 Requires:       ghc-asn1-encoding
34 Requires:       ghc-asn1-types
35 Requires:       ghc-cryptonite
36 Requires:       ghc-pem >= 0.1
37 Requires:       ghc-x509 >= 1.7.5
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 # debuginfo is not useful for ghc
41 %define         _enable_debug_packages  0
42
43 # don't compress haddock files
44 %define         _noautocompressdoc      *.haddock
45
46 %description
47 X.509 collection accessing and storing methods for certificate, crl,
48 exception list.
49
50 %package prof
51 Summary:        Profiling %{pkgname} library for GHC
52 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       ghc-asn1-encoding-prof
56 Requires:       ghc-asn1-types-prof
57 Requires:       ghc-cryptonite-prof
58 Requires:       ghc-pem-prof >= 0.1
59 Requires:       ghc-x509-prof >= 1.7.5
60
61 %description prof
62 Profiling %{pkgname} library for GHC.  Should be installed when
63 GHC's profiling subsystem is needed.
64
65 %description prof -l pl.UTF-8
66 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
67 kiedy potrzebujemy systemu profilującego z GHC.
68
69 %prep
70 %setup -q -n %{pkgname}-%{version}
71
72 %build
73 runhaskell Setup.hs configure -v2 \
74         %{?with_prof:--enable-library-profiling} \
75         --prefix=%{_prefix} \
76         --libdir=%{_libdir} \
77         --libexecdir=%{_libexecdir} \
78         --docdir=%{_docdir}/%{name}-%{version}
79
80 runhaskell Setup.hs build
81 runhaskell Setup.hs haddock --executables
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
86
87 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
88
89 # work around automatic haddock docs installation
90 %{__rm} -rf %{name}-%{version}-doc
91 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
92 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
93
94 runhaskell Setup.hs register \
95         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post
101 %ghc_pkg_recache
102
103 %postun
104 %ghc_pkg_recache
105
106 %files
107 %defattr(644,root,root,755)
108 %doc %{name}-%{version}-doc/*
109 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
110 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
111 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
112 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
113 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
114
115 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
116 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/X509
117 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/X509/*.hi
118 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/X509/*.dyn_hi
119
120 %if %{with prof}
121 %files prof
122 %defattr(644,root,root,755)
123 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
124 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/X509/*.p_hi
125 %endif
This page took 0.129396 seconds and 3 git commands to generate.