]> git.pld-linux.org Git - packages/ghc-unordered-containers.git/blob - ghc-unordered-containers.spec
- up to 0.2.10.0
[packages/ghc-unordered-containers.git] / ghc-unordered-containers.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname unordered-containers
6 Summary:        Efficient hashing-based container types
7 Summary(pl.UTF-8):      Typy wydajnych kontenerów opartych na haszowaniu
8 Name:           ghc-%{pkgname}
9 Version:        0.2.10.0
10 Release:        1
11 License:        BSD
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/unordered-containers
14 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  5994101f6b1f19b264dcfdf863f57324
16 Patch0:         hashable-1.3.patch
17 URL:            http://hackage.haskell.org/package/unordered-containers
18 BuildRequires:  ghc >= 6.12.3
19 BuildRequires:  ghc-base >= 4
20 BuildRequires:  ghc-deepseq >= 1.1
21 BuildRequires:  ghc-hashable >= 1.0.1.1
22 %if %{with prof}
23 BuildRequires:  ghc-prof >= 6.12.3
24 BuildRequires:  ghc-base-prof >= 4
25 BuildRequires:  ghc-deepseq-prof >= 1.1
26 BuildRequires:  ghc-hashable-prof >= 1.0.1.1
27 %endif
28 BuildRequires:  rpmbuild(macros) >= 1.608
29 Requires(post,postun):  /usr/bin/ghc-pkg
30 %requires_eq    ghc
31 Requires:       ghc-base >= 4
32 Requires:       ghc-deepseq >= 1.1
33 Requires:       ghc-hashable >= 1.0.1.1
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 # debuginfo is not useful for ghc
37 %define         _enable_debug_packages  0
38
39 # don't compress haddock files
40 %define         _noautocompressdoc      *.haddock
41
42 %description
43 Efficient hashing-based container types. The containers have been
44 optimized for performance critical use, both in terms of large data
45 quantities and high speed.
46
47 %description -l pl.UTF-8
48 Typy wydajnych kontenerów opartych na haszowaniu. Kontenery zostały
49 zoptymalizowane pod kątem zastosowań krytycznych wydajnościowo,
50 zarówno pod względem dużych ilości danych, jak i dużej szybkości.
51
52 %package prof
53 Summary:        Profiling %{pkgname} library for GHC
54 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       ghc-base-prof >= 4
58 Requires:       ghc-deepseq-prof >= 1.1
59 Requires:       ghc-hashable-prof >= 1.0.1.1
60
61 %description prof
62 Profiling %{pkgname} library for GHC. Should be installed when
63 GHC's profiling subsystem is needed.
64
65 %description prof -l pl.UTF-8
66 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
67 kiedy potrzebujemy systemu profilującego z GHC.
68
69 %package doc
70 Summary:        HTML documentation for %{pkgname} ghc package
71 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
72 Group:          Documentation
73
74 %description doc
75 HTML documentation for %{pkgname} ghc package.
76
77 %description doc -l pl.UTF-8
78 Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
79
80 %prep
81 %setup -q -n %{pkgname}-%{version}
82 %patch -p1
83
84 %build
85 runhaskell Setup.hs configure -v2 \
86         %{?with_prof:--enable-library-profiling} \
87         --prefix=%{_prefix} \
88         --libdir=%{_libdir} \
89         --libexecdir=%{_libexecdir} \
90         --docdir=%{_docdir}/%{name}-%{version}
91
92 runhaskell Setup.hs build
93 runhaskell Setup.hs haddock --executables
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
98
99 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
100
101 # work around automatic haddock docs installation
102 %{__rm} -rf %{name}-%{version}-doc
103 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
104 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
105
106 runhaskell Setup.hs register \
107         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 %ghc_pkg_recache
114
115 %postun
116 %ghc_pkg_recache
117
118 %files
119 %defattr(644,root,root,755)
120 %doc LICENSE
121 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
122 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
123 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSunordered-containers-%{version}-*.so
124 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSunordered-containers-%{version}-*.a
125 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSunordered-containers-%{version}-*_p.a
126 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
127 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.hi
128 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.dyn_hi
129 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap
130 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/*.hi
131 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/*.dyn_hi
132 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/Strict
133 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/Strict/*.hi
134 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/Strict/*.dyn_hi
135 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashSet
136 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashSet/*.hi
137 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashSet/*.dyn_hi
138
139 %if %{with prof}
140 %files prof
141 %defattr(644,root,root,755)
142 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSunordered-containers-%{version}-*_p.a
143 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.p_hi
144 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/*.p_hi
145 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/Strict/*.p_hi
146 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashSet/*.p_hi
147 %endif
148
149 %files doc
150 %defattr(644,root,root,755)
151 %doc %{name}-%{version}-doc/*
This page took 0.074742 seconds and 3 git commands to generate.