]> git.pld-linux.org Git - packages/ghc-unordered-containers.git/blob - ghc-unordered-containers.spec
3901d1201e4256f8b8b09a2e591834b6b78240c9
[packages/ghc-unordered-containers.git] / ghc-unordered-containers.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname unordered-containers
6 Summary:        Efficient hashing-based container types
7 Summary(pl.UTF-8):      Typy wydajnych kontenerów opartych na haszowaniu
8 Name:           ghc-%{pkgname}
9 Version:        0.2.3.3
10 Release:        1
11 License:        BSD
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/unordered-containers
14 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  e1ccd76f0ce7935e83b27a16062f654f
16 URL:            http://hackage.haskell.org/package/unordered-containers
17 BuildRequires:  ghc >= 6.12.3
18 BuildRequires:  ghc-base >= 4
19 BuildRequires:  ghc-base < 5
20 BuildRequires:  ghc-deepseq >= 1.1
21 BuildRequires:  ghc-hashable >= 1.0.1.1
22 %if %{with prof}
23 BuildRequires:  ghc-prof >= 6.12.3
24 BuildRequires:  ghc-base-prof >= 4
25 BuildRequires:  ghc-base-prof < 5
26 BuildRequires:  ghc-deepseq-prof >= 1.1
27 BuildRequires:  ghc-hashable-prof >= 1.0.1.1
28 %endif
29 BuildRequires:  rpmbuild(macros) >= 1.608
30 Requires(post,postun):  /usr/bin/ghc-pkg
31 %requires_eq    ghc
32 Requires:       ghc-base >= 4
33 Requires:       ghc-base < 5
34 Requires:       ghc-deepseq >= 1.1
35 Requires:       ghc-hashable >= 1.0.1.1
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 # debuginfo is not useful for ghc
39 %define         _enable_debug_packages  0
40
41 # don't compress haddock files
42 %define         _noautocompressdoc      *.haddock
43
44 %description
45 Efficient hashing-based container types. The containers have been
46 optimized for performance critical use, both in terms of large data
47 quantities and high speed.
48
49 %description -l pl.UTF-8
50 Typy wydajnych kontenerów opartych na haszowaniu. Kontenery zostały
51 zoptymalizowane pod kątem zastosowań krytycznych wydajnościowo,
52 zarówno pod względem dużych ilości danych, jak i dużej szybkości.
53
54 %package prof
55 Summary:        Profiling %{pkgname} library for GHC
56 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       ghc-base-prof >= 4
60 Requires:       ghc-base-prof < 5
61 Requires:       ghc-deepseq-prof >= 1.1
62 Requires:       ghc-hashable-prof >= 1.0.1.1
63
64 %description prof
65 Profiling %{pkgname} library for GHC. Should be installed when
66 GHC's profiling subsystem is needed.
67
68 %description prof -l pl.UTF-8
69 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
70 kiedy potrzebujemy systemu profilującego z GHC.
71
72 %package doc
73 Summary:        HTML documentation for %{pkgname} ghc package
74 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
75 Group:          Documentation
76
77 %description doc
78 HTML documentation for %{pkgname} ghc package.
79
80 %description doc -l pl.UTF-8
81 Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
82
83 %prep
84 %setup -q -n %{pkgname}-%{version}
85
86 %build
87 runhaskell Setup.hs configure -v2 \
88         %{?with_prof:--enable-library-profiling} \
89         --prefix=%{_prefix} \
90         --libdir=%{_libdir} \
91         --libexecdir=%{_libexecdir} \
92         --docdir=%{_docdir}/%{name}-%{version}
93
94 runhaskell Setup.hs build
95 runhaskell Setup.hs haddock --executables
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
100
101 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
102
103 # work around automatic haddock docs installation
104 %{__rm} -rf %{name}-%{version}-doc
105 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
106 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
107
108 runhaskell Setup.hs register \
109         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 %ghc_pkg_recache
116
117 %postun
118 %ghc_pkg_recache
119
120 %files
121 %defattr(644,root,root,755)
122 %doc LICENSE
123 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
124 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
125 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/HSunordered-containers-%{version}.o
126 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSunordered-containers-%{version}.a
127 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
128 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashSet.hi
129 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap
130 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/*.hi
131
132 %if %{with prof}
133 %files prof
134 %defattr(644,root,root,755)
135 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSunordered-containers-%{version}_p.a
136 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashSet.p_hi
137 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap
138 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/*.p_hi
139 %endif
140
141 %files doc
142 %defattr(644,root,root,755)
143 %doc %{name}-%{version}-doc/*
This page took 0.123217 seconds and 2 git commands to generate.