]> git.pld-linux.org Git - packages/ghc-transformers-base.git/blob - ghc-transformers-base.spec
adapter, do not force remove
[packages/ghc-transformers-base.git] / ghc-transformers-base.spec
1 %define         pkgname transformers-base
2 Summary:        This package provides a straightforward port of monadLib's BaseM typeclass to transformers
3 Name:           ghc-%{pkgname}
4 Version:        0.4.1
5 Release:        1
6 License:        BSD
7 Group:          Development/Languages
8 Source0:        http://hackage.haskell.org/packages/archive/transformers-base/%{version}/%{pkgname}-%{version}.tar.gz
9 # Source0-md5:  bd99282e2daae5eecd1c953b7b77c990
10 URL:            http://hackage.haskell.org/package/transformers-base/
11 BuildRequires:  ghc >= 6.12.3
12 BuildRequires:  ghc-transformers
13 BuildRequires:  rpmbuild(macros) >= 1.608
14 %requires_eq    ghc
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 # debuginfo is not useful for ghc
18 %define         _enable_debug_packages  0
19
20 %description
21 This package provides a straightforward port of monadLib's BaseM
22 typeclass to transformers.
23
24 %package doc
25 Summary:        HTML documentation for %{pkgname}
26 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu %{pkgname}
27 Group:          Documentation
28
29 %description doc
30 HTML documentation for %{pkgname}.
31
32 %description doc -l pl.UTF-8
33 Dokumentacja w formacie HTML dla pakietu %{pkgname}.
34
35 %prep
36 %setup -q -n %{pkgname}-%{version}
37
38 %build
39 runhaskell Setup.hs configure -v2 \
40         --prefix=%{_prefix} \
41         --libdir=%{_libdir} \
42         --libexecdir=%{_libexecdir} \
43         --docdir=%{_docdir}/%{name}-%{version}
44
45 runhaskell Setup.hs build
46 runhaskell Setup.hs haddock --executables
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
51
52 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
53
54 # work around automatic haddock docs installation
55 rm -rf %{name}-%{version}-doc
56 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
57
58 runhaskell Setup.hs register \
59         --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
60
61 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 %ghc_pkg_recache
68
69 %postun
70 %ghc_pkg_recache
71
72 %files
73 %defattr(644,root,root,755)
74 %doc LICENSE
75 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
76 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
77
78 %files doc
79 %defattr(644,root,root,755)
80 %doc %{name}-%{version}-doc/*
This page took 0.082888 seconds and 3 git commands to generate.