]> git.pld-linux.org Git - packages/ghc-safe.git/blob - ghc-safe.spec
rebuild with ghc 8.10.7
[packages/ghc-safe.git] / ghc-safe.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname safe
6 Summary:        Library of safe (exception free) functions
7 Name:           ghc-%{pkgname}
8 Version:        0.3.19
9 Release:        2
10 License:        BSD
11 Group:          Development/Languages
12 #Source0Download: http://hackage.haskell.org/package/safe
13 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14 # Source0-md5:  23a1bcc16b885249dc35370b1c428cc7
15 URL:            http://hackage.haskell.org/package/safe
16 BuildRequires:  ghc >= 6.12.3
17 %if %{with prof}
18 BuildRequires:  ghc-prof
19 %endif
20 BuildRequires:  rpmbuild(macros) >= 1.608
21 %requires_eq    ghc
22 Requires(post,postun):  /usr/bin/ghc-pkg
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 # debuginfo is not useful for ghc
26 %define         _enable_debug_packages  0
27
28 # don't compress haddock files
29 %define         _noautocompressdoc      *.haddock
30
31 %description
32 A library wrapping Prelude/Data.List functions that can throw
33 exceptions, such as head and !!.
34
35 %package prof
36 Summary:        Profiling %{pkgname} library for GHC
37 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description prof
42 Profiling %{pkgname} library for GHC.  Should be installed when
43 GHC's profiling subsystem is needed.
44
45 %description prof -l pl.UTF-8
46 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
47 kiedy potrzebujemy systemu profilującego z GHC.
48
49 %prep
50 %setup -q -n %{pkgname}-%{version}
51
52 %build
53 runhaskell Setup.hs configure -v2 \
54         %{?with_prof:--enable-library-profiling} \
55         --prefix=%{_prefix} \
56         --libdir=%{_libdir} \
57         --libexecdir=%{_libexecdir} \
58         --docdir=%{_docdir}/%{name}-%{version}
59
60 runhaskell Setup.hs build
61 runhaskell Setup.hs haddock --executables
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
66
67 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
68
69 # work around automatic haddock docs installation
70 %{__rm} -rf %{name}-%{version}-doc
71 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
72 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
73
74 runhaskell Setup.hs register \
75         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 %ghc_pkg_recache
82
83 %postun
84 %ghc_pkg_recache
85
86 %files
87 %defattr(644,root,root,755)
88 %doc CHANGES.txt README.md %{name}-%{version}-doc/*
89 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
90 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
91 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
92 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
93 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
94
95 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.hi
96 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.dyn_hi
97 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Safe
98 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Safe/*.hi
99 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Safe/*.dyn_hi
100
101 %if %{with prof}
102 %files prof
103 %defattr(644,root,root,755)
104 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
105 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.p_hi
106 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Safe/*.p_hi
107 %endif
This page took 0.059925 seconds and 3 git commands to generate.