]> git.pld-linux.org Git - packages/ghc-regex-base.git/blob - ghc-regex-base.spec
- up to 0.94.0.0
[packages/ghc-regex-base.git] / ghc-regex-base.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname regex-base
6 Summary:        Interface API for regex-posix,pcre,parsec,tdfa,dfa
7 Summary(pl.UTF-8):      API interfejsu dla regex-posix,pcre,parsec,tdfa,dfa
8 Name:           ghc-%{pkgname}
9 Version:        0.94.0.0
10 Release:        1
11 License:        BSD
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/regex-base
14 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  91f7a3e19e419fb048b8babfecc1294b
16 Patch0:         ghc-8.10.patch
17 URL:            http://hackage.haskell.org/package/regex-base
18 BuildRequires:  ghc >= 6.12.3
19 BuildRequires:  ghc-array
20 BuildRequires:  ghc-base >= 3.0
21 BuildRequires:  ghc-bytestring
22 BuildRequires:  ghc-containers
23 BuildRequires:  ghc-mtl
24 %if %{with prof}
25 BuildRequires:  ghc-prof >= 6.12.3
26 BuildRequires:  ghc-array-prof
27 BuildRequires:  ghc-base-prof >= 3.0
28 BuildRequires:  ghc-bytestring-prof
29 BuildRequires:  ghc-containers-prof
30 BuildRequires:  ghc-mtl-prof
31 %endif
32 BuildRequires:  rpmbuild(macros) >= 1.608
33 Requires(post,postun):  /usr/bin/ghc-pkg
34 %requires_eq    ghc
35 Requires:       ghc-array
36 Requires:       ghc-base >= 3.0
37 Requires:       ghc-bytestring
38 Requires:       ghc-containers
39 Requires:       ghc-mtl
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 # debuginfo is not useful for ghc
43 %define         _enable_debug_packages  0
44
45 # don't compress haddock files
46 %define         _noautocompressdoc      *.haddock
47
48 %description
49 Interface API for regex-posix,pcre,parsec,tdfa,dfa.
50
51 %description -l pl.UTF-8
52 API interfejsu dla regex-posix,pcre,parsec,tdfa,dfa.
53
54 %package prof
55 Summary:        Profiling %{pkgname} library for GHC
56 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC.
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       ghc-array-prof
60 Requires:       ghc-base-prof >= 3.0
61 Requires:       ghc-bytestring-prof
62 Requires:       ghc-containers-prof
63 Requires:       ghc-mtl-prof
64
65 %description prof
66 Profiling %{pkgname} library for GHC. Should be installed when
67 GHC's profiling subsystem is needed.
68
69 %description prof -l pl.UTF-8
70 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
71 kiedy potrzebujemy systemu profilującego z GHC.
72
73 %package doc
74 Summary:        HTML documentation for ghc %{pkgname} package
75 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
76 Group:          Documentation
77
78 %description doc
79 HTML documentation for ghc %{pkgname} package.
80
81 %description doc -l pl.UTF-8
82 Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
83
84 %prep
85 %setup -q -n %{pkgname}-%{version}
86 %patch0 -p1
87
88 %build
89 runhaskell Setup.hs configure -v2 \
90         %{?with_prof:--enable-library-profiling} \
91         --prefix=%{_prefix} \
92         --libdir=%{_libdir} \
93         --libexecdir=%{_libexecdir} \
94         --docdir=%{_docdir}/%{name}-%{version}
95
96 runhaskell Setup.hs build
97 runhaskell Setup.hs haddock --executables
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
102
103 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
104
105 # work around automatic haddock docs installation
106 %{__rm} -rf %{name}-%{version}-doc
107 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
108 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
109
110 runhaskell Setup.hs register \
111         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post
117 %ghc_pkg_recache
118
119 %postun
120 %ghc_pkg_recache
121
122 %files
123 %defattr(644,root,root,755)
124 %doc LICENSE
125 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
126 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
127 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-base-%{version}-*.so
128 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-base-%{version}-*.a
129 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-base-%{version}-*_p.a
130 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.hi
131 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.dyn_hi
132 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
133 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex
134 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/*.hi
135 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/*.dyn_hi
136 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Base
137 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Base/*.hi
138 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Base/*.dyn_hi
139
140 %files prof
141 %defattr(644,root,root,755)
142 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-base-%{version}-*_p.a
143 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.p_hi
144 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/*.p_hi
145 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Base/*.p_hi
146
147 %files doc
148 %defattr(644,root,root,755)
149 %doc %{name}-%{version}-doc/*
This page took 0.126017 seconds and 3 git commands to generate.