]> git.pld-linux.org Git - packages/ghc-pcre-light.git/blob - ghc-pcre-light.spec
f28ac6606569043ee36013707c72ccc61a50a364
[packages/ghc-pcre-light.git] / ghc-pcre-light.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname pcre-light
6 Summary:        A library for Perl 5 compatible regular expressions
7 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych zgodnych z Perlem 5
8 Name:           ghc-%{pkgname}
9 Version:        0.4
10 Release:        4
11 License:        BSD
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/pcre-light
14 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  4907d8d239d3c41f06855faee340d052
16 URL:            http://hackage.haskell.org/package/pcre-light
17 BuildRequires:  ghc >= 6.12.3
18 BuildRequires:  ghc-base >= 3
19 BuildRequires:  ghc-base <= 5
20 BuildRequires:  ghc-bytestring >= 0.9
21 %if %{with prof}
22 BuildRequires:  ghc-prof >= 6.12.3
23 BuildRequires:  ghc-base-prof >= 3
24 BuildRequires:  ghc-base-prof <= 5
25 BuildRequires:  ghc-bytestring-prof >= 0.9
26 %endif
27 BuildRequires:  pcre-devel
28 BuildRequires:  rpmbuild(macros) >= 1.608
29 %requires_eq    ghc
30 Requires:       ghc-base >= 3
31 Requires:       ghc-base <= 5
32 Requires:       ghc-bytestring >= 0.9
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 # debuginfo is not useful for ghc
36 %define         _enable_debug_packages  0
37
38 # don't compress haddock files
39 %define         _noautocompressdoc      *.haddock
40
41 %description
42 A small, efficient and portable regex library for Perl 5 compatible
43 regular expressions.
44
45 %description -l pl.UTF-8
46 Mała, wydajna i przenośna biblioteka wyrażeń regularnych zgodnych z
47 Perlem 5.
48
49 %package prof
50 Summary:        Profiling %{pkgname} library for GHC
51 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       ghc-base-prof >= 3
55 Requires:       ghc-base-prof <= 5
56 Requires:       ghc-bytestring-prof >= 0.9
57
58 %description prof
59 Profiling %{pkgname} library for GHC. Should be installed when
60 GHC's profiling subsystem is needed.
61
62 %description prof -l pl.UTF-8
63 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
64 kiedy potrzebujemy systemu profilującego z GHC.
65
66 %package doc
67 Summary:        HTML documentation for ghc %{pkgname} package
68 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
69 Group:          Documentation
70
71 %description doc
72 HTML documentation for ghc %{pkgname} package.
73
74 %description doc -l pl.UTF-8
75 Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
76
77 %prep
78 %setup -q -n %{pkgname}-%{version}
79
80 %build
81 runhaskell Setup.lhs configure -v2 \
82         %{?with_prof:--enable-library-profiling} \
83         --prefix=%{_prefix} \
84         --libdir=%{_libdir} \
85         --libexecdir=%{_libexecdir} \
86         --docdir=%{_docdir}/%{name}-%{version}
87
88 runhaskell Setup.lhs build
89 runhaskell Setup.lhs haddock --executables
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
94
95 runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
96
97 # work around automatic haddock docs installation
98 %{__rm} -rf %{name}-%{version}-doc
99 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
100 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
101
102 runhaskell Setup.lhs register \
103         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post
109 %ghc_pkg_recache
110
111 %postun
112 %ghc_pkg_recache
113
114 %files
115 %defattr(644,root,root,755)
116 %doc LICENSE TODO
117 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
118 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
119 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/HSpcre-light-%{version}.o
120 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSpcre-light-%{version}.a
121 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
122 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex
123 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE
124 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE/Light.hi
125 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE/Light
126 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE/Light/*.hi
127
128 %if %{with prof}
129 %files prof
130 %defattr(644,root,root,755)
131 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSpcre-light-%{version}_p.a
132 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE/Light.p_hi
133 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/PCRE/Light/*.p_hi
134 %endif
135
136 %files doc
137 %defattr(644,root,root,755)
138 %doc %{name}-%{version}-doc/*
This page took 0.246602 seconds and 2 git commands to generate.