]> git.pld-linux.org Git - packages/ghc-pandoc-types.git/blob - ghc-pandoc-types.spec
c5ab36f0c4f47371b1f5a8166273919a5825e99a
[packages/ghc-pandoc-types.git] / ghc-pandoc-types.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname pandoc-types
6 Summary:        Types for representing a structured document
7 Summary(pl.UTF-8):      Typy do reprezentowania dokumentu posiadającego strukturę
8 Name:           ghc-%{pkgname}
9 Version:        1.20
10 Release:        1
11 License:        GPL v2+
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/pandoc-types
14 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  3bd9ed959e53bc4f2d2457098db584f2
16 Patch0:         QuickCheck-2.14.patch
17 URL:            http://hackage.haskell.org/package/pandoc-types
18 BuildRequires:  ghc >= 6.12.3
19 BuildRequires:  ghc-QuickCheck
20 BuildRequires:  ghc-aeson >= 0.6.2
21 BuildRequires:  ghc-base >= 4
22 BuildRequires:  ghc-bytestring >= 0.9
23 BuildRequires:  ghc-containers >= 0.3
24 BuildRequires:  ghc-ghc-prim >= 0.2
25 BuildRequires:  ghc-syb >= 0.1
26 %if %{with prof}
27 BuildRequires:  ghc-prof >= 6.12.3
28 BuildRequires:  ghc-QuickCheck-prof
29 BuildRequires:  ghc-aeson-prof >= 0.6.2
30 BuildRequires:  ghc-base-prof >= 4
31 BuildRequires:  ghc-bytestring-prof >= 0.9
32 BuildRequires:  ghc-containers-prof >= 0.3
33 BuildRequires:  ghc-ghc-prim-prof >= 0.2
34 BuildRequires:  ghc-syb-prof >= 0.1
35 %endif
36 BuildRequires:  rpmbuild(macros) >= 1.608
37 Requires(post,postun):  /usr/bin/ghc-pkg
38 %requires_eq    ghc
39 Requires:       ghc-QuickCheck
40 Requires:       ghc-aeson >= 0.6.2
41 Requires:       ghc-base >= 4
42 Requires:       ghc-bytestring >= 0.9
43 Requires:       ghc-containers >= 0.3
44 Requires:       ghc-ghc-prim >= 0.2
45 Requires:       ghc-syb >= 0.1
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 # debuginfo is not useful for ghc
49 %define         _enable_debug_packages  0
50
51 # don't compress haddock files
52 %define         _noautocompressdoc      *.haddock
53
54 %description
55 Text.Pandoc.Definition defines the Pandoc data structure, which is
56 used by pandoc to represent structured documents. This module used to
57 live in the pandoc package, but starting with pandoc 1.7, it has been
58 split off, so that other packages can use it without drawing in all of
59 pandoc's dependencies, and pandoc itself can depend on packages (like
60 citeproc-hs) that use them.
61
62 Text.Pandoc.Builder provides functions for building up Pandoc
63 structures programmatically.
64
65 Text.Pandoc.Generic provides generic functions for manipulating Pandoc
66 documents.
67
68 Text.Pandoc.Walk provides faster, nongeneric functions for
69 manipulating Pandoc documents.
70
71 Text.Pandoc.JSON provides functions for serializing and deserializing
72 a Pandoc structure to and from JSON.
73
74 %description -l pl.UTF-8
75 Text.Pandoc.Definition definiuje strukturę danych Pandoc, służącą
76 programowi pandoc do reprezentowania dokumentów ze strukturą. Moduł
77 ten był wcześniej częścią pakietu pandoc, ale od wersji 1.7 został
78 wydzielony, dzięki czemu mogą z niego korzystać inne pakiety bez
79 pociągania wszystkich zależności pandoca, a pandoc może wymagać
80 pakietów używających tego modułu (np. citeproc-hs).
81
82 Text.Pandoc.Builder zapewnia funkcje do programowego budowania
83 struktur Pandoc.
84
85 Text.Pandoc.Generic udostępnia ogólne funkcje do operowania na
86 dokumentach Pandoc.
87
88 Text.Pandoc.Walk zapewnia szybkie, specyficzne funkcje do operowania
89 na dokumentach Pandoc.
90
91 Text.Pandoc.JSON zapewnia funkcje do serializacji i deserializacji
92 struktury Pandoc do/z formatu JSON.
93
94 %package prof
95 Summary:        Profiling %{pkgname} library for GHC
96 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
97 Group:          Development/Libraries
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       ghc-QuickCheck-prof
100 Requires:       ghc-aeson-prof >= 0.6.2
101 Requires:       ghc-base-prof >= 4
102 Requires:       ghc-bytestring-prof >= 0.9
103 Requires:       ghc-containers-prof >= 0.3
104 Requires:       ghc-ghc-prim-prof >= 0.2
105 Requires:       ghc-syb-prof >= 0.1
106
107 %description prof
108 Profiling %{pkgname} library for GHC. Should be installed when
109 GHC's profiling subsystem is needed.
110
111 %description prof -l pl.UTF-8
112 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
113 kiedy potrzebujemy systemu profilującego z GHC.
114
115 %package doc
116 Summary:        HTML documentation for ghc %{pkgname} package
117 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
118 Group:          Documentation
119
120 %description doc
121 HTML documentation for ghc %{pkgname} package.
122
123 %description doc -l pl.UTF-8
124 Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
125
126 %prep
127 %setup -q -n %{pkgname}-%{version}
128 %patch0 -p1
129
130 %build
131 runhaskell Setup.hs configure -v2 \
132         %{?with_prof:--enable-library-profiling} \
133         --prefix=%{_prefix} \
134         --libdir=%{_libdir} \
135         --libexecdir=%{_libexecdir} \
136         --docdir=%{_docdir}/%{name}-%{version}
137
138 runhaskell Setup.hs build
139 runhaskell Setup.hs haddock --executables
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
144
145 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
146
147 # work around automatic haddock docs installation
148 %{__rm} -rf %{name}-%{version}-doc
149 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
150 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
151
152 runhaskell Setup.hs register \
153         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post
159 %ghc_pkg_recache
160
161 %postun
162 %ghc_pkg_recache
163
164 %files
165 %defattr(644,root,root,755)
166 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
167 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
168 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSpandoc-types-%{version}-*.so
169 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSpandoc-types-%{version}-*.a
170 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSpandoc-types-%{version}-*_p.a
171 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.hi
172 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.dyn_hi
173 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
174 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Pandoc
175 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Pandoc/*.hi
176 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Pandoc/*.dyn_hi
177 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Pandoc/Legacy
178 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Pandoc/Legacy/*.hi
179 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Pandoc/Legacy/*.dyn_hi
180
181 %if %{with prof}
182 %files prof
183 %defattr(644,root,root,755)
184 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSpandoc-types-%{version}-*_p.a
185 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.p_hi
186 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Pandoc/*.p_hi
187 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Pandoc/Legacy/*.p_hi
188 %endif
189
190 %files doc
191 %defattr(644,root,root,755)
192 %doc %{name}-%{version}-doc/*
This page took 0.214854 seconds and 2 git commands to generate.