]> git.pld-linux.org Git - packages/ghc-network-bsd.git/blob - ghc-network-bsd.spec
- new
[packages/ghc-network-bsd.git] / ghc-network-bsd.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname network-bsd
6 Summary:        POSIX network database (<netdb.h>) API
7 Name:           ghc-%{pkgname}
8 Version:        2.8.1.0
9 Release:        1
10 License:        BSD
11 Group:          Development/Languages
12 #Source0Download: http://hackage.haskell.org/package/network-bsd
13 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14 # Source0-md5:  53572973c4c5d52e19bcd1a1f71593c3
15 Patch0:         ghc-network-3.1.patch
16 URL:            http://hackage.haskell.org/package/network-bsd
17 BuildRequires:  ghc >= 6.12.3
18 BuildRequires:  ghc-network >= 3.0.0.0
19 %if %{with prof}
20 BuildRequires:  ghc-prof
21 BuildRequires:  ghc-network-prof >= 3.0.0.0
22 %endif
23 BuildRequires:  rpmbuild(macros) >= 1.608
24 %requires_eq    ghc
25 Requires(post,postun):  /usr/bin/ghc-pkg
26 Requires:       ghc-network >= 3.0.0.0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # debuginfo is not useful for ghc
30 %define         _enable_debug_packages  0
31
32 # don't compress haddock files
33 %define         _noautocompressdoc      *.haddock
34
35 %description
36 This package provides Haskell bindings to the the POSIX network
37 database (<netdb.h>) API.
38
39 %package prof
40 Summary:        Profiling %{pkgname} library for GHC
41 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       ghc-network-prof >= 3.0.0.0
45
46 %description prof
47 Profiling %{pkgname} library for GHC.  Should be installed when
48 GHC's profiling subsystem is needed.
49
50 %description prof -l pl.UTF-8
51 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
52 kiedy potrzebujemy systemu profilującego z GHC.
53
54 %prep
55 %setup -q -n %{pkgname}-%{version}
56 %patch0 -p1
57
58 %build
59 runhaskell Setup.hs configure -v2 \
60         %{?with_prof:--enable-library-profiling} \
61         --prefix=%{_prefix} \
62         --libdir=%{_libdir} \
63         --libexecdir=%{_libexecdir} \
64         --docdir=%{_docdir}/%{name}-%{version}
65
66 runhaskell Setup.hs build
67 runhaskell Setup.hs haddock --executables
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
72
73 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
74
75 # work around automatic haddock docs installation
76 %{__rm} -rf %{name}-%{version}-doc
77 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
78 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
79
80 runhaskell Setup.hs register \
81         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post
87 %ghc_pkg_recache
88
89 %postun
90 %ghc_pkg_recache
91
92 %files
93 %defattr(644,root,root,755)
94 %doc CHANGELOG.md LICENSE %{name}-%{version}-doc/html
95 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
96 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
97 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
98 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
99 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
100
101 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network
102 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/*.hi
103 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/*.dyn_hi
104
105 %if %{with prof}
106 %files prof
107 %defattr(644,root,root,755)
108 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
109 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/*.p_hi
110 %endif
This page took 0.062293 seconds and 3 git commands to generate.