]> git.pld-linux.org Git - packages/ghc-monads-tf.git/blob - ghc-monads-tf.spec
rebuild with ghc 8.10.7
[packages/ghc-monads-tf.git] / ghc-monads-tf.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname monads-tf
6 Summary:        Monad classes, using type families
7 Summary(pl.UTF-8):      Klasy monad wykorzystujące rodziny typów
8 Name:           ghc-%{pkgname}
9 Version:        0.1.0.3
10 Release:        2
11 License:        BSD
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/monads-tf
14 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  0c946ba2101c6723d9637d2d145153f8
16 URL:            http://hackage.haskell.org/package/monads-tf
17 BuildRequires:  ghc >= 6.12.3
18 BuildRequires:  ghc-transformers >= 0.2.0.0
19 %if %{with prof}
20 BuildRequires:  ghc-prof >= 6.12.3
21 BuildRequires:  ghc-transformers-prof >= 0.2.0.0
22 %endif
23 BuildRequires:  rpmbuild(macros) >= 1.608
24 Requires(post,postun):  /usr/bin/ghc-pkg
25 %requires_eq    ghc
26 Requires:       ghc-transformers >= 0.2.0.0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # debuginfo is not useful for ghc
30 %define         _enable_debug_packages  0
31
32 # don't compress haddock files
33 %define         _noautocompressdoc      *.haddock
34
35 %description
36 Monad classes using type families, with instances for various monad
37 transformers, inspired by the paper "Functional Programming with
38 Overloading and Higher-Order Polymorphism", by Mark P Jones, in
39 Advanced School of Functional Programming, 1995
40 (<http://web.cecs.pdx.edu/~mpj/pubs/springschool.html>).
41
42 %description -l pl.UTF-8
43 Klasy monad wykorzystujące rodziny typów z instancjami dla różnych
44 transformatorów monad, zainspirowane dokumentem "Functional
45 Programming with Overloading and Higher-Order Polymorphism"
46 (Programowanie funkcyjne z przeciążaniem i polimorfizmem wyższego
47 rzędu) autorstwa Marka P. Jonesa, Advanced School of Functional
48 Programming, 1995
49 (<http://web.cecs.pdx.edu/~mpj/pubs/springschool.html>).
50
51 %package prof
52 Summary:        Profiling %{pkgname} library for GHC
53 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       ghc-transformers-prof >= 0.2.0.0
57
58 %description prof
59 Profiling %{pkgname} library for GHC. Should be installed when GHC's
60 profiling subsystem is needed.
61
62 %description prof -l pl.UTF-8
63 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
64 kiedy potrzebujemy systemu profilującego z GHC.
65
66 %package doc
67 Summary:        HTML documentation for ghc %{pkgname} package
68 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
69 Group:          Documentation
70
71 %description doc
72 HTML documentation for ghc %{pkgname} package.
73
74 %description doc -l pl.UTF-8
75 Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
76
77 %prep
78 %setup -q -n %{pkgname}-%{version}
79
80 %build
81 runhaskell Setup.hs configure -v2 \
82         %{?with_prof:--enable-library-profiling} \
83         --prefix=%{_prefix} \
84         --libdir=%{_libdir} \
85         --libexecdir=%{_libexecdir} \
86         --docdir=%{_docdir}/%{name}-%{version}
87
88 runhaskell Setup.hs build
89 runhaskell Setup.hs haddock --executables
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
94
95 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
96
97 # work around automatic haddock docs installation
98 %{__rm} -rf %{name}-%{version}-doc
99 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
100 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
101
102 runhaskell Setup.hs register \
103         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post
109 %ghc_pkg_recache
110
111 %postun
112 %ghc_pkg_recache
113
114 %files
115 %defattr(644,root,root,755)
116 %doc LICENSE
117 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
118 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
119 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSmonads-tf-%{version}-*.so
120 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSmonads-tf-%{version}-*.a
121 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSmonads-tf-%{version}-*_p.a
122 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control
123 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad
124 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/*.hi
125 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/*.dyn_hi
126 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Cont
127 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Cont/*.hi
128 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Cont/*.dyn_hi
129 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Error
130 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Error/*.hi
131 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Error/*.dyn_hi
132 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/RWS
133 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/RWS/*.hi
134 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/RWS/*.dyn_hi
135 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Reader
136 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Reader/*.hi
137 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Reader/*.dyn_hi
138 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/State
139 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/State/*.hi
140 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/State/*.dyn_hi
141 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Writer
142 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Writer/*.hi
143 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Writer/*.dyn_hi
144
145 %if %{with prof}
146 %files prof
147 %defattr(644,root,root,755)
148 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSmonads-tf-%{version}-*_p.a
149 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/*.p_hi
150 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Cont/*.p_hi
151 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Error/*.p_hi
152 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/RWS/*.p_hi
153 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Reader/*.p_hi
154 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/State/*.p_hi
155 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Writer/*.p_hi
156 %endif
157
158 %files doc
159 %defattr(644,root,root,755)
160 %doc %{name}-%{version}-doc/*
This page took 0.063461 seconds and 3 git commands to generate.