]> git.pld-linux.org Git - packages/ghc-monad-control.git/blob - ghc-monad-control.spec
dc93e20d664162b0be2147ec55fe7ac85ccf1379
[packages/ghc-monad-control.git] / ghc-monad-control.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname monad-control
6 Summary:        Generic control operations
7 Summary(pl.UTF-8):      Ogólne operacje sterujące
8 Name:           ghc-%{pkgname}
9 Version:        0.3.2.2
10 Release:        1
11 License:        BSD
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/monad-control
14 Source0:        http://hackage.haskell.org/package/monad-control-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  cc836f29b8e95c6b6ea28d804422ae1c
16 URL:            http://hackage.haskell.org/package/monad-control
17 BuildRequires:  ghc >= 6.12.3
18 BuildRequires:  ghc-base >= 3
19 BuildRequires:  ghc-base < 5
20 BuildRequires:  ghc-base-unicode-symbols >= 0.1.1
21 BuildRequires:  ghc-base-unicode-symbols < 0.3
22 BuildRequires:  ghc-transformers >= 0.2
23 BuildRequires:  ghc-transformers < 0.4
24 BuildRequires:  ghc-transformers-base >= 0.4.1
25 BuildRequires:  ghc-transformers-base < 0.5
26 %if %{with prof}
27 BuildRequires:  ghc-prof >= 6.12.3
28 BuildRequires:  ghc-base-prof >= 3
29 BuildRequires:  ghc-base-prof < 5
30 BuildRequires:  ghc-base-unicode-symbols-prof >= 0.1.1
31 BuildRequires:  ghc-base-unicode-symbols-prof < 0.3
32 BuildRequires:  ghc-transformers-prof >= 0.2
33 BuildRequires:  ghc-transformers-prof < 0.4
34 BuildRequires:  ghc-transformers-base-prof >= 0.4.1
35 BuildRequires:  ghc-transformers-base-prof < 0.5
36 %endif
37 BuildRequires:  rpmbuild(macros) >= 1.608
38 Requires(post,postun):  /usr/bin/ghc-pkg
39 %requires_eq    ghc
40 Requires:       ghc-base >= 3
41 Requires:       ghc-base < 5
42 Requires:       ghc-base-unicode-symbols >= 0.1.1
43 Requires:       ghc-base-unicode-symbols < 0.3
44 Requires:       ghc-transformers >= 0.2
45 Requires:       ghc-transformers < 0.4
46 Requires:       ghc-transformers-base >= 0.4.1
47 Requires:       ghc-transformers-base < 0.5
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 # debuginfo is not useful for ghc
51 %define         _enable_debug_packages  0
52
53 %description
54 This package defines the type class MonadBaseControl, a subset of
55 MonadBase into which generic control operations such as catch can be
56 lifted from IO or any other base monad. Instances are based on monad
57 transformers in MonadTransControl, which includes all standard monad
58 transformers in the transformers library except ContT.
59
60 %description -l pl.UTF-8
61 Ten pakiet definiuje klasę typu MonadBaseControl, będącą podzbiorem
62 MonadBase, do której można podnieść ogólne operacje sterujące (takie
63 jak catch) z IO lub dowolnej innej podstawowej monady. Instancje są
64 oparte na transformatorach monad w MonadTransControl, która dołącza
65 wszystkie standardowe transformatory monad z biblioteki transformers z
66 wyjątkiem ContT.
67
68 %package prof
69 Summary:        Profiling %{pkgname} library for GHC
70 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       ghc-base-prof >= 3
74 Requires:       ghc-base-prof < 5
75 Requires:       ghc-base-unicode-symbols-prof >= 0.1.1
76 Requires:       ghc-base-unicode-symbols-prof < 0.3
77 Requires:       ghc-transformers-prof >= 0.2
78 Requires:       ghc-transformers-prof < 0.4
79 Requires:       ghc-transformers-base-prof >= 0.4.1
80 Requires:       ghc-transformers-base-prof < 0.5
81
82 %description prof
83 Profiling %{pkgname} library for GHC. Should be installed when
84 GHC's profiling subsystem is needed.
85
86 %description prof -l pl.UTF-8
87 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
88 kiedy potrzebujemy systemu profilującego z GHC.
89
90 %package doc
91 Summary:        HTML documentation for ghc %{pkgname} package
92 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
93 Group:          Documentation
94
95 %description doc
96 HTML documentation for ghc %{pkgname} package.
97
98 %description doc -l pl.UTF-8
99 Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
100
101 %prep
102 %setup -q -n %{pkgname}-%{version}
103
104 %build
105 runhaskell Setup.hs configure -v2 \
106         %{?with_prof:--enable-library-profiling} \
107         --prefix=%{_prefix} \
108         --libdir=%{_libdir} \
109         --libexecdir=%{_libexecdir} \
110         --docdir=%{_docdir}/%{name}-%{version}
111
112 runhaskell Setup.hs build
113 runhaskell Setup.hs haddock --executables
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
118
119 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
120
121 # work around automatic haddock docs installation
122 %{__rm} -rf %{name}-%{version}-doc
123 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
124 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
125
126 runhaskell Setup.hs register \
127         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post
133 %ghc_pkg_recache
134
135 %postun
136 %ghc_pkg_recache
137
138 %files
139 %defattr(644,root,root,755)
140 %doc LICENSE NEWS README.markdown
141 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
142 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
143 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/HSmonad-control-%{version}.o
144 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSmonad-control-%{version}.a
145 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control
146 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad
147 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Trans
148 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Trans/Control.hi
149
150 %if %{with prof}
151 %files prof
152 %defattr(644,root,root,755)
153 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSmonad-control-%{version}_p.a
154 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Trans/Control.p_hi
155 %endif
156
157 %files doc
158 %defattr(644,root,root,755)
159 %doc %{name}-%{version}-doc/*
This page took 0.062585 seconds and 2 git commands to generate.