]> git.pld-linux.org Git - packages/ghc-libmpd.git/blob - ghc-libmpd.spec
f8b9056b125cfc34072ad85628b98496644570e4
[packages/ghc-libmpd.git] / ghc-libmpd.spec
1 %define         pkgname libmpd
2 Summary:        A Haskell binding to the libmpd graphics library
3 Name:           ghc-%{pkgname}
4 Version:        0.9.1.0
5 Release:        1
6 License:        BSD
7 Group:          Development/Languages
8 Source0:        http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9 # Source0-md5:  41a00cf7bc919d8ee3cdb7c21e5436a2
10 Patch0:         ghc-8.10.patch
11 URL:            http://hackage.haskell.org/package/libmpd/
12 BuildRequires:  ghc >= 6.12.3
13 BuildRequires:  ghc-attoparsec >= 0.10.1
14 BuildRequires:  ghc-base >= 4.9
15 BuildRequires:  ghc-bytestring >= 0.9
16 BuildRequires:  ghc-containers >= 0.3
17 BuildRequires:  ghc-data-default-class >= 0.0.1
18 BuildRequires:  ghc-filepath >= 1
19 BuildRequires:  ghc-mtl >= 2.0
20 BuildRequires:  ghc-network >= 2.6.3.5
21 BuildRequires:  ghc-safe-exceptions >= 0.1
22 BuildRequires:  ghc-safe-exceptions >= 0.1
23 BuildRequires:  ghc-text >= 0.11
24 BuildRequires:  ghc-time >= 1.5
25 BuildRequires:  ghc-utf8-string >= 0.3.1
26 BuildRequires:  rpmbuild(macros) >= 1.608
27 %requires_eq    ghc
28 Requires:       ghc-attoparsec >= 0.10.1
29 Requires:       ghc-base >= 4.9
30 Requires:       ghc-bytestring >= 0.9
31 Requires:       ghc-containers >= 0.3
32 Requires:       ghc-data-default-class >= 0.0.1
33 Requires:       ghc-filepath >= 1
34 Requires:       ghc-mtl >= 2.0
35 Requires:       ghc-network >= 2.6.3.5
36 Requires:       ghc-safe-exceptions >= 0.1
37 Requires:       ghc-safe-exceptions >= 0.1
38 Requires:       ghc-text >= 0.11
39 Requires:       ghc-time >= 1.5
40 Requires:       ghc-utf8-string >= 0.3.1
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 # debuginfo is not useful for ghc
44 %define         _enable_debug_packages  0
45
46 %description
47 A Haskell binding to the libmpd graphics library.
48
49 %package doc
50 Summary:        HTML documentation for %{pkgname}
51 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
52 Group:          Documentation
53
54 %description doc
55 HTML documentation for %{pkgname}.
56
57 %description doc -l pl.UTF-8
58 Dokumentacja w formacie HTML dla %{pkgname}.
59
60 %prep
61 %setup -q -n %{pkgname}-%{version}
62 %patch0 -p1
63
64 %build
65 runhaskell Setup.lhs configure -v2 \
66         --prefix=%{_prefix} \
67         --libdir=%{_libdir} \
68         --libexecdir=%{_libexecdir} \
69         --docdir=%{_docdir}/%{name}-%{version}
70
71 runhaskell Setup.lhs build
72 runhaskell Setup.lhs haddock --executables
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
77
78 runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
79
80 # work around automatic haddock docs installation
81 rm -rf %{name}-%{version}-doc
82 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
83 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
84
85 runhaskell Setup.lhs register \
86         --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post
92 %ghc_pkg_recache
93
94 %postun
95 %ghc_pkg_recache
96
97 %files
98 %defattr(644,root,root,755)
99 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
100 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
101
102 %files doc
103 %defattr(644,root,root,755)
104 %doc %{name}-%{version}-doc/*
This page took 0.08723 seconds and 2 git commands to generate.