]> git.pld-linux.org Git - packages/ghc-hxt-charproperties.git/blob - ghc-hxt-charproperties.spec
rebuild with ghc 8.10.7
[packages/ghc-hxt-charproperties.git] / ghc-hxt-charproperties.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname hxt-charproperties
6 Summary:        Character properties and classes for XML and Unicode
7 Name:           ghc-%{pkgname}
8 Version:        9.4.0.0
9 Release:        2
10 License:        MIT
11 Group:          Development/Languages
12 #Source0Download: http://hackage.haskell.org/package/hxt-charproperties
13 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14 # Source0-md5:  63b8718c14bdb9eb8ea0717e484eef0b
15 URL:            http://hackage.haskell.org/package/hxt-charproperties
16 BuildRequires:  ghc >= 6.12.3
17 %if %{with prof}
18 BuildRequires:  ghc-prof
19 %endif
20 BuildRequires:  rpmbuild(macros) >= 1.608
21 %requires_eq    ghc
22 Requires(post,postun):  /usr/bin/ghc-pkg
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 # debuginfo is not useful for ghc
26 %define         _enable_debug_packages  0
27
28 # don't compress haddock files
29 %define         _noautocompressdoc      *.haddock
30
31 %description
32 Character properties defined by XML and Unicode standards. These
33 modules contain predicates for Unicode blocks and char proprties and
34 character predicates defined by XML. Supported Unicode version is
35 12.1.0.
36
37 %package prof
38 Summary:        Profiling %{pkgname} library for GHC
39 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description prof
44 Profiling %{pkgname} library for GHC.  Should be installed when
45 GHC's profiling subsystem is needed.
46
47 %description prof -l pl.UTF-8
48 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
49 kiedy potrzebujemy systemu profilującego z GHC.
50
51 %prep
52 %setup -q -n %{pkgname}-%{version}
53
54 %build
55 runhaskell Setup.hs configure -v2 \
56         %{?with_prof:--enable-library-profiling} \
57         --prefix=%{_prefix} \
58         --libdir=%{_libdir} \
59         --libexecdir=%{_libexecdir} \
60         --docdir=%{_docdir}/%{name}-%{version}
61
62 runhaskell Setup.hs build
63 runhaskell Setup.hs haddock --executables
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
68
69 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
70
71 # work around automatic haddock docs installation
72 %{__rm} -rf %{name}-%{version}-doc
73 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
74 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
75
76 runhaskell Setup.hs register \
77         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post
83 %ghc_pkg_recache
84
85 %postun
86 %ghc_pkg_recache
87
88 %files
89 %defattr(644,root,root,755)
90 %doc %{name}-%{version}-doc/*
91 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
92 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
93 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
94 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
95 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
96
97 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
98 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Char
99 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Char/Properties
100 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Char/Properties/*.hi
101 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Char/Properties/*.dyn_hi
102 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Set
103 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Set/*.hi
104 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Set/*.dyn_hi
105
106 %if %{with prof}
107 %files prof
108 %defattr(644,root,root,755)
109 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
110 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Char/Properties/*.p_hi
111 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Set/*.p_hi
112 %endif
This page took 0.288499 seconds and 3 git commands to generate.