]> git.pld-linux.org Git - packages/ghc-emojis.git/blob - ghc-emojis.spec
- new
[packages/ghc-emojis.git] / ghc-emojis.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname emojis
6 Summary:        Conversion between emoji characters and their names
7 Name:           ghc-%{pkgname}
8 Version:        0.1
9 Release:        1
10 License:        BSD
11 Group:          Development/Languages
12 #Source0Download: http://hackage.haskell.org/package/emojis
13 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14 # Source0-md5:  43c54fbbb961c419fafef87584cb91d2
15 URL:            http://hackage.haskell.org/package/emojis
16 BuildRequires:  ghc >= 6.12.3
17 %if %{with prof}
18 BuildRequires:  ghc-prof
19 %endif
20 BuildRequires:  rpmbuild(macros) >= 1.608
21 %requires_eq    ghc
22 Requires(post,postun):  /usr/bin/ghc-pkg
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 # debuginfo is not useful for ghc
26 %define         _enable_debug_packages  0
27
28 # don't compress haddock files
29 %define         _noautocompressdoc      *.haddock
30
31 %description
32 This package provides functions for converting emoji names to emoji
33 characters and vice versa.
34
35 %package prof
36 Summary:        Profiling %{pkgname} library for GHC
37 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description prof
42 Profiling %{pkgname} library for GHC.  Should be installed when
43 GHC's profiling subsystem is needed.
44
45 %description prof -l pl.UTF-8
46 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
47 kiedy potrzebujemy systemu profilującego z GHC.
48
49 %prep
50 %setup -q -n %{pkgname}-%{version}
51
52 cat >Setup.lhs<<'EOF'
53 #!/usr/bin/env runhaskell
54 > import Distribution.Simple
55 > main = defaultMain
56 EOF
57
58 %build
59 runhaskell Setup.lhs configure -v2 \
60         %{?with_prof:--enable-library-profiling} \
61         --prefix=%{_prefix} \
62         --libdir=%{_libdir} \
63         --libexecdir=%{_libexecdir} \
64         --docdir=%{_docdir}/%{name}-%{version}
65
66 runhaskell Setup.lhs build
67 runhaskell Setup.lhs haddock --executables
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
72
73 runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
74
75 # work around automatic haddock docs installation
76 %{__rm} -rf %{name}-%{version}-doc
77 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
78 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
79
80 runhaskell Setup.lhs register \
81         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post
87 %ghc_pkg_recache
88
89 %postun
90 %ghc_pkg_recache
91
92 %files
93 %defattr(644,root,root,755)
94 %doc README.md changelog.md %{name}-%{version}-doc/*
95 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
96 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
97 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
98 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
99 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
100
101 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
102 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/*.hi
103 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/*.dyn_hi
104
105 %if %{with prof}
106 %files prof
107 %defattr(644,root,root,755)
108 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
109 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/*.p_hi
110 %endif
This page took 0.090481 seconds and 3 git commands to generate.