]> git.pld-linux.org Git - packages/ghc-curl.git/blob - ghc-curl.spec
- sane deps
[packages/ghc-curl.git] / ghc-curl.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname curl
6 Summary:        Haskell binding to libcurl
7 Summary(pl.UTF-8):      Wiązanie Haskella do biblioteki libcurl
8 Name:           ghc-%{pkgname}
9 Version:        1.3.8
10 Release:        3
11 License:        BSD
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/curl
14 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  853113e2ac933e203894a4588150821d
16 URL:            http://hackage.haskell.org/package/curl
17 BuildRequires:  curl-devel
18 BuildRequires:  ghc >= 6.12.3
19 BuildRequires:  ghc-base >= 3
20 BuildRequires:  ghc-base < 5
21 BuildRequires:  ghc-bytestring >= 0.9
22 BuildRequires:  ghc-containers
23 %if %{with prof}
24 BuildRequires:  ghc-prof >= 6.12.3
25 BuildRequires:  ghc-base-prof >= 3
26 BuildRequires:  ghc-base-prof < 5
27 BuildRequires:  ghc-bytestring-prof >= 0.9
28 BuildRequires:  ghc-containers-prof
29 %endif
30 BuildRequires:  rpmbuild(macros) >= 1.608
31 Requires(post,postun):  /usr/bin/ghc-pkg
32 Requires:       ghc-base >= 3
33 Requires:       ghc-base < 5
34 Requires:       ghc-bytestring >= 0.9
35 Requires:       ghc-containers
36 %requires_eq    ghc
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 # debuginfo is not useful for ghc
40 %define         _enable_debug_packages  0
41
42 # don't compress haddock files
43 %define         _noautocompressdoc      *.haddock
44
45 %description
46 libcurl is a client-side URL transfer library, supporting FTP, FTPS,
47 HTTP, HTTPS, SCP, SFTP, TFTP, TELNET, DICT, LDAP, LDAPS and FILE.
48 libcurl supports SSL certificates, HTTP POST, HTTP PUT, FTP uploading,
49 HTTP form based upload, proxies, cookies, user+password authentication
50 (Basic, Digest, NTLM, Negotiate, Kerberos4), file transfer resume,
51 http proxy tunneling and more!
52
53 This package provides a Haskell binding to libcurl.
54
55 %description -l pl.UTF-8
56 libcurl to biblioteka kliencka do przesyłania danych wskazanych przez
57 URL-e, obsługująca protokoły FTP, FTPS, HTTP, HTTPS, SCP, SFTP, TFTP,
58 TELNET, DICT, LDAP, LDAPS oraz FILE. libcurl obsługuje certyfikaty
59 SSL, wysyłanie danych przez HTTP POST, HTTP PUT i FTP, pobieranie
60 danych w oparciu o formularze HTTP, a także serwery proxy, ciasteczka,
61 uwierzytelnianie nazwą użytkownika i hasłem (metody Basic, Digest,
62 NTLM, Negotiate, Kerberos4), wznawianie transmisji plików, tunelowanie
63 proxy HTTP itd.
64
65 Ten pakiet zapewnia wiązanie Haskella do biblioteki libcurl.
66
67 %package prof
68 Summary:        Profiling %{pkgname} library for GHC
69 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC.
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description prof
74 Profiling %{pkgname} library for GHC. Should be installed when GHC's
75 profiling subsystem is needed.
76
77 %description prof -l pl.UTF-8
78 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
79 kiedy potrzebujemy systemu profilującego z GHC.
80
81 %prep
82 %setup -q -n %{pkgname}-%{version}
83
84 %build
85 %configure
86 runhaskell Setup.hs configure -v2 \
87         %{?with_prof:--enable-library-profiling} \
88         --prefix=%{_prefix} \
89         --libdir=%{_libdir} \
90         --libexecdir=%{_libexecdir} \
91         --docdir=%{_docdir}/%{name}-%{version}
92
93 runhaskell Setup.hs build
94 runhaskell Setup.hs haddock --executables
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
99
100 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
101
102 # work around automatic haddock docs installation
103 %{__rm} -rf %{name}-%{version}-doc
104 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
105 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
106
107 runhaskell Setup.hs register \
108         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post
114 %ghc_pkg_recache
115
116 %postun
117 %ghc_pkg_recache
118
119 %files
120 %defattr(644,root,root,755)
121 %doc CHANGES %{name}-%{version}-doc/*
122 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
123 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
124 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/HScurl-%{version}.o
125 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHScurl-%{version}.a
126 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network
127 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/Curl.hi
128 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/Curl
129 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/Curl/*.hi
130
131 %if %{with prof}
132 %files prof
133 %defattr(644,root,root,755)
134 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHScurl-%{version}_p.a
135 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/Curl.p_hi
136 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/Curl/*.p_hi
137 %endif
This page took 0.075532 seconds and 3 git commands to generate.