]> git.pld-linux.org Git - packages/ghc-clock.git/blob - ghc-clock.spec
rebuild with ghc 8.10.7
[packages/ghc-clock.git] / ghc-clock.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname clock
6 Summary:        High-resolution clock functions: monotonic, realtime, cputime
7 Name:           ghc-%{pkgname}
8 Version:        0.8
9 Release:        2
10 License:        BSD
11 Group:          Development/Languages
12 #Source0Download: http://hackage.haskell.org/package/clock
13 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14 # Source0-md5:  a2fcee09fe0da5f60e1c4356d39ed1bd
15 URL:            http://hackage.haskell.org/package/clock
16 BuildRequires:  ghc >= 6.12.3
17 BuildRequires:  ghc-base >= 2
18 BuildRequires:  ghc-base <= 5
19 %if %{with prof}
20 BuildRequires:  ghc-prof >= 6.12.3
21 BuildRequires:  ghc-base-prof >= 2
22 BuildRequires:  ghc-base-prof <= 5
23 %endif
24 BuildRequires:  rpmbuild(macros) >= 1.608
25 Requires(post,postun):  /usr/bin/ghc-pkg
26 %requires_eq    ghc
27 Requires:       ghc-base >= 2
28 Requires:       ghc-base <= 5
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 # debuginfo is not useful for ghc
32 %define         _enable_debug_packages  0
33
34 # don't compress haddock files
35 %define         _noautocompressdoc      *.haddock
36
37 %description
38 A package for convenient access to high-resolution clock and timer
39 functions of different operating systems via a unified API.
40
41 %package prof
42 Summary:        Profiling %{pkgname} library for GHC
43 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       ghc-base-prof < 6
47 Requires:       ghc-bytestring-prof
48 Requires:       ghc-text-prof
49
50 %description prof
51 Profiling %{pkgname} library for GHC. Should be installed when
52 GHC's profiling subsystem is needed.
53
54 %description prof -l pl.UTF-8
55 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
56 kiedy potrzebujemy systemu profilującego z GHC.
57
58 %prep
59 %setup -q -n %{pkgname}-%{version}
60
61 %build
62 runhaskell Setup.hs configure -v2 \
63         %{?with_prof:--enable-library-profiling} \
64         --prefix=%{_prefix} \
65         --libdir=%{_libdir} \
66         --libexecdir=%{_libexecdir} \
67         --docdir=%{_docdir}/%{name}-%{version}
68
69 runhaskell Setup.hs build
70 runhaskell Setup.hs haddock --executables
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
75
76 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
77
78 # work around automatic haddock docs installation
79 %{__rm} -rf %{name}-%{version}-doc
80 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
81 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
82
83 runhaskell Setup.hs register \
84         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post
90 %ghc_pkg_recache
91
92 %postun
93 %ghc_pkg_recache
94
95 %files
96 %defattr(644,root,root,755)
97 %doc %{name}-%{version}-doc/*
98 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
99 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
100 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSclock-%{version}-*.so
101 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSclock-%{version}-*.a
102 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSclock-%{version}-*_p.a
103 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System
104 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/*.hi
105 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/*.dyn_hi
106
107 %if %{with prof}
108 %files prof
109 %defattr(644,root,root,755)
110 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSclock-%{version}-*_p.a
111 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/*.p_hi
112 %endif
This page took 0.059177 seconds and 3 git commands to generate.