]> git.pld-linux.org Git - packages/ghc-case-insensitive.git/blob - ghc-case-insensitive.spec
rebuild with ghc 8.10.7
[packages/ghc-case-insensitive.git] / ghc-case-insensitive.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname case-insensitive
6 Summary:        Case insensitive string comparison
7 Summary(pl.UTF-8):      Porównywanie łańcuchów nie wrażliwe na wielkość liter
8 Name:           ghc-%{pkgname}
9 Version:        1.2.1.0
10 Release:        2
11 License:        BSD
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/case-insensitive
14 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  c501248804f3aaf4c56e2f16d03c3969
16 URL:            http://hackage.haskell.org/package/case-insensitive
17 BuildRequires:  ghc >= 6.12.3
18 BuildRequires:  ghc-base >= 3
19 BuildRequires:  ghc-bytestring >= 0.9
20 BuildRequires:  ghc-deepseq >= 1.1
21 BuildRequires:  ghc-hashable >= 1.0
22 BuildRequires:  ghc-text >= 0.3
23 %if %{with prof}
24 BuildRequires:  ghc-prof >= 6.12.3
25 BuildRequires:  ghc-base-prof >= 3
26 BuildRequires:  ghc-bytestring-prof >= 0.9
27 BuildRequires:  ghc-deepseq-prof >= 1.1
28 BuildRequires:  ghc-hashable-prof >= 1.0
29 BuildRequires:  ghc-text-prof >= 0.3
30 %endif
31 BuildRequires:  rpmbuild(macros) >= 1.608
32 Requires(post,postun):  /usr/bin/ghc-pkg
33 %requires_eq    ghc
34 Requires:       ghc-base >= 3
35 Requires:       ghc-bytestring >= 0.9
36 Requires:       ghc-deepseq >= 1.1
37 Requires:       ghc-hashable >= 1.0
38 Requires:       ghc-text >= 0.3
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 # debuginfo is not useful for ghc
42 %define         _enable_debug_packages  0
43
44 # don't compress haddock files
45 %define         _noautocompressdoc      *.haddock
46
47 %description
48 The module Data.CaseInsensitive provides the CI type constructor which
49 can be parameterised by a string-like type like: String, ByteString,
50 Text, etc.. Comparisons of values of the resulting type will be
51 insensitive to cases.
52
53 %description -l pl.UTF-8
54 Moduł Data.CaseInsensitive udostępnia konstruktor typu C, który może
55 być parametryzowany typem typu łańcuchowego, takim jak String,
56 ByteString, Text itp. Porównywanie wartości typu wynikowego nie będzie
57 wrażliwe na wielkość liter.
58
59 %package prof
60 Summary:        Profiling %{pkgname} library for GHC
61 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       ghc-base-prof >= 3
65 Requires:       ghc-bytestring-prof >= 0.9
66 Requires:       ghc-deepseq-prof >= 1.1
67 Requires:       ghc-hashable-prof >= 1.0
68 Requires:       ghc-text-prof >= 0.3
69
70 %description prof
71 Profiling %{pkgname} library for GHC. Should be installed when GHC's
72 profiling subsystem is needed.
73
74 %description prof -l pl.UTF-8
75 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
76 kiedy potrzebujemy systemu profilującego z GHC.
77
78 %package doc
79 Summary:        HTML documentation for ghc %{pkgname} package
80 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
81 Group:          Documentation
82
83 %description doc
84 HTML documentation for ghc %{pkgname} package.
85
86 %description doc -l pl.UTF-8
87 Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
88
89 %prep
90 %setup -q -n %{pkgname}-%{version}
91
92 %build
93 runhaskell Setup.lhs configure -v2 \
94         %{?with_prof:--enable-library-profiling} \
95         --prefix=%{_prefix} \
96         --libdir=%{_libdir} \
97         --libexecdir=%{_libexecdir} \
98         --docdir=%{_docdir}/%{name}-%{version}
99
100 runhaskell Setup.lhs build
101 runhaskell Setup.lhs haddock --executables
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
106
107 runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
108
109 # work around automatic haddock docs installation
110 %{__rm} -rf %{name}-%{version}-doc
111 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
112 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
113
114 runhaskell Setup.lhs register \
115         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 %ghc_pkg_recache
122
123 %postun
124 %ghc_pkg_recache
125
126 %files
127 %defattr(644,root,root,755)
128 %doc LICENSE README.markdown
129 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
130 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
131 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHScase-insensitive-%{version}-*.so
132 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHScase-insensitive-%{version}-*.a
133 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHScase-insensitive-%{version}-*_p.a
134 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
135 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.hi
136 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.dyn_hi
137 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/CaseInsensitive
138 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/CaseInsensitive/*.hi
139 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/CaseInsensitive/*.dyn_hi
140
141 %if %{with prof}
142 %files prof
143 %defattr(644,root,root,755)
144 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHScase-insensitive-%{version}-*_p.a
145 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.p_hi
146 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/CaseInsensitive/*.p_hi
147 %endif
148
149 %files doc
150 %defattr(644,root,root,755)
151 %doc %{name}-%{version}-doc/*
This page took 0.090211 seconds and 3 git commands to generate.