]> git.pld-linux.org Git - packages/ghc-blaze-markup.git/blob - ghc-blaze-markup.spec
- release 2 (by relup.sh)
[packages/ghc-blaze-markup.git] / ghc-blaze-markup.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname blaze-markup
6 Summary:        A blazingly fast markup combinator library for Haskell
7 Summary(pl.UTF-8):      Biblioteka olśniewająco szybkiego kombinatora dodającego znaczniki
8 Name:           ghc-%{pkgname}
9 Version:        0.8.2.5
10 Release:        2
11 License:        BSD
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/blaze-markup
14 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  75ad355f7d3c32881997b4164ac95e3b
16 URL:            http://hackage.haskell.org/package/blaze-markup
17 BuildRequires:  ghc >= 6.12.3
18 BuildRequires:  ghc-base >= 4
19 BuildRequires:  ghc-base < 5
20 BuildRequires:  ghc-blaze-builder >= 0.3
21 BuildRequires:  ghc-blaze-builder < 0.5
22 BuildRequires:  ghc-bytestring >= 0.9
23 BuildRequires:  ghc-bytestring < 0.11
24 BuildRequires:  ghc-text >= 0.10
25 BuildRequires:  ghc-text < 1.3
26 %if %{with prof}
27 BuildRequires:  ghc-prof
28 BuildRequires:  ghc-base-prof >= 4
29 BuildRequires:  ghc-base-prof < 5
30 BuildRequires:  ghc-blaze-builder-prof >= 0.3
31 BuildRequires:  ghc-blaze-builder-prof < 0.5
32 BuildRequires:  ghc-bytestring-prof >= 0.9
33 BuildRequires:  ghc-bytestring-prof < 0.11
34 BuildRequires:  ghc-text-prof >= 0.10
35 BuildRequires:  ghc-text-prof < 1.3
36 %endif
37 BuildRequires:  rpmbuild(macros) >= 1.608
38 Requires(post,postun):  /usr/bin/ghc-pkg
39 %requires_eq    ghc
40 Requires:       ghc-base >= 4
41 Requires:       ghc-base < 5
42 Requires:       ghc-blaze-builder >= 0.3
43 Requires:       ghc-blaze-builder < 0.5
44 Requires:       ghc-bytestring >= 0.9
45 Requires:       ghc-bytestring < 0.11
46 Requires:       ghc-text >= 0.10
47 Requires:       ghc-text < 1.3
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 # debuginfo is not useful for ghc
51 %define         _enable_debug_packages  0
52
53 # don't compress haddock files
54 %define         _noautocompressdoc      *.haddock
55
56 %description
57 Core modules of a blazingly fast markup combinator library for the
58 Haskell programming language.
59
60 %description -l pl.UTF-8
61 Podstawowe moduły biblioteki olśniewająco szybkiego kombinatora
62 dodającego znaczniki dla języka programowania Haskell.
63
64 %package prof
65 Summary:        Profiling %{pkgname} library for GHC
66 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       ghc-base-prof >= 4
70 Requires:       ghc-base-prof < 5
71 Requires:       ghc-blaze-builder-prof >= 0.3
72 Requires:       ghc-blaze-builder-prof < 0.5
73 Requires:       ghc-bytestring-prof >= 0.9
74 Requires:       ghc-bytestring-prof < 0.11
75 Requires:       ghc-text-prof >= 0.10
76 Requires:       ghc-text-prof < 1.3
77
78 %description prof
79 Profiling %{pkgname} library for GHC.  Should be installed when
80 GHC's profiling subsystem is needed.
81
82 %description prof -l pl.UTF-8
83 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
84 kiedy potrzebujemy systemu profilującego z GHC.
85
86 %package doc
87 Summary:        HTML documentation for %{pkgname} ghc package
88 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
89 Group:          Documentation
90
91 %description doc
92 HTML documentation for %{pkgname} ghc package.
93
94 %description doc -l pl.UTF-8
95 Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
96
97 %prep
98 %setup -q -n %{pkgname}-%{version}
99
100 %build
101 runhaskell Setup.hs configure -v2 \
102         %{?with_prof:--enable-library-profiling} \
103         --prefix=%{_prefix} \
104         --libdir=%{_libdir} \
105         --libexecdir=%{_libexecdir} \
106         --docdir=%{_docdir}/%{name}-%{version}
107
108 runhaskell Setup.hs build
109 runhaskell Setup.hs haddock --executables
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
114
115 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
116
117 # work around automatic haddock docs installation
118 %{__rm} -rf %{name}-%{version}-doc
119 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
120 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
121
122 runhaskell Setup.hs register \
123         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post
129 %ghc_pkg_recache
130
131 %postun
132 %ghc_pkg_recache
133
134 %files
135 %defattr(644,root,root,755)
136 %doc LICENSE
137 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
138 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
139 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSblaze-markup-%{version}-*.so
140 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSblaze-markup-%{version}-*.a
141 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSblaze-markup-%{version}-*_p.a
142 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
143 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze.hi
144 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze.dyn_hi
145 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze
146 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/*.hi
147 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/*.dyn_hi
148 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Renderer
149 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Renderer/*.hi
150 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Renderer/*.dyn_hi
151
152 %if %{with prof}
153 %files prof
154 %defattr(644,root,root,755)
155 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSblaze-markup-%{version}-*_p.a
156 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze.p_hi
157 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/*.p_hi
158 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Renderer/*.p_hi
159 %endif
160
161 %files doc
162 %defattr(644,root,root,755)
163 %doc %{name}-%{version}-doc/*
This page took 0.117702 seconds and 3 git commands to generate.