]> git.pld-linux.org Git - packages/ghc-blaze-html.git/blob - ghc-blaze-html.spec
e46ca6ddc4bb08b804b02014605b17e52ef9fb54
[packages/ghc-blaze-html.git] / ghc-blaze-html.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname blaze-html
6 Summary:        A blazingly fast HTML combinator library for Haskell
7 Summary(pl.UTF-8):      Biblioteka olśniewająco szybkiego kombinatora HTML dla Haskella
8 Name:           ghc-%{pkgname}
9 Version:        0.6.1.2
10 Release:        1
11 License:        BSD
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/blaze-html
14 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  262a4753fc37f6a8b8762f2b1f6d1bab
16 URL:            http://hackage.haskell.org/package/blaze-html
17 BuildRequires:  ghc >= 6.12.3
18 BuildRequires:  ghc-base >= 4
19 BuildRequires:  ghc-base < 5
20 BuildRequires:  ghc-blaze-builder >= 0.2
21 BuildRequires:  ghc-blaze-builder < 0.4
22 BuildRequires:  ghc-blaze-markup >= 0.5.1
23 BuildRequires:  ghc-blaze-markup < 0.6
24 BuildRequires:  ghc-bytestring >= 0.9
25 BuildRequires:  ghc-bytestring < 0.11
26 BuildRequires:  ghc-text >= 0.10
27 BuildRequires:  ghc-text < 1.1
28 %if %{with prof}
29 BuildRequires:  ghc-prof
30 BuildRequires:  ghc-base-prof >= 4
31 BuildRequires:  ghc-base-prof < 5
32 BuildRequires:  ghc-blaze-builder-prof >= 0.2
33 BuildRequires:  ghc-blaze-builder-prof < 0.4
34 BuildRequires:  ghc-blaze-markup-prof >= 0.5.1
35 BuildRequires:  ghc-blaze-markup-prof < 0.6
36 BuildRequires:  ghc-bytestring-prof >= 0.9
37 BuildRequires:  ghc-bytestring-prof < 0.11
38 BuildRequires:  ghc-text-prof >= 0.10
39 BuildRequires:  ghc-text-prof < 1.1
40 %endif
41 BuildRequires:  rpmbuild(macros) >= 1.608
42 Requires(post,postun):  /usr/bin/ghc-pkg
43 %requires_releq ghc
44 Requires:       ghc-base >= 4
45 Requires:       ghc-base < 5
46 Requires:       ghc-blaze-builder >= 0.2
47 Requires:       ghc-blaze-builder < 0.4
48 Requires:       ghc-blaze-markup >= 0.5.1
49 Requires:       ghc-blaze-markup < 0.6
50 Requires:       ghc-bytestring >= 0.9
51 Requires:       ghc-bytestring < 0.11
52 Requires:       ghc-text >= 0.10
53 Requires:       ghc-text < 1.1
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 # debuginfo is not useful for ghc
57 %define         _enable_debug_packages  0
58
59 # don't compress haddock files
60 %define         _noautocompressdoc      *.haddock
61
62 %description
63 A blazingly fast HTML combinator library for the Haskell programming
64 language.
65
66 %description -l pl.UTF-8
67 Biblioteka olśniewająco szybkiego kombinatora HTML dla języka
68 programowania Haskell.
69
70 %package prof
71 Summary:        Profiling %{pkgname} library for GHC
72 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       ghc-base-prof >= 4
76 Requires:       ghc-base-prof < 5
77 Requires:       ghc-blaze-builder-prof >= 0.2
78 Requires:       ghc-blaze-builder-prof < 0.4
79 Requires:       ghc-blaze-markup-prof >= 0.5.1
80 Requires:       ghc-blaze-markup-prof < 0.6
81 Requires:       ghc-bytestring-prof >= 0.9
82 Requires:       ghc-bytestring-prof < 0.11
83 Requires:       ghc-text-prof >= 0.10
84 Requires:       ghc-text-prof < 1.1
85
86 %description prof
87 Profiling %{pkgname} library for GHC.  Should be installed when
88 GHC's profiling subsystem is needed.
89
90 %description prof -l pl.UTF-8
91 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
92 kiedy potrzebujemy systemu profilującego z GHC.
93
94 %package doc
95 Summary:        HTML documentation for %{pkgname} ghc package
96 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
97 Group:          Documentation
98
99 %description doc
100 HTML documentation for %{pkgname} ghc package.
101
102 %description doc -l pl.UTF-8
103 Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
104
105 %prep
106 %setup -q -n %{pkgname}-%{version}
107
108 %build
109 runhaskell Setup.hs configure -v2 \
110         %{?with_prof:--enable-library-profiling} \
111         --prefix=%{_prefix} \
112         --libdir=%{_libdir} \
113         --libexecdir=%{_libexecdir} \
114         --docdir=%{_docdir}/%{name}-%{version}
115
116 runhaskell Setup.hs build
117 runhaskell Setup.hs haddock --executables
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
122
123 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
124
125 # work around automatic haddock docs installation
126 %{__rm} -rf %{name}-%{version}-doc
127 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
128 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
129
130 runhaskell Setup.hs register \
131         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post
137 %ghc_pkg_recache
138
139 %postun
140 %ghc_pkg_recache
141
142 %files
143 %defattr(644,root,root,755)
144 %doc LICENSE
145 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
146 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
147 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/HSblaze-html-%{version}.o
148 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSblaze-html-%{version}.a
149 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
150 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze
151 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/*.hi
152 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html
153 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html/Renderer
154 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html/Renderer/*.hi
155 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html4
156 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html4/*.hi
157 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html4/FrameSet
158 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html4/FrameSet/*.hi
159 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html4/Strict
160 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html4/Strict/*.hi
161 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html4/Transitional
162 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html4/Transitional/*.hi
163 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html5
164 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html5/*.hi
165 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml1
166 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml1/*.hi
167 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml1/FrameSet
168 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml1/FrameSet/*.hi
169 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml1/Strict
170 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml1/Strict/*.hi
171 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml1/Transitional
172 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml1/Transitional/*.hi
173 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml5
174 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml5/*.hi
175
176 %if %{with prof}
177 %files prof
178 %defattr(644,root,root,755)
179 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSblaze-html-%{version}_p.a
180 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/*.p_hi
181 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html/Renderer/*.p_hi
182 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html4/*.p_hi
183 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html4/FrameSet/*.p_hi
184 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html4/Strict/*.p_hi
185 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html4/Transitional/*.p_hi
186 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Html5/*.p_hi
187 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml1/*.p_hi
188 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml1/FrameSet/*.p_hi
189 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml1/Strict/*.p_hi
190 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml1/Transitional/*.p_hi
191 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/XHtml5/*.p_hi
192 %endif
193
194 %files doc
195 %defattr(644,root,root,755)
196 %doc %{name}-%{version}-doc/*
This page took 0.187712 seconds and 2 git commands to generate.