]> git.pld-linux.org Git - packages/ghc-binary.git/blob - ghc-binary.spec
- up to 0.8.8.0
[packages/ghc-binary.git] / ghc-binary.spec
1 %define         pkgname binary
2 Summary:        Binary serialisation for Haskell values using lazy ByteStrings
3 Name:           ghc-%{pkgname}
4 Version:        0.8.8.0
5 Release:        1
6 License:        BSD
7 Group:          Development/Languages
8 Source0:        http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9 # Source0-md5:  fdec925b21bd42fa4e9df5505d15ba81
10 URL:            http://hackage.haskell.org/package/binary/
11 BuildRequires:  ghc >= 6.12.3
12 BuildRequires:  rpmbuild(macros) >= 1.608
13 %requires_eq    ghc
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 # debuginfo is not useful for ghc
17 %define         _enable_debug_packages  0
18
19 %description
20 Efficient, pure binary serialisation using lazy ByteStrings. Haskell
21 values may be encoded to and from binary formats, written to disk as
22 binary, or sent over the network. Serialisation speeds of over 1 G/sec
23 have been observed, so this library should be suitable for high
24 performance scenarios.
25
26 %package doc
27 Summary:        HTML documentation for %{pkgname}
28 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
29 Group:          Documentation
30
31 %description doc
32 HTML documentation for %{pkgname}.
33
34 %description doc -l pl.UTF-8
35 Dokumentacja w formacie HTML dla %{pkgname}.
36
37 %prep
38 %setup -q -n %{pkgname}-%{version}
39
40 %build
41 runhaskell Setup.lhs configure -v2 \
42         --prefix=%{_prefix} \
43         --libdir=%{_libdir} \
44         --libexecdir=%{_libexecdir} \
45         --docdir=%{_docdir}/%{name}-%{version}
46
47 runhaskell Setup.lhs build
48 runhaskell Setup.lhs haddock --executables
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
53
54 runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
55
56 # work around automatic haddock docs installation
57 %{__rm} -rf %{name}-%{version}-doc
58 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
59 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
60
61 runhaskell Setup.lhs register \
62         --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 %ghc_pkg_recache
69
70 %postun
71 %ghc_pkg_recache
72
73 %files
74 %defattr(644,root,root,755)
75 %doc README.md
76 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
77 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
78
79 %files doc
80 %defattr(644,root,root,755)
81 %doc %{name}-%{version}-doc/*
This page took 0.056794 seconds and 3 git commands to generate.