]> git.pld-linux.org Git - packages/ghc-alsa-mixer.git/blob - ghc-alsa-mixer.spec
f07489a15fd43548201e486cda94bbd654cc35d6
[packages/ghc-alsa-mixer.git] / ghc-alsa-mixer.spec
1 %define         pkgname alsa-mixer
2 Summary:        A Haskell binding to the alsa-mixer graphics library
3 Name:           ghc-%{pkgname}
4 Version:        0.1.2
5 Release:        1
6 License:        BSD
7 Group:          Development/Languages
8 Source0:        http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9 # Source0-md5:  839b461c977d21c61ee49a1ed1d67482
10 URL:            http://hackage.haskell.org/package/alsa-mixer/
11 BuildRequires:  ghc >= 6.12.3
12 BuildRequires:  ghc-alsa-core >= 0.5
13 BuildRequires:  ghc-c2hs
14 BuildRequires:  rpmbuild(macros) >= 1.608
15 %requires_eq    ghc
16 Requires:       ghc-alsa-core >= 0.5
17 Requires:       ghc-c2hs
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 # debuginfo is not useful for ghc
21 %define         _enable_debug_packages  0
22
23 %description
24 A Haskell binding to the alsa-mixer graphics library.
25
26 %package doc
27 Summary:        HTML documentation for %{pkgname}
28 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
29 Group:          Documentation
30
31 %description doc
32 HTML documentation for %{pkgname}.
33
34 %description doc -l pl.UTF-8
35 Dokumentacja w formacie HTML dla %{pkgname}.
36
37 %prep
38 %setup -q -n %{pkgname}-%{version}
39
40 %build
41 runhaskell Setup.hs configure -v2 \
42         --prefix=%{_prefix} \
43         --libdir=%{_libdir} \
44         --libexecdir=%{_libexecdir} \
45         --docdir=%{_docdir}/%{name}-%{version}
46
47 runhaskell Setup.hs build
48 runhaskell Setup.hs haddock --executables
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
53
54 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
55
56 # work around automatic haddock docs installation
57 rm -rf %{name}-%{version}-doc
58 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
59 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
60
61 runhaskell Setup.hs register \
62         --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 %ghc_pkg_recache
69
70 %postun
71 %ghc_pkg_recache
72
73 %files
74 %defattr(644,root,root,755)
75 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
76 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
77
78 %files doc
79 %defattr(644,root,root,755)
80 %doc %{name}-%{version}-doc/*
This page took 0.087339 seconds and 2 git commands to generate.