]> git.pld-linux.org Git - packages/ghc-MonadCatchIO-transformers.git/blob - ghc-MonadCatchIO-transformers.spec
- updated to 0.3.1.0, pl, unified
[packages/ghc-MonadCatchIO-transformers.git] / ghc-MonadCatchIO-transformers.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname MonadCatchIO-transformers
6 Summary:        Monad-transformer compatible version of the Control.Exception module
7 Summary(pl.UTF-8):      Wersja modułu Control.Exception zgodna z transformatorami monad
8 Name:           ghc-%{pkgname}
9 Version:        0.3.1.0
10 Release:        1
11 License:        BSD
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/MonadCatchIO-transformers
14 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  3b54254de4a192fdbdea06d2950cac8d
16 URL:            http://hackage.haskell.org/package/MonadCatchIO-transformers
17 BuildRequires:  ghc >= 6.12.3
18 BuildRequires:  ghc-base < 4.8
19 BuildRequires:  ghc-extensible-exceptions >= 0.1
20 BuildRequires:  ghc-extensible-exceptions < 0.2
21 BuildRequires:  ghc-monads-tf >= 0.1
22 BuildRequires:  ghc-monads-tf < 0.2
23 BuildRequires:  ghc-transformers >= 0.2
24 BuildRequires:  ghc-transformers < 0.4
25 %if %{with prof}
26 BuildRequires:  ghc-prof >= 6.12.3
27 BuildRequires:  ghc-base-prof < 4.8
28 BuildRequires:  ghc-extensible-exceptions-prof >= 0.1
29 BuildRequires:  ghc-extensible-exceptions-prof < 0.2
30 BuildRequires:  ghc-monads-tf-prof >= 0.1
31 BuildRequires:  ghc-monads-tf-prof < 0.2
32 BuildRequires:  ghc-transformers-prof >= 0.2
33 BuildRequires:  ghc-transformers-prof < 0.4
34 %endif
35 BuildRequires:  rpmbuild(macros) >= 1.608
36 %requires_releq ghc
37 Requires(post,postun):  /usr/bin/ghc-pkg
38 Requires:       ghc-base < 4.8
39 Requires:       ghc-extensible-exceptions >= 0.1
40 Requires:       ghc-extensible-exceptions < 0.2
41 Requires:       ghc-monads-tf >= 0.1
42 Requires:       ghc-monads-tf < 0.2
43 Requires:       ghc-transformers >= 0.2
44 Requires:       ghc-transformers < 0.4
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 # debuginfo is not useful for ghc
48 %define         _enable_debug_packages  0
49
50 # don't compress haddoc files
51 %define         _noautocompressdoc      *.haddock
52
53 %description
54 Provides functions to throw and catch exceptions. Unlike the functions
55 from Control.Exception, which work in IO, these work in any stack of
56 monad transformers (from the transformers package) with IO as the base
57 monad. You can extend this functionality to other monads, by creating
58 an instance of the MonadCatchIO class.
59
60 %description -l pl.UTF-8
61 Ten pakiet dostarcza funkcje do rzucania i przechwytywania wyjątków. W
62 przeciwieństwie do funkcji z Control.Exceptions, działających w IO, te
63 działają w dowolnym stosie transformatorów monad (z pakietu
64 transformers) z IO jako podstawową monadą. Można rozszerzać tę
65 funkcjonalność na inne monady poprzez tworzenie instancji klasy
66 MonadCatchIO.
67
68 %package prof
69 Summary:        Profiling %{pkgname} library for GHC
70 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC.
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       ghc-base-prof < 4.8
74 Requires:       ghc-extensible-exceptions-prof >= 0.1
75 Requires:       ghc-extensible-exceptions-prof < 0.2
76 Requires:       ghc-monads-tf-prof >= 0.1
77 Requires:       ghc-monads-tf-prof < 0.2
78 Requires:       ghc-transformers-prof >= 0.2
79 Requires:       ghc-transformers-prof < 0.4
80
81 %description prof
82 Profiling %{pkgname} library for GHC.  Should be installed when
83 GHC's profiling subsystem is needed.
84
85 %description prof -l pl.UTF-8
86 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
87 kiedy potrzebujemy systemu profilującego z GHC.
88
89 %prep
90 %setup -q -n %{pkgname}-%{version}
91
92 %build
93 runhaskell Setup.hs configure -v2 \
94         %{?with_prof:--enable-library-profiling} \
95         --prefix=%{_prefix} \
96         --libdir=%{_libdir} \
97         --libexecdir=%{_libexecdir} \
98         --docdir=%{_docdir}/%{name}-%{version}
99
100 runhaskell Setup.hs build
101 runhaskell Setup.hs haddock --executables
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
106
107 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
108
109 # work around automatic haddock docs installation
110 %{__rm} -rf %{name}-%{version}-doc
111 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
112 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
113
114 runhaskell Setup.hs register \
115         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 %ghc_pkg_recache
122
123 %postun
124 %ghc_pkg_recache
125
126 %files
127 %defattr(644,root,root,755)
128 %doc %{name}-%{version}-doc/*
129 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
130 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
131 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/HSMonadCatchIO-transformers-%{version}.o
132 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSMonadCatchIO-transformers-%{version}.a
133 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control
134 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad
135 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/CatchIO.hi
136 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/CatchIO
137 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/CatchIO/*.hi
138
139 %files prof
140 %defattr(644,root,root,755)
141 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSMonadCatchIO-transformers-%{version}_p.a
142 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/CatchIO.p_hi
143 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/CatchIO/*.p_hi
This page took 0.085533 seconds and 3 git commands to generate.