]> git.pld-linux.org Git - packages/ghc-MissingH.git/blob - ghc-MissingH.spec
d9866ce331f39716fba7c8fe20c702b55c807adb
[packages/ghc-MissingH.git] / ghc-MissingH.spec
1 %define         pkgname MissingH
2 Summary:        Large utility library
3 Name:           ghc-%{pkgname}
4 Version:        1.2.0.0
5 Release:        1
6 Group:          Libraries
7 # Data/Hash/CRC32/GZip.hs is BSD
8 # Data/Hash/CRC32/Posix.hs is GPL+
9 # System/Path/NameManip.hs is LGPLv2+
10 # System/Time/ParseDate.hs is GPLv2 (newer parsedate is now BSD)
11 # all 40 other src (and testsrc) files are GPLv2+
12 License:        GPL v2+
13 URL:            http://hackage.haskell.org/package/MissingH
14 Source0:        http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  1b932f4637fedcb3b451e5aa9179c304
16 BuildRequires:  ghc >= 6.12.3
17 BuildRequires:  ghc-HUnit
18 BuildRequires:  ghc-hslogger
19 BuildRequires:  ghc-mtl
20 BuildRequires:  ghc-network
21 BuildRequires:  ghc-parsec
22 BuildRequires:  ghc-prof
23 BuildRequires:  ghc-random
24 BuildRequires:  ghc-regex-compat
25 BuildRequires:  rpmbuild(macros) >= 1.608
26 %requires_eq    ghc
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # debuginfo is not useful for ghc
30 %define         _enable_debug_packages  0
31
32 %description
33 MissingH is a library of all sorts of utility functions for Haskell
34 programmers. It is written in pure Haskell and thus should be
35 extremely portable and easy to use.
36
37 %package doc
38 Summary:        HTML documentation for %{pkgname}
39 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
40 Group:          Documentation
41
42 %description doc
43 HTML documentation for %{pkgname}.
44
45 %description doc -l pl.UTF-8
46 Dokumentacja w formacie HTML dla %{pkgname}.
47
48 %prep
49 %setup -q -n %{pkgname}-%{version}
50
51 %build
52 runhaskell Setup.hs configure -v2 \
53         --prefix=%{_prefix} \
54         --libdir=%{_libdir} \
55         --libexecdir=%{_libexecdir} \
56         --docdir=%{_docdir}/%{name}-%{version}
57
58 runhaskell Setup.hs build
59 runhaskell Setup.hs haddock --executables
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
64
65 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
66
67 # work around automatic haddock docs installation
68 rm -rf %{name}-%{version}-doc
69 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
70
71 runhaskell Setup.hs register \
72         --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
73
74 rm -rf $RPM_BUILD_ROOT/%{_docdir}/%{name}-%{version}
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 %ghc_pkg_recache
80
81 %postun
82 %ghc_pkg_recache
83
84 %files
85 %defattr(644,root,root,755)
86 %doc TODO
87 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
88 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
89
90 %files doc
91 %defattr(644,root,root,755)
92 %doc %{name}-%{version}-doc/*
This page took 0.05337 seconds and 2 git commands to generate.