]> git.pld-linux.org Git - packages/gflags.git/blob - gflags.spec
- updated to 2.1.2
[packages/gflags.git] / gflags.spec
1 Summary:        A commandline flags library that allows for distributed flags
2 Summary(pl.UTF-8):      Biblioteka flag linii poleceń pozwalająca na rozproszone flagi
3 Name:           gflags
4 Version:        2.1.2
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 #Source0Download: https://github.com/gflags/gflags/releases
9 Source0:        https://github.com/schuhschuh/gflags/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  ac432de923f9de1e9780b5254884599f
11 Source1:        libgflags.pc
12 Source2:        libgflags_nothreads.pc
13 Patch0:         %{name}-nothreads.patch
14 URL:            http://gflags.github.io/gflags/
15 BuildRequires:  cmake >= 2.8.4
16 BuildRequires:  libstdc++-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 gflags is Google's commandline flags library. It differs from other
21 libraries, such as getopt(), in that flag definitions can be scattered
22 around the source code, and not just listed in one place such as
23 main().
24
25 %description -l pl.UTF-8
26 gflags to biblioteka flag linii poleceń stworzona przez Google. Różni
27 się od innych bibliotek, takich jak getopt(), tym, że definicje flag
28 mogą być rozproszone po kodzie źródłowym, a nie wypisane tylko w
29 jednym miejscu, takim jak main().
30
31 %package devel
32 Summary:        Header files for gflags library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gflags
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       libstdc++-devel
37
38 %description devel
39 Header files for gflags library.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe biblioteki gflags.
43
44 %package static
45 Summary:        Static gflags library
46 Summary(pl.UTF-8):      Statyczna biblioteka gflags
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description static
51 Static gflags library.
52
53 %description static -l pl.UTF-8
54 Statyczna biblioteka gflags.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59
60 %{__sed} -i \
61         -e 's|LIBRARY_INSTALL_DIR lib|LIBRARY_INSTALL_DIR %{_lib}|g' \
62         -e 's|CONFIG_INSTALL_DIR  lib/cmake|CONFIG_INSTALL_DIR  %{_lib}/cmake|g' \
63         CMakeLists.txt
64
65 %build
66 install -d build
67 cd build
68 %cmake .. \
69         -DBUILD_STATIC_LIBS=ON
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} -C build install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 # .pc files used to be provided before gflags 2.1; reintroduce them
79 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
80 for f in %{SOURCE1} %{SOURCE2} ; do
81         sed -e "s|@prefix@|%{_prefix}|;s|@libdir@|%{_libdir}|" "$f" \
82                 >$RPM_BUILD_ROOT%{_pkgconfigdir}/$(basename $f)
83 done
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS.txt COPYING.txt ChangeLog.txt README.md
94 %attr(755,root,root) %{_bindir}/gflags_completions.sh
95 %attr(755,root,root) %{_libdir}/libgflags.so.*.*.*
96 %attr(755,root,root) %ghost %{_libdir}/libgflags.so.2
97 %attr(755,root,root) %{_libdir}/libgflags_nothreads.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libgflags_nothreads.so.2
99
100 %files devel
101 %defattr(644,root,root,755)
102 %doc doc/{index.html,designstyle.css}
103 %attr(755,root,root) %{_libdir}/libgflags.so
104 %attr(755,root,root) %{_libdir}/libgflags_nothreads.so
105 %{_includedir}/gflags
106 %{_pkgconfigdir}/libgflags.pc
107 %{_pkgconfigdir}/libgflags_nothreads.pc
108 %{_libdir}/cmake/gflags
109
110 %files static
111 %defattr(644,root,root,755)
112 %{_libdir}/libgflags.a
113 %{_libdir}/libgflags_nothreads.a
This page took 0.052696 seconds and 3 git commands to generate.