]> git.pld-linux.org Git - packages/gexiv2.git/blob - gexiv2.spec
d6c2ebfc11058dcb0afa52ba3b5961fe4dbd86f3
[packages/gexiv2.git] / gexiv2.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # static library
5
6 Summary:        GObject-based wrapper around the Exiv2 library
7 Summary(pl.UTF-8):      Oparte na GObject obudowanie biblioteki Exiv2
8 Name:           gexiv2
9 Version:        0.14.0
10 Release:        1
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        https://download.gnome.org/sources/gexiv2/0.14/%{name}-%{version}.tar.xz
14 # Source0-md5:  b4b1ac55bf9d32fb36a35eb346e1728e
15 URL:            https://wiki.gnome.org/Projects/gexiv2
16 BuildRequires:  exiv2-devel >= 0.27.4
17 BuildRequires:  glib2-devel >= 1:2.46.0
18 BuildRequires:  gobject-introspection-devel >= 0.10
19 BuildRequires:  gtk-doc >= 1.14
20 BuildRequires:  libstdc++-devel >= 6:4.7
21 BuildRequires:  meson >= 0.48
22 BuildRequires:  ninja >= 1.5
23 BuildRequires:  pkgconfig >= 1:0.26
24 BuildRequires:  python >= 2
25 BuildRequires:  python-pygobject3-devel >= 3
26 BuildRequires:  python3 >= 1:3.2
27 BuildRequires:  python3-pygobject3-devel >= 3
28 BuildRequires:  rpm-build >= 4.6
29 BuildRequires:  rpmbuild(macros) >= 1.752
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  vala
32 BuildRequires:  xz
33 Requires:       exiv2-libs >= 0.27.4
34 Requires:       glib2 >= 1:2.46.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 gexiv2 is a GObject-based wrapper around the Exiv2 library. It makes
39 the basic features of Exiv2 available to GNOME applications.
40
41 %description -l pl.UTF-8
42 gexiv2 to oparte na GObject obudowanie biblioteki Exiv2. Udostępnia
43 podstawowe możliwości Exiv2 aplikacjom GNOME.
44
45 %package devel
46 Summary:        Header files for gexiv2 library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gexiv2
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       exiv2-devel >= 0.27.4
51 Requires:       glib2-devel >= 1:2.46.0
52 Requires:       libstdc++-devel
53
54 %description devel
55 Header files for gexiv2 library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki gexiv2.
59
60 %package static
61 Summary:        Static gexiv2 library
62 Summary(pl.UTF-8):      Statyczna biblioteka gexiv2
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static gexiv2 library.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka gexiv2.
71
72 %package apidocs
73 Summary:        gexiv2 API documentation
74 Summary(pl.UTF-8):      Dokumentacja API gexiv2
75 Group:          Documentation
76 Requires:       gtk-doc-common
77 BuildArch:      noarch
78
79 %description apidocs
80 gexiv2 API documentation.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API gexiv2.
84
85 %package -n python-gexiv2
86 Summary:        Python 2 binding for gexiv2 library
87 Summary(pl.UTF-8):      Wiązanie Pythona 2 do biblioteki gexiv2
88 Group:          Development/Languages/Python
89 Requires:       %{name} = %{version}-%{release}
90 Requires:       python-pygobject3 >= 3
91
92 %description -n python-gexiv2
93 Python 2 binding for gexiv2 library.
94
95 %description -n python-gexiv2 -l pl.UTF-8
96 Wiązanie Pythona 2 do biblioteki gexiv2.
97
98 %package -n python3-gexiv2
99 Summary:        Python 3 binding for gexiv2 library
100 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki gexiv2
101 Group:          Development/Languages/Python
102 Requires:       %{name} = %{version}-%{release}
103 Requires:       python3-pygobject3 >= 3
104
105 %description -n python3-gexiv2
106 Python 3 binding for gexiv2 library.
107
108 %description -n python3-gexiv2 -l pl.UTF-8
109 Wiązanie Pythona 3 do biblioteki gexiv2.
110
111 %package -n vala-gexiv2
112 Summary:        Vala binding for gexiv2 library
113 Summary(pl.UTF-8):      Wiązanie języka vala do biblioteki gexiv2
114 Group:          Development/Languages
115 Requires:       %{name}-devel = %{version}-%{release}
116 BuildArch:      noarch
117
118 %description -n vala-gexiv2
119 Vala binding for gexiv2 library.
120
121 %description -n vala-gexiv2 -l pl.UTF-8
122 Wiązanie języka vala do biblioteki gexiv2.
123
124 %prep
125 %setup -q
126
127 %build
128 %meson build \
129         %{?with_apidocs:-Dgtk_doc=true}
130
131 %ninja_build -C build
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %ninja_install -C build
137
138 # no longer installed by meson
139 install -d $RPM_BUILD_ROOT%{py_sitedir}/gi/overrides
140 cp -p GExiv2.py $RPM_BUILD_ROOT%{py_sitedir}/gi/overrides
141 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/gi/overrides
142 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/gi/overrides
143 %py_postclean
144
145 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/gi/overrides
146 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/gi/overrides
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 %doc AUTHORS NEWS README THANKS
157 %attr(755,root,root) %{_libdir}/libgexiv2.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libgexiv2.so.2
159 %{_libdir}/girepository-1.0/GExiv2-0.10.typelib
160
161 %files devel
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libgexiv2.so
164 %{_datadir}/gir-1.0/GExiv2-0.10.gir
165 %{_includedir}/gexiv2
166 %{_pkgconfigdir}/gexiv2.pc
167
168 %if %{with static_libs}
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/libgexiv2.a
172 %endif
173
174 %if %{with apidocs}
175 %files apidocs
176 %defattr(644,root,root,755)
177 %{_gtkdocdir}/gexiv2
178 %endif
179
180 %files -n python-gexiv2
181 %defattr(644,root,root,755)
182 %{py_sitedir}/gi/overrides/GExiv2.py[co]
183
184 %files -n python3-gexiv2
185 %defattr(644,root,root,755)
186 %{py3_sitedir}/gi/overrides/GExiv2.py
187 %{py3_sitedir}/gi/overrides/__pycache__/GExiv2.cpython-*.py[co]
188
189 %files -n vala-gexiv2
190 %defattr(644,root,root,755)
191 %{_datadir}/vala/vapi/gexiv2.deps
192 %{_datadir}/vala/vapi/gexiv2.vapi
This page took 0.162888 seconds and 2 git commands to generate.