]> git.pld-linux.org Git - packages/gexiv2.git/blob - gexiv2.spec
- updated to 0.12.1
[packages/gexiv2.git] / gexiv2.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # static library
5
6 Summary:        GObject-based wrapper around the Exiv2 library
7 Summary(pl.UTF-8):      Oparte na GObject obudowanie biblioteki Exiv2
8 Name:           gexiv2
9 Version:        0.12.1
10 Release:        1
11 License:        GPL v2
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gexiv2/0.12/%{name}-%{version}.tar.xz
14 # Source0-md5:  44a3cfeab1afd83a71e852835d24e656
15 URL:            https://wiki.gnome.org/Projects/gexiv2
16 BuildRequires:  exiv2-devel >= 0.26
17 BuildRequires:  glib2-devel >= 1:2.38.0
18 BuildRequires:  gobject-introspection-devel >= 0.10
19 BuildRequires:  gtk-doc >= 1.14
20 BuildRequires:  libstdc++-devel >= 6:4.7
21 BuildRequires:  meson
22 BuildRequires:  ninja >= 1.5
23 BuildRequires:  pkgconfig >= 1:0.26
24 BuildRequires:  python >= 2
25 BuildRequires:  python-pygobject3-devel >= 3
26 BuildRequires:  python3 >= 1:3.2
27 BuildRequires:  python3-pygobject3-devel >= 3
28 BuildRequires:  rpmbuild(macros) >= 1.736
29 BuildRequires:  vala
30 Requires:       exiv2-libs >= 0.26
31 Requires:       glib2 >= 1:2.38.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 gexiv2 is a GObject-based wrapper around the Exiv2 library. It makes
36 the basic features of Exiv2 available to GNOME applications.
37
38 %description -l pl.UTF-8
39 gexiv2 to oparte na GObject obudowanie biblioteki Exiv2. Udostępnia
40 podstawowe możliwości Exiv2 aplikacjom GNOME.
41
42 %package devel
43 Summary:        Header files for gexiv2 library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gexiv2
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       exiv2-devel >= 0.26
48 Requires:       glib2-devel >= 1:2.38.0
49 Requires:       libstdc++-devel
50
51 %description devel
52 Header files for gexiv2 library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki gexiv2.
56
57 %package static
58 Summary:        Static gexiv2 library
59 Summary(pl.UTF-8):      Statyczna biblioteka gexiv2
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static gexiv2 library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka gexiv2.
68
69 %package apidocs
70 Summary:        gexiv2 API documentation
71 Summary(pl.UTF-8):      Dokumentacja API gexiv2
72 Group:          Documentation
73 Requires:       gtk-doc-common
74 %if "%{_rpmversion}" >= "5"
75 BuildArch:      noarch
76 %endif
77
78 %description apidocs
79 gexiv2 API documentation.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API gexiv2.
83
84 %package -n python-gexiv2
85 Summary:        Python 2 binding for gexiv2 library
86 Summary(pl.UTF-8):      Wiązanie Pythona 2 do biblioteki gexiv2
87 Group:          Development/Languages/Python
88 Requires:       %{name} = %{version}-%{release}
89 Requires:       python-pygobject3 >= 3
90
91 %description -n python-gexiv2
92 Python 2 binding for gexiv2 library.
93
94 %description -n python-gexiv2 -l pl.UTF-8
95 Wiązanie Pythona 2 do biblioteki gexiv2.
96
97 %package -n python3-gexiv2
98 Summary:        Python 3 binding for gexiv2 library
99 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki gexiv2
100 Group:          Development/Languages/Python
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       python3-pygobject3 >= 3
103
104 %description -n python3-gexiv2
105 Python 3 binding for gexiv2 library.
106
107 %description -n python3-gexiv2 -l pl.UTF-8
108 Wiązanie Pythona 3 do biblioteki gexiv2.
109
110 %package -n vala-gexiv2
111 Summary:        Vala binding for gexiv2 library
112 Summary(pl.UTF-8):      Wiązanie języka vala do biblioteki gexiv2
113 Group:          Development/Languages
114 Requires:       %{name}-devel = %{version}-%{release}
115 %if "%{_rpmversion}" >= "5"
116 BuildArch:      noarch
117 %endif
118
119 %description -n vala-gexiv2
120 Vala binding for gexiv2 library.
121
122 %description -n vala-gexiv2 -l pl.UTF-8
123 Wiązanie języka vala do biblioteki gexiv2.
124
125 %prep
126 %setup -q
127
128 %build
129 %meson build \
130         %{?with_apidocs:-Dgtk_doc=true}
131
132 %ninja_build -C build
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %ninja_install -C build
138
139 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/gi/overrides
140 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/gi/overrides
141 %py_postclean
142
143 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/gi/overrides
144 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/gi/overrides
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files
153 %defattr(644,root,root,755)
154 %doc AUTHORS MAINTAINERS NEWS README THANKS
155 %attr(755,root,root) %{_libdir}/libgexiv2.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libgexiv2.so.2
157 %{_libdir}/girepository-1.0/GExiv2-0.10.typelib
158
159 %files devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libgexiv2.so
162 %{_datadir}/gir-1.0/GExiv2-0.10.gir
163 %{_includedir}/gexiv2
164 %{_pkgconfigdir}/gexiv2.pc
165
166 %if %{with static_libs}
167 %files static
168 %defattr(644,root,root,755)
169 %{_libdir}/libgexiv2.a
170 %endif
171
172 %files apidocs
173 %defattr(644,root,root,755)
174 %{_gtkdocdir}/gexiv2
175
176 %files -n python-gexiv2
177 %defattr(644,root,root,755)
178 %{py_sitedir}/gi/overrides/GExiv2.py[co]
179
180 %files -n python3-gexiv2
181 %defattr(644,root,root,755)
182 %{py3_sitedir}/gi/overrides/GExiv2.py
183 %{py3_sitedir}/gi/overrides/__pycache__/GExiv2.cpython-*.py[co]
184
185 %files -n vala-gexiv2
186 %defattr(644,root,root,755)
187 %{_datadir}/vala/vapi/gexiv2.deps
188 %{_datadir}/vala/vapi/gexiv2.vapi
This page took 0.085521 seconds and 3 git commands to generate.