]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
9b95ae206028747e0791bc9d6bf8b9cb04929d8f
[packages/gdb.git] / gdb.spec
1 # NOTE
2 # - Do not remove -lib package, it is required by FPC
3
4 # TODO
5 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
6 #
7 # Conditional build:
8 %bcond_without  python          # build without python support
9
10 Summary:        A GNU source-level debugger for C, C++ and Fortran
11 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
12 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
13 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
14 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
15 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
16 Summary(ru.UTF-8):      Символический отладчик для C и других языков
17 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
18 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
19 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
20 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
21 %define         snap    20120926
22 Name:           gdb
23 Version:        7.6
24 Release:        0.1
25 License:        GPL v3+
26 Group:          Development/Debuggers
27 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
28 # Source0-md5:  fda57170e4d11cdde74259ca575412a8
29 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
30 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
31 Source3:        %{name}-gstack.man
32 Patch100:       gdb-6.6-buildid-locate.patch
33 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
34 Patch102:       gdb-6.6-buildid-locate-rpm.patch
35 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
36 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
37 Patch1000:      %{name}-readline.patch
38 Patch1001:      %{name}-info.patch
39 Patch1002:      %{name}-passflags.patch
40 Patch1005:      %{name}-pretty-print-by-default.patch
41 Patch1006:      buildid-locate-rpm-pld.patch
42 URL:            http://www.gnu.org/software/gdb/
43 BuildRequires:  autoconf >= 2.69
44 BuildRequires:  automake
45 BuildRequires:  bison
46 BuildRequires:  expat-devel
47 BuildRequires:  flex
48 BuildRequires:  gettext-devel
49 BuildRequires:  libselinux-devel
50 BuildRequires:  libtool
51 BuildRequires:  libunwind-devel >= 0.97
52 BuildRequires:  ncurses-devel >= 5.2
53 BuildRequires:  pkgconfig
54 BuildRequires:  readline-devel
55 BuildRequires:  rpmbuild(macros) >= 1.219
56 BuildRequires:  texinfo >= 4.4
57 BuildRequires:  zlib-devel
58 %if %{with python}
59 BuildRequires:  python-devel
60 BuildRequires:  rpm-pythonprov
61 Obsoletes:      python-gdb
62 # for traceback module
63 Requires:       python-modules
64 %endif
65 Requires:       libunwind >= 0.97
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 Gdb is a full featured, command driven debugger. Gdb allows you to
70 trace the execution of programs and examine their internal state at
71 any time. Gdb works for C and C++ compiled with the GNU C compiler
72 gcc.
73
74 %description -l de.UTF-8
75 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
76 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
77 kompiliertes C++.
78
79 %description -l es.UTF-8
80 Este es un debugger orientado a comandos repleto de características.
81 Te permite rastrear la ejecución de programas y examinar su estado
82 interno a cualquier momento. Funciona para C y C++ compilado con el
83 compilador GNU C.
84
85 %description -l fr.UTF-8
86 Débugger complet, piloté par commandes. Permet de tracer l'exécution
87 des programmes et d'examiner à tout moment leur état interne.
88 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
89 de GNU, gcc.
90
91 %description -l pl.UTF-8
92 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
93 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
94 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
95 przy pomocy kompilatora GNU (gcc).
96
97 %description -l pt_BR.UTF-8
98 Este é um debugger orientado a comandos repleto de características.
99 Ele permite à você rastrear a execução de programas e examinar o seu
100 estado interno a qualquer momento. Ele funciona para para C e C++
101 compilado com o compilador GNU C.
102
103 %description -l ru.UTF-8
104 Это полноценный отладчик, управляемый командами. Он позволяет
105 трассировать исполнение программ и изучать их внутреннее состояние в
106 любой момент времени. Работает с программами на C и C++,
107 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
108
109 %description -l tr.UTF-8
110 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
111 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
112 verir.
113
114 %description -l uk.UTF-8
115 Це повноцінний відладчик, що керується командами. Він дозволяє
116 трасувати виконання програм та вивчати їх внутрішній стан в довільний
117 момент часу. Працює з програмами на C та C++, зкомпільованими
118 компіляторами GNU C (gcc, egcs, pgcc).
119
120 %package gdbserver
121 Summary:        A standalone server for GDB (the GNU source-level debugger)
122 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
123 Group:          Development/Debuggers
124
125 %description gdbserver
126 GDB, the GNU debugger, allows you to debug programs written in C, C++,
127 Java, and other languages, by executing them in a controlled fashion
128 and printing their data.
129
130 This package provides a program that allows you to run GDB on a
131 different machine than the one which is running the program being
132 debugged.
133
134 %description gdbserver -l pl.UTF-8
135 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
136 innych językach programowania poprzez wykonywanie ich w sposób
137 kontrolowany oraz wypisywanie ich danych.
138
139 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
140 maszynie niż ta, na której działa śledzony program.
141
142 %package lib
143 Summary:        GDB in the form of a static library
144 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
145 Group:          Development/Debuggers
146 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
147 Requires:       binutils-static >= 2.17.50
148 Requires:       expat-static
149 Requires:       libselinux-static
150 Requires:       libsepol-static
151 Requires:       ncurses-static
152 Requires:       python-static
153 Requires:       readline-static
154 Requires:       xz-static
155 Requires:       zlib-static
156
157 %description lib
158 GDB in the form of a static library.
159
160 %description lib -l pl.UTF-8
161 GDB w postaci biblioteki statycznej.
162
163 %prep
164 %setup -q
165
166 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
167 rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
168 rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
169
170 %patch100 -p1
171 %patch101 -p1
172 %patch102 -p1
173 %patch103 -p1
174 %patch104 -p1
175
176 %patch1000 -p1
177 %patch1001 -p1
178 %patch1002 -p1
179 %patch1005 -p1
180 %patch1006 -p1
181
182 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
183 cat > gdb/version.in << EOF
184 %{version}-%{release} (PLD Linux)
185 EOF
186
187 sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
188
189 %build
190 # omit hand-written gdb/testsuite aclocal.m4
191 for dir in gdb gdb/gdbserver ; do
192         olddir=$(pwd)
193         cd $dir
194         %{__rm} aclocal.m4
195         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
196         cd $olddir
197 done
198 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
199         dir=$(dirname "$dir")
200         olddir=$(pwd)
201         cd $dir
202         %{__autoconf}
203         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
204         cd $olddir
205 done
206 cp -f /usr/share/automake/config.* .
207 # don't --enable-shared here, there would be libs version mismatch with binutils
208 %configure \
209         --with-gdb-datadir=%{_datadir}/gdb \
210         --with-separate-debug-dir=/usr/lib/debug \
211 %if %{with python}
212         --with-python=yes \
213         --with-pythondir=%{py_sitescriptdir} \
214 %else
215         --without-python \
216 %endif
217         --disable-gdbtk \
218         --disable-shared \
219         --enable-gdbcli \
220         --enable-gdbmi \
221         --enable-multi-ice \
222         --enable-netrom \
223         --enable-nls \
224         --enable-tui \
225         --with-system-readline \
226         --with-cpu=%{_target_cpu} \
227 %ifnarch alpha
228         --with-mmalloc \
229 %endif
230         --without-included-gettext \
231         --without-included-regex \
232         --without-x
233
234 %{__make} -j1
235 %{__make} -j1 info
236
237 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
238 %{__make} -j1 -C gdb libgdb.a
239
240 %install
241 rm -rf $RPM_BUILD_ROOT
242 install -d $RPM_BUILD_ROOT%{_infodir}
243
244 %{__make} -j1 install install-info \
245         DESTDIR=$RPM_BUILD_ROOT
246
247 # gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
248 # window is created too.
249 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
250 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
251
252 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
253 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
254
255 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
256 rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
257
258 %if %{with python}
259 # Temporarily now:
260 for LIB in lib lib64; do
261         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
262         install -d $LIBPATH
263 done
264
265 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
266 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
267 %py_postclean
268 %endif
269
270 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
271
272 install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
273
274 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
275 # These are part of binutils
276 rm -rf $RPM_BUILD_ROOT%{_localedir}
277 rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
278 rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
279 rm -f $RPM_BUILD_ROOT%{_infodir}/mmalloc*
280 rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
281 rm -rf $RPM_BUILD_ROOT%{_includedir}
282 rm -rf $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*,iberty*,mmalloc*}
283
284 %clean
285 rm -rf $RPM_BUILD_ROOT
286
287 %post   -p /sbin/postshell
288 -/usr/sbin/fix-info-dir -c %{_infodir}
289
290 %postun -p /sbin/postshell
291 -/usr/sbin/fix-info-dir -c %{_infodir}
292
293 %files
294 %defattr(644,root,root,755)
295 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
296 %attr(755,root,root) %{_bindir}/gdb
297 %attr(755,root,root) %{_bindir}/gdbtui
298 %dir %{_datadir}/gdb
299 %dir %{_datadir}/gdb/auto-load
300 %dir %{_datadir}/gdb/auto-load%{_prefix}
301 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
302 %ifarch %{x8664}
303 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
304 %endif
305 %{_datadir}/gdb/syscalls
306 %{_datadir}/gdb/python
307 %{_mandir}/man1/gdb.1*
308 %{_mandir}/man1/gdbtui.1*
309 %{_mandir}/man1/gstack.1*
310 %lang(es) %{_mandir}/es/man1/*
311 %lang(fr) %{_mandir}/fr/man1/*
312 %lang(hu) %{_mandir}/hu/man1/*
313 %lang(ja) %{_mandir}/ja/man1/*
314 %lang(pl) %{_mandir}/pl/man1/*
315 %{_infodir}/annotate.info*
316 %{_infodir}/gdb.info*
317 %{_infodir}/gdbint.info*
318 %{_infodir}/stabs.info*
319
320 %files gdbserver
321 %defattr(644,root,root,755)
322 %attr(755,root,root) %{_bindir}/gdbserver
323 %{_mandir}/man1/gdbserver.1*
324 %attr(755,root,root) %{_libdir}/libinproctrace.so
325
326 %files lib
327 %defattr(644,root,root,755)
328 %{_libdir}/libdecnumber.a
329 %{_libdir}/libgdb.a
This page took 0.102216 seconds and 2 git commands to generate.