]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
81a420ed6398c5766198a1bc2c324c6c510d1739
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - MongoCXX (mongo/client/dbclient.h, -lmongoclient -lboost_system -lboost_thread -lboost_regex)
6 # - rasterlite2
7 # - sfcgal >= 1.2.2
8 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9 # - libkml (1.3.0 needed, not released yet)
10 # - wait for newer pcidsk, switch to external again
11 # - csharp, java
12 # - additional, proprietary(?) formats support:
13 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17 #   - MrSID (http://www.lizardtech.com/developer/)
18 #   - LuraTech JP2Lura 
19 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
20 #   - Ingres (--with-ingres=/path)
21 #   - Informix DB (--with-idb)
22 #   - DWGdirect (members only? http://www.opendwg.org/)
23 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
24 #   - Teigha DWG/DGN (https://www.opendesign.com/products/drawings?)
25 #
26 # Conditional build:
27 %bcond_without  armadillo       # Armadillo support for faster TPS transform
28 %bcond_without  crnlib          # DDS support via crunch/crnlib
29 %bcond_without  epsilon         # EPSILON wavelet compression support
30 %bcond_without  fyba            # SOSI geodata support using FYBA
31 %bcond_with     grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
32 %bcond_without  gta             # GTA format support
33 %bcond_without  kea             # KEA format support
34 %bcond_without  mysql           # MySQL DB support
35 %bcond_with     oci             # ORACLE OCI DB and Georaster support
36 %bcond_without  odbc            # ODBC DB support
37 %bcond_without  opencl          # OpenCL (GPU) support
38 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
39 %bcond_with     podofo          # PDF support via podofo instead of poppler
40 %bcond_without  poppler         # PDF support via poppler
41 %bcond_with     rasdaman        # Rasdaman support
42 %bcond_with     spatialite      # SpatiaLite support
43 %bcond_without  xerces          # Xerces support
44 %bcond_without  java            # Java and MDB support
45
46 %if %{with podofo}
47 %undefine       with_poppler
48 %endif
49 Summary:        Geospatial Data Abstraction Library
50 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
51 Name:           gdal
52 Version:        3.0.4
53 Release:        17
54 License:        BSD-like
55 Group:          Libraries
56 Source0:        https://github.com/OSGeo/gdal/releases/download/v%{version}/%{name}-%{version}.tar.gz
57 # Source0-md5:  c6bbb5caca06e96bd97a32918e0aa9aa
58 Patch0:         %{name}-perl.patch
59 Patch1:         %{name}-pc.patch
60 Patch2:         %{name}-dds.patch
61 Patch3:         %{name}-rasdaman.patch
62 Patch4:         %{name}-pluginsdir.patch
63 Patch5:         libx32.patch
64 Patch6:         %{name}-poppler.patch
65 Patch7:         decl.patch
66 Patch8:         %{name}_tirpcinc.patch
67 Patch9:         jasper.patch
68 Patch10:        gcc11.patch
69 URL:            http://www.gdal.org/
70 # 1.x or 2.x supported
71 BuildRequires:  CharLS-devel
72 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
73 %{?with_armadillo:BuildRequires:        armadillo-devel}
74 BuildRequires:  autoconf >= 2.52
75 BuildRequires:  automake
76 BuildRequires:  cfitsio-devel
77 %{?with_crnlib:BuildRequires:   crnlib-devel}
78 BuildRequires:  cryptopp-devel
79 BuildRequires:  curl-devel
80 BuildRequires:  doxygen >= 1.4.2
81 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
82 BuildRequires:  expat-devel >= 1.95.0
83 %{?with_fyba:BuildRequires:     fyba-devel}
84 BuildRequires:  freexl-devel >= 1.0
85 BuildRequires:  gcc >= 6:4.1
86 BuildRequires:  geos-devel >= 3.1.0
87 BuildRequires:  giflib-devel >= 4.0
88 %{?with_grass:BuildRequires:    grass-devel >= 6.4}
89 BuildRequires:  hdf-devel >= 4.2.5
90 BuildRequires:  hdf5-devel
91 BuildRequires:  jasper-devel
92 %{?with_java:BuildRequires:     jdk >= 11}
93 %{?with_java:BuildRequires:     jpackage-utils}
94 BuildRequires:  json-c-devel >= 0.11
95 %{?with_kea:BuildRequires:      kealib-devel}
96 BuildRequires:  libcsf-devel >= 2.0-0.041111.6
97 BuildRequires:  libdap-devel >= 3.10
98 BuildRequires:  libgeotiff-devel >= 1.2.1
99 %{?with_gta:BuildRequires:      libgta-devel}
100 BuildRequires:  libjpeg-devel >= 6b
101 #BuildRequires: libkml-devel >= 1.3.0
102 BuildRequires:  libpng-devel >= 2:1.2.8
103 %{?with_spatialite:BuildRequires:       libspatialite-devel}
104 BuildRequires:  libstdc++-devel
105 BuildRequires:  libtiff-devel >= 4.0
106 BuildRequires:  libtirpc-devel
107 BuildRequires:  libtool
108 BuildRequires:  libuuid-devel
109 BuildRequires:  libwebp-devel
110 BuildRequires:  libxml2-devel >= 2
111 #%{?with_mysql:BuildRequires:   mysql-devel >= 4}
112 %{?with_mysql:BuildRequires:    /usr/bin/mysql_config}
113 BuildRequires:  netcdf-devel >= 4.1
114 BuildRequires:  ogdi-devel >= 3.1
115 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
116 # 8.1.7 for DB support, 10.0.1 for georaster
117 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
118 #BuildRequires: pcidsk-devel > 0.3
119 BuildRequires:  pcre-devel
120 BuildRequires:  perl-devel
121 BuildRequires:  pkgconfig >= 1:0.21
122 %{?with_podofo:BuildRequires:   podofo-devel}
123 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
124 # ensure it's compiled with PQescapeStringConn support
125 BuildRequires:  postgresql-backend-devel >= 8.1.4
126 BuildRequires:  postgresql-devel >= 8.1.4
127 BuildRequires:  proj-devel >= 4
128 BuildRequires:  python-devel >= 1:2.5
129 BuildRequires:  python-numpy-devel >= 1:1.0.0
130 BuildRequires:  python-setuptools
131 BuildRequires:  qhull-devel >= 2012
132 %{?with_rasdaman:BuildRequires: rasdaman-devel}
133 BuildRequires:  rpm-pythonprov
134 BuildRequires:  rpmbuild(macros) >= 1.344
135 BuildRequires:  sed >= 4.0
136 BuildRequires:  sqlite3-devel >= 3.0.0
137 BuildRequires:  swig-perl
138 BuildRequires:  swig-python >= 1.3
139 BuildRequires:  texlive-dvips
140 BuildRequires:  texlive-latex
141 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
142 %{?with_xerces:BuildRequires:   xerces-c-devel >= 3.1.0}
143 BuildRequires:  xz-devel
144 BuildRequires:  zlib-devel >= 1.1.4
145 # for ZSTD compression in TIFF
146 BuildRequires:  zstd-devel
147 Requires:       freexl >= 1.0
148 Requires:       geos >= 3.1.0
149 Requires:       hdf >= 4.2.5
150 Requires:       libgeotiff >= 1.2.1
151 Requires:       libpng >= 2:1.2.8
152 Requires:       libtiff >= 4.0
153 %{?with_openjpeg:Requires:      openjpeg2 >= 2.1.0}
154 Requires:       qhull >= 2012
155 %{?with_xerces:Requires:        xerces-c >= 3.1.0}
156 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
157
158 %description
159 GDAL is a translator library for raster geospatial data formats that
160 is released under an Open Source license. As a library, it presents a
161 single abstract data model to the calling application for all
162 supported formats. The related OGR library (which lives within the
163 GDAL source tree) provides a similar capability for simple features
164 vector data.
165
166 %description -l pl.UTF-8
167 GDAL to biblioteka konwertująca między formatami rastrowych danych
168 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
169 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
170 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
171 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
172 możliwości dla danych wektorowych.
173
174 %package devel
175 Summary:        GDAL library header files
176 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
177 Group:          Development/Libraries
178 Requires:       %{name} = %{version}-%{release}
179 Requires:       CharLS-devel
180 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
181 %{?with_armadillo:Requires:     armadillo-devel}
182 Requires:       cfitsio-devel
183 %{?with_crnlib:Requires:        crnlib-devel}
184 Requires:       cryptopp-devel
185 Requires:       curl-devel
186 %{?with_epsilon:Requires:       epsilon-compressor-devel}
187 %{?with_fyba:Requires:  fyba-devel}
188 Requires:       expat-devel >= 1.95.0
189 Requires:       freexl-devel >= 1.0
190 Requires:       geos-devel >= 3.1.0
191 Requires:       giflib-devel >= 4.0
192 Requires:       hdf-devel >= 4.2.5
193 Requires:       hdf5-devel
194 Requires:       jasper-devel
195 Requires:       json-c-devel >= 0.11
196 %{?with_kea:Requires:   kealib-devel}
197 Requires:       libcsf-devel
198 Requires:       libdap-devel >= 3.10
199 Requires:       libgeotiff-devel >= 1.2.1
200 %{?with_gta:Requires:   libgta-devel}
201 Requires:       libjpeg-devel >= 6b
202 Requires:       libpng-devel >= 2:1.2.8
203 %{?with_spatialite:Requires:    libspatialite-devel}
204 Requires:       libstdc++-devel
205 Requires:       libtiff-devel >= 4.0
206 Requires:       libuuid-devel
207 Requires:       libwebp-devel
208 Requires:       libxml2-devel >= 2
209 %{?with_mysql:Requires: /usr/bin/mysql_config}
210 Requires:       netcdf-devel >= 4
211 Requires:       ogdi-devel >= 3.1
212 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.1.0}
213 #Requires:      pcidsk-devel > 0.3
214 Requires:       pcre-devel
215 %{?with_podofo:Requires:        podofo-devel}
216 %{?with_poppler:Requires:       poppler-devel >= 0.24}
217 Requires:       postgresql-devel
218 Requires:       proj-devel >= 4
219 Requires:       qhull-devel >= 2012
220 %{?with_rasdaman:Requires:      rasdaman-devel}
221 Requires:       sqlite3-devel >= 3.0.0
222 %{?with_odbc:Requires:  unixODBC-devel}
223 %{?with_xerces:Requires:        xerces-c-devel >= 3.1.0}
224 Requires:       xz-devel
225 Requires:       zlib-devel >= 1.1.4
226 Requires:       zstd-devel
227
228 %description devel
229 GDAL library header files.
230
231 %description devel -l pl.UTF-8
232 Pliki nagłówkowe biblioteki GDAL.
233
234 %package static
235 Summary:        GDAL static libraries
236 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
237 Group:          Development/Libraries
238 Requires:       %{name}-devel = %{version}-%{release}
239
240 %description static
241 GDAL static libraries.
242
243 %description static -l pl.UTF-8
244 Statyczne biblioteki GDAL.
245
246 %package -n perl-gdal
247 Summary:        Perl bindings for GDAL
248 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
249 Group:          Development/Languages/Perl
250 Requires:       %{name} = %{version}-%{release}
251
252 %description -n perl-gdal
253 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
254
255 %description -n perl-gdal -l pl.UTF-8
256 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
257
258 %package -n python-gdal
259 Summary:        GDAL Python module
260 Summary(pl.UTF-8):      Moduł Pythona GDAL
261 Group:          Libraries/Python
262 Requires:       %{name} = %{version}-%{release}
263 Requires:       python-libs
264
265 %description -n python-gdal
266 GDAL Python module.
267
268 %description -n python-gdal -l pl.UTF-8
269 Moduł Pythona GDAL.
270
271 %prep
272 %setup -q
273 %patch0 -p1
274 %patch1 -p1
275 %patch2 -p1
276 %patch3 -p1
277 %patch4 -p1
278 %patch5 -p1
279 %patch6 -p1
280 %patch7 -p1
281 %patch8 -p1
282 %patch9 -p2
283 %patch10 -p2
284
285 # need to regenerate (old ones don't support perl 5.10)
286 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
287
288 # our man path
289 sed -i -e 's#^mandir=.*##g' configure.ac
290
291 %{__rm} -r man
292
293 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
294
295 sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
296           -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
297           -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
298       swig/python/scripts/epsg_tr.py \
299       swig/python/scripts/esri2wkt.py \
300       swig/python/scripts/gcps2vec.py \
301       swig/python/scripts/gcps2wld.py \
302       swig/python/scripts/gdal2tiles.py \
303       swig/python/scripts/gdal2xyz.py \
304       swig/python/scripts/gdal_auth.py \
305       swig/python/scripts/gdal_calc.py \
306       swig/python/scripts/gdal_edit.py \
307       swig/python/scripts/gdal_fillnodata.py \
308       swig/python/scripts/gdal_merge.py \
309       swig/python/scripts/gdal_pansharpen.py \
310       swig/python/scripts/gdal_polygonize.py \
311       swig/python/scripts/gdal_proximity.py \
312       swig/python/scripts/gdal_retile.py \
313       swig/python/scripts/gdal_sieve.py \
314       swig/python/scripts/gdalchksum.py \
315       swig/python/scripts/gdalcompare.py \
316       swig/python/scripts/gdalident.py \
317       swig/python/scripts/gdalimport.py \
318       swig/python/scripts/gdalmove.py \
319       swig/python/scripts/mkgraticule.py \
320       swig/python/scripts/ogrmerge.py \
321       swig/python/scripts/pct2rgb.py \
322       swig/python/scripts/rgb2pct.py
323
324 %build
325 cp -f /usr/share/gettext/config.rpath .
326
327 %ifarch %{x8664}
328 jvm_arch=amd64
329 %endif
330 %ifarch %{ix86}
331 jvm_arch=i386
332 %endif
333 %ifarch x32
334 jvm_arch=x32
335 %endif
336
337 %{__libtoolize}
338 %{__aclocal} -I m4
339 %{__autoconf}
340 %{__autoheader}
341 %configure \
342         --includedir=%{_includedir}/gdal \
343         --datadir=%{_datadir}/gdal \
344         --with-dods-root=/usr \
345         %{?with_armadillo:--with-armadillo} \
346         %{?with_crnlib:--with-dds} \
347         %{?with_epsilon:--with-epsilon} \
348         %{?with_grass:--with-grass} \
349         %{!?with_gta:--without-gta} \
350         --with-hide-internal-symbols \
351         %{?with_java:--with-java=%{java_home}} \
352         --with-liblzma \
353         %{!?with_kea:--without-kea} \
354         %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/lib/server} \
355         %{?with_mysql:--with-mysql} \
356         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
357         %{?with_opencl:--with-opencl} \
358         --with-perl \
359         %{?with_podofo:--with-podofo} \
360         %{?with_poppler:--with-poppler} \
361         --with-python \
362         %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
363         %{?with_fyba:--with-sosi} \
364         %{?with_spatialite:--with-spatialite} \
365         --with-sqlite3 \
366         --with-webp \
367         %{?with_xerces:--with-xerces} \
368         --with-xerces-inc=/usr/include \
369         --with-xerces-lib="-lxerces-c" \
370         --without-libgrass
371 #       --with-pcidsk=/usr (needs > 0.3)
372 # csharp builds, but has no configure option nor install target
373
374 # regenerate where needed
375 %{__make} -j1 -C swig/perl generate
376
377 %{__make} \
378         %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
379         %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
380
381 %{__make} -j1 docs
382
383 %{__make} -j1 man
384
385 %install
386 rm -rf $RPM_BUILD_ROOT
387
388 %{__make} -j1 install install-man \
389         DESTDIR=$RPM_BUILD_ROOT
390
391 # TODO: remove libgdal.la when gdal.pc gets maintained Requires.private/Libs.private list
392
393 rm -rf _html
394 cp -a html _html
395
396 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
397 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
398 %py_postclean
399
400 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
401 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
402 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
403 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
404 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
405
406 %clean
407 rm -rf $RPM_BUILD_ROOT
408
409 %post   -p /sbin/ldconfig
410 %postun -p /sbin/ldconfig
411
412 %files
413 %defattr(644,root,root,755)
414 %doc NEWS PROVENANCE.TXT
415 %attr(755,root,root) %{_bindir}/epsg_tr.py
416 %attr(755,root,root) %{_bindir}/esri2wkt.py
417 %attr(755,root,root) %{_bindir}/gcps2vec.py
418 %attr(755,root,root) %{_bindir}/gcps2wld.py
419 %attr(755,root,root) %{_bindir}/gdal2tiles.py
420 %attr(755,root,root) %{_bindir}/gdal2xyz.py
421 %attr(755,root,root) %{_bindir}/gdaladdo
422 %attr(755,root,root) %{_bindir}/gdal_auth.py
423 %attr(755,root,root) %{_bindir}/gdalbuildvrt
424 %attr(755,root,root) %{_bindir}/gdal_calc.py
425 %attr(755,root,root) %{_bindir}/gdalchksum.py
426 %attr(755,root,root) %{_bindir}/gdalcompare.py
427 %attr(755,root,root) %{_bindir}/gdal_contour
428 %attr(755,root,root) %{_bindir}/gdaldem
429 %attr(755,root,root) %{_bindir}/gdal_edit.py
430 %attr(755,root,root) %{_bindir}/gdalenhance
431 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
432 %attr(755,root,root) %{_bindir}/gdal_grid
433 %attr(755,root,root) %{_bindir}/gdalident.py
434 %attr(755,root,root) %{_bindir}/gdalimport.py
435 %attr(755,root,root) %{_bindir}/gdalinfo
436 %attr(755,root,root) %{_bindir}/gdallocationinfo
437 %attr(755,root,root) %{_bindir}/gdalmanage
438 %attr(755,root,root) %{_bindir}/gdal_merge.py
439 %attr(755,root,root) %{_bindir}/gdalmove.py
440 %attr(755,root,root) %{_bindir}/gdal_pansharpen.py
441 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
442 %attr(755,root,root) %{_bindir}/gdal_proximity.py
443 %attr(755,root,root) %{_bindir}/gdal_rasterize
444 %attr(755,root,root) %{_bindir}/gdal_retile.py
445 %attr(755,root,root) %{_bindir}/gdalserver
446 %attr(755,root,root) %{_bindir}/gdal_sieve.py
447 %attr(755,root,root) %{_bindir}/gdalsrsinfo
448 %attr(755,root,root) %{_bindir}/gdaltindex
449 %attr(755,root,root) %{_bindir}/gdaltransform
450 %attr(755,root,root) %{_bindir}/gdal_translate
451 %attr(755,root,root) %{_bindir}/gdalwarp
452 %attr(755,root,root) %{_bindir}/gnmanalyse
453 %attr(755,root,root) %{_bindir}/gnmmanage
454 %attr(755,root,root) %{_bindir}/mkgraticule.py
455 %attr(755,root,root) %{_bindir}/nearblack
456 %attr(755,root,root) %{_bindir}/ogr2ogr
457 %attr(755,root,root) %{_bindir}/ogrinfo
458 %attr(755,root,root) %{_bindir}/ogrlineref
459 %attr(755,root,root) %{_bindir}/ogrmerge.py
460 %attr(755,root,root) %{_bindir}/ogrtindex
461 %attr(755,root,root) %{_bindir}/pct2rgb.py
462 %attr(755,root,root) %{_bindir}/rgb2pct.py
463 %attr(755,root,root) %{_bindir}/testepsg
464 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
465 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.26
466 %dir %{_libdir}/gdalplugins
467 %{_datadir}/gdal
468 %{_mandir}/man1/gdal2tiles.1*
469 %{_mandir}/man1/gdal_calc.1*
470 %{_mandir}/man1/gdal_contour.1*
471 %{_mandir}/man1/gdal_edit.1*
472 %{_mandir}/man1/gdal_fillnodata.1*
473 %{_mandir}/man1/gdal_grid.1*
474 %{_mandir}/man1/gdal_merge.1*
475 %{_mandir}/man1/gdal_polygonize.1*
476 %{_mandir}/man1/gdal_proximity.1*
477 %{_mandir}/man1/gdal_rasterize.1*
478 %{_mandir}/man1/gdal_retile.1*
479 %{_mandir}/man1/gdal_sieve.1*
480 %{_mandir}/man1/gdal_translate.1*
481 %{_mandir}/man1/gdal_utilities.1*
482 %{_mandir}/man1/gdaladdo.1*
483 %{_mandir}/man1/gdalbuildvrt.1*
484 %{_mandir}/man1/gdalcompare.1*
485 %{_mandir}/man1/gdaldem.1*
486 %{_mandir}/man1/gdalinfo.1*
487 %{_mandir}/man1/gdallocationinfo.1*
488 %{_mandir}/man1/gdalmanage.1*
489 %{_mandir}/man1/gdalmove.1*
490 %{_mandir}/man1/gdalsrsinfo.1*
491 %{_mandir}/man1/gdaltindex.1*
492 %{_mandir}/man1/gdaltransform.1*
493 %{_mandir}/man1/gdalwarp.1*
494 %{_mandir}/man1/nearblack.1*
495 %{_mandir}/man1/ogr2ogr.1*
496 %{_mandir}/man1/ogr_utilities.1*
497 %{_mandir}/man1/ogrinfo.1*
498 %{_mandir}/man1/ogrlineref.1*
499 %{_mandir}/man1/ogrtindex.1*
500 %{_mandir}/man1/pct2rgb.1*
501 %{_mandir}/man1/rgb2pct.1*
502 %{_mandir}/man1/gdal_pansharpen.1*
503 %{_mandir}/man1/gnm_utilities.1*
504 %{_mandir}/man1/gnmanalyse.1*
505 %{_mandir}/man1/gnmmanage.1*
506 %{_mandir}/man1/ogrmerge.1*
507
508 %files devel
509 %defattr(644,root,root,755)
510 %doc _html/*
511 %attr(755,root,root) %{_bindir}/gdal-config
512 %attr(755,root,root) %{_libdir}/libgdal.so
513 %{_libdir}/libgdal.la
514 %{_pkgconfigdir}/gdal.pc
515 %{_includedir}/gdal
516 %{_mandir}/man1/gdal-config.1*
517
518 %files static
519 %defattr(644,root,root,755)
520 %{_libdir}/libgdal.a
521
522 %files -n perl-gdal
523 %defattr(644,root,root,755)
524 %dir %{perl_vendorarch}/Geo
525 %{perl_vendorarch}/Geo/GDAL.pm
526 %dir %{perl_vendorarch}/Geo/GDAL
527 %{perl_vendorarch}/Geo/GDAL/Const.pm
528 %{perl_vendorarch}/Geo/OGR.pm
529 %{perl_vendorarch}/Geo/OSR.pm
530 %dir %{perl_vendorarch}/auto/Geo
531 %dir %{perl_vendorarch}/auto/Geo/GDAL
532 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
533 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
534 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
535 %dir %{perl_vendorarch}/auto/Geo/GNM
536 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GNM/GNM.so
537 %dir %{perl_vendorarch}/auto/Geo/OGR
538 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
539 %dir %{perl_vendorarch}/auto/Geo/OSR
540 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
541 %{_mandir}/man3/Geo::GDAL.3pm*
542 %{perl_vendorarch}/Geo/GNM.pm
543
544 %files -n python-gdal
545 %defattr(644,root,root,755)
546 %{py_sitedir}/gdal.py[co]
547 %{py_sitedir}/gdalconst.py[co]
548 %{py_sitedir}/gdalnumeric.py[co]
549 %{py_sitedir}/ogr.py[co]
550 %{py_sitedir}/osr.py[co]
551 %{py_sitedir}/GDAL-*.egg-info
552 %dir %{py_sitedir}/osgeo
553 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
554 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
555 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
556 %attr(755,root,root) %{py_sitedir}/osgeo/_gnm.so
557 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
558 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
559 %{py_sitedir}/osgeo/*.py[co]
This page took 0.105875 seconds and 2 git commands to generate.