]> git.pld-linux.org Git - packages/gc.git/blob - gc.spec
5d4cd383edba47104617ffe4588322c8e2f78e5e
[packages/gc.git] / gc.spec
1 Summary:        The Boehm-Demers-Weiser conservative garbage collector
2 Summary(pl.UTF-8):      Konserwatywny odśmiecacz pamięci Boehma-Demersa-Weisera
3 Name:           gc
4 Version:        7.2
5 Release:        1
6 License:        BSD-like
7 Group:          Libraries
8 Source0:        http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/%{name}-%{version}.tar.gz
9 # Source0-md5:  d17aecedef3d73e75387fb63558fa4eb
10 URL:            http://www.hpl.hp.com/personal/Hans_Boehm/gc/
11 BuildRequires:  autoconf >= 2.64
12 BuildRequires:  automake
13 BuildRequires:  libatomic_ops >= 7.2
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool >= 2:1.5
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Gc is a conservative garbage collector for C and C++. It is used as a
20 replacement for standard malloc() and free(). GC_malloc will attempt
21 to reclaim inaccessible space automatically by invoking a conservative
22 garbage collector at appropriate points.
23
24 %description -l pl.UTF-8
25 Gc jest konserwatywnym odśmiecaczem pamięci dla C i C++. Jest używany
26 jako zamiennik dla standardowych funkcji malloc() i free(). GC_malloc
27 próbuje odzyskać niedostępna pamięć automatycznie przez wywoływanie
28 konserwatywnego odśmiecacza pamięci w odpowiednich miejscach.
29
30 %package devel
31 Summary:        Headers for conservative garbage collector
32 Summary(pl.UTF-8):      Nagłówki dla konserwatywnego odśmiecacza pamięci
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Headers for conservative garbage collector
38
39 %description devel -l pl.UTF-8
40 Nagłówki dla konserwatywnego odśmiecacza pamięci
41
42 %package static
43 Summary:        Static version of gc library
44 Summary(pl.UTF-8):      Statyczna wersja biblioteki gc
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 Static version of gc library
50
51 %description static -l pl.UTF-8
52 Statyczna wersja biblioteki gc
53
54 %package c++
55 Summary:        C++ interface to GC library
56 Summary(pl.UTF-8):      Interfejs C++ do biblioteki GC
57 Group:          Libraries
58 Requires:       %{name} = %{version}-%{release}
59
60 %description c++
61 C++ interface to GC library.
62
63 %description c++ -l pl.UTF-8
64 Interfejs C++ do biblioteki GC.
65
66 %package c++-devel
67 Summary:        Header files for C++ interface for GC library
68 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu C++ do biblioteki GC
69 Group:          Development/Libraries
70 Requires:       %{name}-c++ = %{version}-%{release}
71 Requires:       %{name}-devel = %{version}-%{release}
72 Requires:       libstdc++-devel
73
74 %description c++-devel
75 Header files for C++ interface for GC library.
76
77 %description c++-devel -l pl.UTF-8
78 Pliki nagłówkowe interfejsu C++ do biblioteki GC.
79
80 %package c++-static
81 Summary:        C++ interface to GC library - static library
82 Summary(pl.UTF-8):      Interfejs C++ do biblioteki GC - biblioteka statyczna
83 Group:          Development/Libraries
84 Requires:       %{name}-c++-devel = %{version}-%{release}
85
86 %description c++-static
87 C++ interface to GC library - static library.
88
89 %description c++-static -l pl.UTF-8
90 Interfejs C++ do biblioteki GC - biblioteka statyczna.
91
92 %prep
93 %setup -q
94
95 # don't install docs to %{_datadir}/%{name}
96 %{__perl} -pi -e 's/^dist_pkgdata_DATA/EXTRA_DIST/' doc/doc.am
97
98 %build
99 %{__libtoolize}
100 %{__aclocal}
101 %{__autoconf}
102 %{__automake}
103 %configure \
104 %ifnarch sparc64
105         CPPFLAGS="-DUSE_LIBC_PRIVATES" \
106 %endif
107         --enable-cplusplus \
108         --enable-threads=posix
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 install -d $RPM_BUILD_ROOT%{_includedir}/gc/private
118 install -D doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
119 # are these still needed? (what is ecls?)
120 install include/private/* $RPM_BUILD_ROOT%{_includedir}/gc/private
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %post   c++ -p /sbin/ldconfig
129 %postun c++ -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc README.QUICK doc/README{,.{linux,changes,contributors,environment,macros}} doc/*.html
134 %attr(755,root,root) %{_libdir}/libcord.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libcord.so.1
136 %attr(755,root,root) %{_libdir}/libgc.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libgc.so.1
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libcord.so
142 %attr(755,root,root) %{_libdir}/libgc.so
143 %{_libdir}/libcord.la
144 %{_libdir}/libgc.la
145 %dir %{_includedir}/gc
146 %{_includedir}/gc/private
147 %{_includedir}/gc/cord.h
148 %{_includedir}/gc/gc.h
149 %{_includedir}/gc/gc_allocator.h
150 %{_includedir}/gc/gc_amiga_redirects.h
151 %{_includedir}/gc/gc_backptr.h
152 %{_includedir}/gc/gc_config_macros.h
153 %{_includedir}/gc/gc_gcj.h
154 %{_includedir}/gc/gc_inline.h
155 %{_includedir}/gc/gc_mark.h
156 %{_includedir}/gc/gc_pthread_redirects.h
157 %{_includedir}/gc/gc_tiny_fl.h
158 %{_includedir}/gc/gc_typed.h
159 %{_includedir}/gc/gc_version.h
160 %{_includedir}/gc/leak_detector.h
161 %{_includedir}/gc/new_gc_alloc.h
162 %{_includedir}/gc/weakpointer.h
163 %{_includedir}/gc.h
164 %{_pkgconfigdir}/bdw-gc.pc
165 %{_mandir}/man3/gc.3*
166
167 %files static
168 %defattr(644,root,root,755)
169 %{_libdir}/libcord.a
170 %{_libdir}/libgc.a
171
172 %files c++
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/libgccpp.so.*.*.*
175 %attr(755,root,root) %ghost %{_libdir}/libgccpp.so.1
176
177 %files c++-devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/libgccpp.so
180 %{_libdir}/libgccpp.la
181 %{_includedir}/gc/gc_cpp.h
182 %{_includedir}/gc_cpp.h
183
184 %files c++-static
185 %defattr(644,root,root,755)
186 %{_libdir}/libgccpp.a
This page took 0.071638 seconds and 2 git commands to generate.