]> git.pld-linux.org Git - packages/gc.git/blob - gc.spec
add missing R: atomic_ops for -devel package.
[packages/gc.git] / gc.spec
1 Summary:        The Boehm-Demers-Weiser conservative garbage collector
2 Summary(pl.UTF-8):      Konserwatywny odśmiecacz pamięci Boehma-Demersa-Weisera
3 Name:           gc
4 Version:        7.2
5 Release:        1
6 License:        BSD-like
7 Group:          Libraries
8 Source0:        http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/%{name}-%{version}.tar.gz
9 # Source0-md5:  d17aecedef3d73e75387fb63558fa4eb
10 URL:            http://www.hpl.hp.com/personal/Hans_Boehm/gc/
11 BuildRequires:  autoconf >= 2.64
12 BuildRequires:  automake
13 BuildRequires:  libatomic_ops >= 7.2
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool >= 2:1.5
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Gc is a conservative garbage collector for C and C++. It is used as a
20 replacement for standard malloc() and free(). GC_malloc will attempt
21 to reclaim inaccessible space automatically by invoking a conservative
22 garbage collector at appropriate points.
23
24 %description -l pl.UTF-8
25 Gc jest konserwatywnym odśmiecaczem pamięci dla C i C++. Jest używany
26 jako zamiennik dla standardowych funkcji malloc() i free(). GC_malloc
27 próbuje odzyskać niedostępna pamięć automatycznie przez wywoływanie
28 konserwatywnego odśmiecacza pamięci w odpowiednich miejscach.
29
30 %package devel
31 Summary:        Headers for conservative garbage collector
32 Summary(pl.UTF-8):      Nagłówki dla konserwatywnego odśmiecacza pamięci
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       libatomic_ops >= 7.2
36
37 %description devel
38 Headers for conservative garbage collector
39
40 %description devel -l pl.UTF-8
41 Nagłówki dla konserwatywnego odśmiecacza pamięci
42
43 %package static
44 Summary:        Static version of gc library
45 Summary(pl.UTF-8):      Statyczna wersja biblioteki gc
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static version of gc library
51
52 %description static -l pl.UTF-8
53 Statyczna wersja biblioteki gc
54
55 %package c++
56 Summary:        C++ interface to GC library
57 Summary(pl.UTF-8):      Interfejs C++ do biblioteki GC
58 Group:          Libraries
59 Requires:       %{name} = %{version}-%{release}
60
61 %description c++
62 C++ interface to GC library.
63
64 %description c++ -l pl.UTF-8
65 Interfejs C++ do biblioteki GC.
66
67 %package c++-devel
68 Summary:        Header files for C++ interface for GC library
69 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu C++ do biblioteki GC
70 Group:          Development/Libraries
71 Requires:       %{name}-c++ = %{version}-%{release}
72 Requires:       %{name}-devel = %{version}-%{release}
73 Requires:       libstdc++-devel
74
75 %description c++-devel
76 Header files for C++ interface for GC library.
77
78 %description c++-devel -l pl.UTF-8
79 Pliki nagłówkowe interfejsu C++ do biblioteki GC.
80
81 %package c++-static
82 Summary:        C++ interface to GC library - static library
83 Summary(pl.UTF-8):      Interfejs C++ do biblioteki GC - biblioteka statyczna
84 Group:          Development/Libraries
85 Requires:       %{name}-c++-devel = %{version}-%{release}
86
87 %description c++-static
88 C++ interface to GC library - static library.
89
90 %description c++-static -l pl.UTF-8
91 Interfejs C++ do biblioteki GC - biblioteka statyczna.
92
93 %prep
94 %setup -q
95
96 # don't install docs to %{_datadir}/%{name}
97 %{__perl} -pi -e 's/^dist_pkgdata_DATA/EXTRA_DIST/' doc/doc.am
98
99 %build
100 %{__libtoolize}
101 %{__aclocal}
102 %{__autoconf}
103 %{__automake}
104 %configure \
105 %ifnarch sparc64
106         CPPFLAGS="-DUSE_LIBC_PRIVATES" \
107 %endif
108         --enable-cplusplus \
109         --enable-threads=posix
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install -d $RPM_BUILD_ROOT%{_includedir}/gc/private
119 install -D doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
120 # are these still needed? (what is ecls?)
121 install include/private/* $RPM_BUILD_ROOT%{_includedir}/gc/private
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %post   c++ -p /sbin/ldconfig
130 %postun c++ -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc README.QUICK doc/README{,.{linux,changes,contributors,environment,macros}} doc/*.html
135 %attr(755,root,root) %{_libdir}/libcord.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libcord.so.1
137 %attr(755,root,root) %{_libdir}/libgc.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libgc.so.1
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libcord.so
143 %attr(755,root,root) %{_libdir}/libgc.so
144 %{_libdir}/libcord.la
145 %{_libdir}/libgc.la
146 %dir %{_includedir}/gc
147 %{_includedir}/gc/private
148 %{_includedir}/gc/cord.h
149 %{_includedir}/gc/gc.h
150 %{_includedir}/gc/gc_allocator.h
151 %{_includedir}/gc/gc_amiga_redirects.h
152 %{_includedir}/gc/gc_backptr.h
153 %{_includedir}/gc/gc_config_macros.h
154 %{_includedir}/gc/gc_gcj.h
155 %{_includedir}/gc/gc_inline.h
156 %{_includedir}/gc/gc_mark.h
157 %{_includedir}/gc/gc_pthread_redirects.h
158 %{_includedir}/gc/gc_tiny_fl.h
159 %{_includedir}/gc/gc_typed.h
160 %{_includedir}/gc/gc_version.h
161 %{_includedir}/gc/leak_detector.h
162 %{_includedir}/gc/new_gc_alloc.h
163 %{_includedir}/gc/weakpointer.h
164 %{_includedir}/gc.h
165 %{_pkgconfigdir}/bdw-gc.pc
166 %{_mandir}/man3/gc.3*
167
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libcord.a
171 %{_libdir}/libgc.a
172
173 %files c++
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/libgccpp.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libgccpp.so.1
177
178 %files c++-devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/libgccpp.so
181 %{_libdir}/libgccpp.la
182 %{_includedir}/gc/gc_cpp.h
183 %{_includedir}/gc_cpp.h
184
185 %files c++-static
186 %defattr(644,root,root,755)
187 %{_libdir}/libgccpp.a
This page took 0.124889 seconds and 3 git commands to generate.