]> git.pld-linux.org Git - packages/ganeti-p2v-transfer.git/blob - ganeti-p2v-transfer.spec
- rel 1
[packages/ganeti-p2v-transfer.git] / ganeti-p2v-transfer.spec
1 Summary:        Tool for converting a physical computer into a Ganeti instance
2 Name:           ganeti-p2v-transfer
3 Version:        0.1
4 Release:        1
5 License:        GPL v2
6 Group:          Applications/System
7 Source0:        https://ganeti.googlecode.com/files/%{name}-%{version}.tar.gz
8 # Source0-md5:  c0333098304fa1868ffcaa82a942eba0
9 Patch0:         DESTDIR.patch
10 Patch1:         kpartx-sync.patch
11 URL:            https://code.google.com/p/ganeti/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  docutils
15 BuildRequires:  rpmbuild(macros) >= 1.647
16 Requires:       blockdev
17 Requires:       coreutils
18 Requires:       dump
19 Requires:       e2fsprogs
20 Requires:       ganeti
21 Requires:       kpartx
22 Requires:       losetup
23 Requires:       mawk
24 Requires:       mount
25 Requires:       sed
26 Requires:       tar
27 Requires:       util-linux
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This is a tool for converting a physical computer into a ganeti
32 instance. It consists of two parts, a ganeti instance OS template that
33 allows the instance to be booted to receive the files, and a script
34 that is run on the source machine to make the transfer.
35
36 A design document is available in doc/design.rst that describes the
37 functioning of the system. This document will focus on getting the
38 system up and running, and the process for actually performing
39 physical-to-virtual transfers.
40
41 %package source
42 Summary:        Source system transfer script.
43 Group:          Applications/System
44
45 %description source
46 This script is run from the transfer OS to establish an SSH connection
47 with the bootstrap OS, mount the source filesystem(s), and copy
48 the data over to the target. It will prompt the user for credentials
49 as necessary to gain access to the bootstrap OS.
50
51 %prep
52 %setup -q
53 %patch0 -p1
54 %patch1 -p1
55
56 %build
57 %{__aclocal}
58 %{__autoconf}
59 %{__automake}
60 %configure
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install-source install-target \
67         DESTDIR=$RPM_BUILD_ROOT
68
69
70 %{__mv} $RPM_BUILD_ROOT%{_datadir}/ganeti/os/p2v-target/variants.list $RPM_BUILD_ROOT%{_sysconfdir}/ganeti/instance-p2v-target
71 ln -s %{_sysconfdir}/ganeti/instance-p2v-target//variants.list $RPM_BUILD_ROOT%{_datadir}/ganeti/os/p2v-target/variants.list
72
73 %{__rm} -r $RPM_BUILD_ROOT/%{_docdir}/%{name}
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc NEWS README* doc/design.* doc/instance-p2v-target.*
81 %dir %{_sysconfdir}/ganeti/instance-p2v-target
82 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ganeti/instance-p2v-target/p2v-target.conf
83 %dir %{_sysconfdir}/ganeti/instance-p2v-target/fixes
84 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/10_fix_fstab
85 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/20_remove_persistent_rules
86 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/30_add_console_inittab
87 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/30_add_console_upstart
88 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/40_copy_hostname
89 %dir %{_sysconfdir}/ganeti/instance-p2v-target/fixes/fixlib
90 %{_sysconfdir}/ganeti/instance-p2v-target/fixes/fixlib/*.py*
91 %dir %{_sysconfdir}/ganeti/instance-p2v-target/hooks
92 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/clear-root-password
93 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/install-fixes
94 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/interfaces
95 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/ramboot
96 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/xen-hvc0
97 %dir %{_sysconfdir}/ganeti/instance-p2v-target/variants
98 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ganeti/instance-p2v-target/variants/default.conf
99 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ganeti/instance-p2v-target/variants.list
100 %dir %{_datadir}/ganeti/os/p2v-target
101 %{_datadir}/ganeti/os/p2v-target/common.sh
102 %attr(755,root,root) %{_datadir}/ganeti/os/p2v-target/create
103 %attr(755,root,root) %{_datadir}/ganeti/os/p2v-target/export
104 %{_datadir}/ganeti/os/p2v-target/ganeti_api_version
105 %attr(755,root,root) %{_datadir}/ganeti/os/p2v-target/import
106 %attr(755,root,root) %{_datadir}/ganeti/os/p2v-target/rename
107 %{_datadir}/ganeti/os/p2v-target/variants.list
108 %attr(755,root,root) %{_sbindir}/make_ramboot_initrd.py
109
110 %files source
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_sbindir}/p2v_transfer.py
This page took 0.072852 seconds and 3 git commands to generate.