]> git.pld-linux.org Git - packages/ftgl.git/blob - ftgl.spec
a43345f001700d7a0da5b1f64b73de393d6e649b
[packages/ftgl.git] / ftgl.spec
1 Summary:        OpenGL frontend to freetype2
2 Summary(pl.UTF-8):      Nakładka OpenGL na freetype2 - łatwy dostęp do fontów z poziomu OpenGL
3 Name:           ftgl
4 Version:        2.4.0
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 #Source0Download: https://github.com/frankheckenbach/ftgl
9 Source0:        https://github.com/frankheckenbach/ftgl/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  fba1e1c548ebe3ab362495e96a7a0670
11 URL:            https://github.com/frankheckenbach/ftgl
12 BuildRequires:  OpenGL-GLU-devel >= 1.2
13 BuildRequires:  autoconf >= 2.58
14 BuildRequires:  automake >= 1.6
15 BuildRequires:  doxygen
16 # pkgconfig(freetype2) >= 9.0.3
17 BuildRequires:  freetype-devel >= 2.0.9
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool >= 2:1.5
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpmbuild(macros) >= 1.752
22 BuildRequires:  texlive-pdftex
23 # for tests
24 #BuildRequires: OpenGL-glut-devel
25 #BuildRequires: cppunit-devel
26 #BuildRequires: fonts-TTF-DejaVu
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 FTGL is a free, open source library to enable developers to use
31 arbitrary fonts in their OpenGL (http://www.opengl.org/) applications.
32 Unlike other OpenGL font libraries FTGL uses standard font file
33 formats so doesn't need a preprocessing step to convert the high
34 quality font data into a lesser quality, proprietary format. FTGL uses
35 the Freetype (http://www.freetype.org/) font library to open and
36 'decode' the fonts. It then takes that output and stores it in a
37 format most efficient for OpenGL rendering.
38
39 %description -l pl.UTF-8
40 FTPGL to wolnodostępna biblioteka z otwartymi źródłami umożliwiająca
41 programistom używanie dowolnych fontów w aplikacjach OpenGL
42 (http://www.opengl.org/). W przeciwieństwie do innych bibliotek OpenGL
43 FTGL używa standardowych formatów plików z fontami, dzięki czemu nie
44 jest wymagany żaden preprocessing, aby przetworzyć dane fontu wysokiej
45 jakości na własnościowy format niższej jakości. FTGL do wczytywania i
46 dekodowania fontów używa biblioteki obsługi fontów Freetype
47 (http://www.freetype.org/), następnie przejmuje wyjście i przechowuje
48 je w formacie najbardziej wydajnym przy renderingu OpenGL.
49
50 %package devel
51 Summary:        OpenGL frontend to freetype2 - development files
52 Summary(pl.UTF-8):      Nakładka OpenGL na freetype2 - pliki dla programistów
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       OpenGL-GLU-devel >= 1.2
56 Requires:       freetype-devel >= 2.0.9
57 Requires:       libstdc++-devel
58
59 %description devel
60 OpenGL frontend to freetype2 - development files.
61
62 %description devel -l pl.UTF-8
63 Nakładka OpenGL na freetype2 - pliki dla programistów.
64
65 %package static
66 Summary:        Static FTGL library
67 Summary(pl.UTF-8):      Statyczna biblioteka FTGL
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static FTGL library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka FTGL.
76
77 %package apidocs
78 Summary:        API documentation for FTGL library
79 Summary(pl.UTF-8):      Dokumentacja API biblioteki FTGL
80 Group:          Documentation
81 %{?noarchpackage}
82
83 %description apidocs
84 API documentation for FTGL library.
85
86 %description apidocs -l pl.UTF-8
87 Dokumentacja API biblioteki FTGL.
88
89 %prep
90 %setup -q
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         ac_cv_path_LATEX=no
100 #       --enable-shared
101
102 %{__make} \
103         ECHO=/bin/echo
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT \
110         ECHO=/bin/echo
111
112 # obsolted by pkg-config
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libftgl.la
114
115 # packaged as %doc
116 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README TODO
127 %attr(755,root,root) %{_libdir}/libftgl.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libftgl.so.2
129
130 %files devel
131 %defattr(644,root,root,755)
132 %doc docs/html
133 %attr(755,root,root) %{_libdir}/libftgl.so
134 %{_includedir}/FTGL
135 %{_pkgconfigdir}/ftgl.pc
136
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libftgl.a
140
141 %files apidocs
142 %defattr(644,root,root,755)
143 %doc docs/html/*
This page took 0.081143 seconds and 2 git commands to generate.