]> git.pld-linux.org Git - packages/freshplayerplugin.git/blob - freshplayerplugin.spec
Up to 0.3.1; missing R:
[packages/freshplayerplugin.git] / freshplayerplugin.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk3            # build with gtk+3 instead of gtk+2
4 %bcond_without  jack            # jack
5 %bcond_without  pulseaudio      # pulseaudio
6 %bcond_without  vaapi           # vaapi
7
8 Summary:        PPAPI-host NPAPI-plugin adapter for flashplayer in npapi based browsers
9 Name:           freshplayerplugin
10 Version:        0.3.1
11 Release:        0.1
12 License:        MIT
13 Group:          X11/Applications/Multimedia
14 Source0:        https://github.com/i-rinat/freshplayerplugin/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  e8661cf64acbb6872f4b4aed7f2384a4
16 URL:            https://github.com/i-rinat/freshplayerplugin
17 BuildRequires:  Mesa-libEGL-devel
18 BuildRequires:  Mesa-libGLES-devel
19 BuildRequires:  alsa-lib-devel
20 BuildRequires:  cmake >= 2.8.8
21 BuildRequires:  freetype-devel
22 BuildRequires:  glib2-devel
23 %{!?with_gtk3:BuildRequires: gtk+2-devel}
24 %{?with_gtk3:BuildRequires: gtk+3-devel}
25 %{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
26 BuildRequires:  libconfig-devel
27 BuildRequires:  libevent-devel
28 BuildRequires:  libv4l-devel
29 %{?with_vaapi:BuildRequires: libva-devel}
30 BuildRequires:  openssl-devel
31 %{?with_pulseaudio:BuildRequires: pulseaudio-devel}
32 BuildRequires:  ragel
33 BuildRequires:  rpmbuild(macros) >= 1.357
34 BuildRequires:  xorg-lib-libXrandr-devel
35 BuildRequires:  xorg-lib-libXrender-devel
36 Requires:       browser-plugins >= 2.0
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 PPAPI-host NPAPI-plugin adapter for flashplayer in npapi based
41 browsers.
42
43 %prep
44 %setup -q
45
46 %build
47 install -d build
48 cd build
49 %cmake \
50         -DCMAKE_SKIP_RPATH=1 \
51         %{?with_jack:-DJACK=1} \
52         %{?with_pulseaudio:-DPULSEAUDIO=1} \
53         -DWITH_GTK=%{!?with_gtk3:2}%{?with_gtk3:3} \
54         -DWITH_HWDEC=%{!?with_vaapi:0}%{?with_vaapi:1} \
55         ..
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_browserpluginsdir}
61 install -p build/libfreshwrapper-pepperflash.so $RPM_BUILD_ROOT%{_browserpluginsdir}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 %update_browser_plugins
68
69 %postun
70 if [ "$1" = 0 ]; then
71         %update_browser_plugins
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %doc ChangeLog data/freshwrapper.conf.example README.md
77 %attr(755,root,root) %{_browserpluginsdir}/libfreshwrapper-pepperflash.so
This page took 0.075302 seconds and 3 git commands to generate.