]> git.pld-linux.org Git - packages/freerdp2.git/blob - freerdp2.spec
up to 2.6.1
[packages/freerdp2.git] / freerdp2.spec
1 # TODO:
2 # - what is libpcsc-winpr? (-DWITH_PCSC_WINPR)
3 # - fix DirectFB client build (orphaned code)
4 # - WITH_IPP?
5 #
6 # Conditional build:
7 %bcond_without  alsa            # ALSA sound support
8 %bcond_without  cups            # CUPS printing support
9 %bcond_with     directfb        # DirectFB client
10 %bcond_without  ffmpeg          # FFmpeg audio/video codecs support (covers H264, GSM, LAME, FAAC, FAAD2, SOXR)
11 %bcond_with     faac            # faac for AAC audio coding (if without ffmpeg)
12 %bcond_with     faad            # faad2 for AAC audio decoding (if without ffmpeg)
13 %bcond_with     gsm             # GSM audio codec (if without ffmpeg)
14 %bcond_without  gstreamer       # GStreamer sound support
15 # for now the kerberos5 support has to be disabled due to a bad state of its code.
16 # See: https://github.com/FreeRDP/FreeRDP/issues/4348
17 # See: https://github.com/FreeRDP/FreeRDP/issues/5746
18 %bcond_with     kerberos5       # GSSAPI auth support
19 %bcond_with     lame            # LAME for MP3 audio codec (if without ffmpeg)
20 %bcond_without  opencl          # OpenCL support
21 %bcond_with     openh264        # OpenH264 for H.264 codec (overrides ffmpeg for H264)
22 %bcond_without  pcsc            # SmartCard support via PCSC-lite library
23 %bcond_without  pulseaudio      # Pulseaudio sound support
24 %bcond_with     soxr            # soxr for audio resampling (if without ffmpeg)
25 %bcond_without  systemd         # systemd journal support
26 %bcond_without  wayland         # Wayland client
27 %bcond_without  x11             # X11 client
28 %bcond_without  sse2            # SSE2 and higher instructions (runtime detection with sse patch)
29
30 %define freerdp_api     2
31
32 %ifnarch %{ix86} %{x8664} x32
33 %undefine       with_sse2
34 %endif
35 Summary:        Remote Desktop Protocol client
36 Summary(pl.UTF-8):      Klient protokołu RDP
37 Name:           freerdp2
38 Version:        2.6.1
39 Release:        1
40 License:        Apache v2.0
41 Group:          Applications/Communications
42 Source0:        https://pub.freerdp.com/releases/freerdp-%{version}.tar.gz
43 # Source0-md5:  e06ef73a6803391beee6e704c437ac34
44 Patch0:         freerdp-opt.patch
45 Patch1:         freerdp-gsm.patch
46 Patch2:         docbook-xsl.patch
47 URL:            http://www.freerdp.com/
48 %{?with_directfb:BuildRequires: DirectFB-devel}
49 %{?with_opencl:BuildRequires:   OpenCL-devel}
50 %{?with_alsa:BuildRequires:     alsa-lib-devel}
51 %{!?with_ffmpeg:BuildRequires:  cairo-devel}
52 BuildRequires:  cmake >= 2.8
53 %{?with_cups:BuildRequires:     cups-devel}
54 BuildRequires:  desktop-file-utils
55 BuildRequires:  docbook-style-xsl-nons
56 %{?with_faac:BuildRequires:     faac-devel}
57 %{?with_faad:BuildRequires:     faad2-devel >= 2}
58 # libavcodec >= 57.48.101, libavresample, libavutil
59 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 3.1}
60 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 1.0.5}
61 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 1.0.5}
62 # MIT krb5 >= 1.13 also possible
63 %{?with_kerberos5:BuildRequires:        heimdal-devel}
64 %{?with_lame:BuildRequires:     lame-libs-devel}
65 %{?with_gsm:BuildRequires:      libgsm-devel}
66 BuildRequires:  libjpeg-devel
67 %{?with_openh264:BuildRequires: openh264-devel}
68 # also mbedtls possible
69 BuildRequires:  openssl-devel
70 %{?with_pcsc:BuildRequires:     pcsc-lite-devel}
71 BuildRequires:  pkgconfig
72 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
73 BuildRequires:  rpmbuild(macros) >= 1.742
74 %{?with_soxr:BuildRequires:     soxr-devel}
75 %{?with_systemd:BuildRequires:  systemd-devel >= 1:209}
76 %{?with_wayland:BuildRequires:  wayland-devel}
77 BuildRequires:  xmlto
78 %{?with_wayland:BuildRequires:  xorg-lib-libxkbcommon-devel}
79 %if %{with x11}
80 BuildRequires:  xorg-lib-libX11-devel
81 BuildRequires:  xorg-lib-libXcursor-devel
82 BuildRequires:  xorg-lib-libXdamage-devel
83 BuildRequires:  xorg-lib-libXext-devel
84 BuildRequires:  xorg-lib-libXfixes-devel
85 BuildRequires:  xorg-lib-libXinerama-devel
86 BuildRequires:  xorg-lib-libXrandr-devel
87 BuildRequires:  xorg-lib-libXtst-devel
88 BuildRequires:  xorg-lib-libXv-devel
89 BuildRequires:  xorg-lib-libxkbfile-devel
90 %endif
91 BuildRequires:  zlib-devel
92 Requires:       %{name}-libs = %{version}-%{release}
93 Requires:       hicolor-icon-theme
94 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
96 %description
97 FreeRDP is Remote Desktop Protocol (RDP) client.
98
99 xfreerdp can connect to RDP servers such as Microsoft Windows
100 machines, xrdp and VirtualBox.
101
102 %description -l pl.UTF-8
103 xfreerdp to klient protokołu RDP (Remote Desktop Protocol) z projektu
104 FreeRDP.
105
106 xfreerdp może łączyć się z serwerami RDP, takimi jak maszyny z
107 Microsoft Windows, xrdp oraz VirtualBox.
108
109 %package dfb
110 Summary:        DirectFB based Remote Desktop Protocol klient
111 Summary(pl.UTF-8):      Klient protokołu RDP oparty na DirectFB
112 Group:          Applications/Communications
113 Requires:       %{name} = %{version}-%{release}
114 Obsoletes:      freerdp-dfb < 2
115
116 %description dfb
117 DirectFB based Remote Desktop Protocol klient.
118
119 dfreerdp can connect to RDP servers such as Microsoft Windows
120 machines, xrdp and VirtualBox.
121
122 %description dfb -l pl.UTF-8
123 Klient protokołu RDP oparty na DirectFB.
124
125 dfreerdp może łączyć się z serwerami RDP, takimi jak maszyny z
126 Microsoft Windows, xrdp oraz VirtualBox.
127
128 %package wayland
129 Summary:        Wayland based Remote Desktop Protocol klient
130 Summary(pl.UTF-8):      Klient protokołu RDP oparty na Wayland
131 Group:          Applications/Communications
132 Requires:       %{name} = %{version}-%{release}
133
134 %description wayland
135 Wayland based Remote Desktop Protocol klient.
136
137 wlfreerdp can connect to RDP servers such as Microsoft Windows
138 machines, xrdp and VirtualBox.
139
140 %description wayland -l pl.UTF-8
141 Klient protokołu RDP oparty na Wayland.
142
143 wlfreerdp może łączyć się z serwerami RDP, takimi jak maszyny z
144 Microsoft Windows, xrdp oraz VirtualBox.
145
146 %package x11
147 Summary:        X11 based Remote Desktop Protocol klient
148 Summary(pl.UTF-8):      Klient protokołu RDP oparty na X11
149 Group:          Applications/Communications
150 Requires:       %{name} = %{version}-%{release}
151 Provides:       xfreerdp = %{version}-%{release}
152 Obsoletes:      freerdp < 2
153
154 %description x11
155 X11 based Remote Desktop Protocol klient.
156
157 xfreerdp can connect to RDP servers such as Microsoft Windows
158 machines, xrdp and VirtualBox.
159
160 %description x11 -l pl.UTF-8
161 Klient protokołu RDP oparty na X11.
162
163 xfreerdp może łączyć się z serwerami RDP, takimi jak maszyny z
164 Microsoft Windows, xrdp oraz VirtualBox.
165
166 %package libs
167 Summary:        Core libraries implementing the RDP protocol
168 Summary(pl.UTF-8):      Główne biblioteki implementujące protokół RDP
169 Group:          Libraries
170
171 %description libs
172 Core libraries implementing the RDP protocol.
173
174 %description libs -l pl.UTF-8
175 Główne biblioteki implementujące protokół RDP.
176
177 %package devel
178 Summary:        Development files for FreeRDP 2 libraries
179 Summary(pl.UTF-8):      Pliki programistyczne bibliotek FreeRDP 2
180 Group:          Development/Libraries
181 Requires:       %{name}-libs = %{version}-%{release}
182
183 %description devel
184 This package contains the header files for developing applications
185 that use FreeRDP 2 libraries.
186
187 %description devel -l pl.UTF-8
188 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
189 wykorzystujących biblioteki FreeRDP 2.
190
191 %prep
192 %setup -q -n freerdp-%{version}
193 %patch0 -p1
194 %patch1 -p1
195 %patch2 -p1
196
197 cat << EOF > xfreerdp.desktop
198 [Desktop Entry]
199 Type=Application
200 Name=X FreeRDP
201 NoDisplay=true
202 Comment=Connect to RDP server and display remote desktop
203 Comment[pl]=Połączenie z serwerem RDP i wyświetlanie zdalnego pulpitu
204 Icon=%{name}
205 Exec=%{_bindir}/xfreerdp
206 Terminal=false
207 Categories=Network;RemoteAccess;
208 EOF
209
210 %build
211 install -d build
212 cd build
213 %cmake .. \
214         -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
215         %{cmake_on_off alsa WITH_ALSA} \
216         %{!?with_ffmpeg:-DWITH_CAIRO=ON} \
217         -DWITH_CUNIT=OFF \
218         %{cmake_on_off cups WITH_CUPS} \
219         -DWITH_DEBUG_LICENSE=ON \
220         %{cmake_on_off directfb WITH_DIRECTFB} \
221         %{cmake_on_off ffmpeg WITH_DSP_FFMPEG} \
222         %{cmake_on_off faac WITH_FAAC} \
223         %{cmake_on_off faad WITH_FAAD2} \
224         %{cmake_on_off ffmpeg WITH_FFMPEG} \
225         %{cmake_on_off gsm WITH_GSM} \
226         %{cmake_on_off gstreamer WITH_GSTREAMER_1_0} \
227         %{cmake_on_off kerberos5 WITH_GSSAPI} \
228         -DWITH_JPEG=ON \
229         %{cmake_on_off systemd WITH_LIBSYSTEMD} \
230         %{cmake_on_off opencl WITH_OPENCL} \
231         %{cmake_on_off openh264 WITH_OPENH264} \
232         -DWITH_OSS=ON \
233         %{cmake_on_off pcsc WITH_PCSC} \
234         %{cmake_on_off pulseaudio WITH_PULSE} \
235         -DWITH_SERVER=ON \
236         %{cmake_on_off soxr WITH_SOXR} \
237         %{cmake_on_off sse2 WITH_SSE2} \
238         %{cmake_on_off ffmpeg WITH_SWSCALE} \
239         %{cmake_on_off wayland WITH_WAYLAND} \
240         %{cmake_on_off x11 WITH_X11} \
241         -DWITH_XCURSOR=ON \
242         -DWITH_XEXT=ON \
243         -DWITH_XINERAMA=ON \
244         -DWITH_XKBFILE=ON \
245         -DWITH_XV=ON
246
247 %{__make}
248
249 %install
250 rm -rf $RPM_BUILD_ROOT
251
252 %{__make} -C build install \
253         INSTALL="install -p" \
254         DESTDIR=$RPM_BUILD_ROOT
255
256 desktop-file-install --dir=$RPM_BUILD_ROOT%{_desktopdir} xfreerdp.desktop
257 install -p -D resources/FreeRDP_Icon_256px.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
258
259 %clean
260 rm -rf $RPM_BUILD_ROOT
261
262 %post
263 %update_icon_cache hicolor
264
265 %postun
266 %update_icon_cache hicolor
267
268 %post   libs -p /sbin/ldconfig
269 %postun libs -p /sbin/ldconfig
270
271 %files
272 %defattr(644,root,root,755)
273 %attr(755,root,root) %{_bindir}/freerdp-proxy
274 %attr(755,root,root) %{_bindir}/freerdp-shadow-cli
275 %attr(755,root,root) %{_bindir}/winpr-hash
276 %attr(755,root,root) %{_bindir}/winpr-makecert
277 %{_iconsdir}/hicolor/256x256/apps/freerdp2.png
278 %{_mandir}/man1/freerdp-shadow-cli.1*
279 %{_mandir}/man1/winpr-hash.1*
280 %{_mandir}/man1/winpr-makecert.1*
281 %{_mandir}/man7/wlog.7*
282
283 %if %{with directfb}
284 %files dfb
285 %defattr(644,root,root,755)
286 %doc doc/README.directfb
287 %attr(755,root,root) %{_bindir}/dfreerdp
288 %endif
289
290 %if %{with wayland}
291 %files wayland
292 %defattr(644,root,root,755)
293 %attr(755,root,root) %{_bindir}/wlfreerdp
294 %{_mandir}/man1/wlfreerdp.1*
295 %endif
296
297 %if %{with x11}
298 %files x11
299 %defattr(644,root,root,755)
300 %attr(755,root,root) %{_bindir}/xfreerdp
301 %{_desktopdir}/xfreerdp.desktop
302 %{_mandir}/man1/xfreerdp.1*
303 %endif
304
305 %files libs
306 %defattr(644,root,root,755)
307 %doc ChangeLog README.md
308 %attr(755,root,root) %{_libdir}/libfreerdp-client%{freerdp_api}.so.*.*.*
309 %attr(755,root,root) %ghost %{_libdir}/libfreerdp-client%{freerdp_api}.so.2
310 %attr(755,root,root) %{_libdir}/libfreerdp-server%{freerdp_api}.so.*.*.*
311 %attr(755,root,root) %ghost %{_libdir}/libfreerdp-server%{freerdp_api}.so.2
312 %attr(755,root,root) %{_libdir}/libfreerdp-shadow%{freerdp_api}.so.*.*.*
313 %attr(755,root,root) %ghost %{_libdir}/libfreerdp-shadow%{freerdp_api}.so.2
314 %attr(755,root,root) %{_libdir}/libfreerdp-shadow-subsystem%{freerdp_api}.so.*.*.*
315 %attr(755,root,root) %ghost %{_libdir}/libfreerdp-shadow-subsystem%{freerdp_api}.so.2
316 %attr(755,root,root) %{_libdir}/libfreerdp%{freerdp_api}.so.*.*.*
317 %attr(755,root,root) %ghost %{_libdir}/libfreerdp%{freerdp_api}.so.2
318 %attr(755,root,root) %{_libdir}/libuwac0.so.*.*.*
319 %attr(755,root,root) %ghost %{_libdir}/libuwac0.so.0
320 %attr(755,root,root) %{_libdir}/libwinpr%{freerdp_api}.so.*.*.*
321 %attr(755,root,root) %ghost %{_libdir}/libwinpr%{freerdp_api}.so.2
322 %attr(755,root,root) %{_libdir}/libwinpr-tools%{freerdp_api}.so.*.*.*
323 %attr(755,root,root) %ghost %{_libdir}/libwinpr-tools%{freerdp_api}.so.2
324
325 %files devel
326 %defattr(644,root,root,755)
327 %attr(755,root,root) %{_libdir}/libfreerdp-client%{freerdp_api}.so
328 %attr(755,root,root) %{_libdir}/libfreerdp-server%{freerdp_api}.so
329 %attr(755,root,root) %{_libdir}/libfreerdp-shadow%{freerdp_api}.so
330 %attr(755,root,root) %{_libdir}/libfreerdp-shadow-subsystem%{freerdp_api}.so
331 %attr(755,root,root) %{_libdir}/libfreerdp%{freerdp_api}.so
332 %attr(755,root,root) %{_libdir}/libuwac0.so
333 %attr(755,root,root) %{_libdir}/libwinpr%{freerdp_api}.so
334 %attr(755,root,root) %{_libdir}/libwinpr-tools%{freerdp_api}.so
335 %{_includedir}/freerdp2
336 %{_includedir}/uwac0
337 %{_includedir}/winpr2
338 %{_pkgconfigdir}/freerdp-client2.pc
339 %{_pkgconfigdir}/freerdp-server2.pc
340 %{_pkgconfigdir}/freerdp-shadow2.pc
341 %{_pkgconfigdir}/freerdp2.pc
342 %{_pkgconfigdir}/uwac0.pc
343 %{_pkgconfigdir}/winpr-tools2.pc
344 %{_pkgconfigdir}/winpr2.pc
345 %{_libdir}/cmake/FreeRDP-Client2
346 %{_libdir}/cmake/FreeRDP-Server2
347 %{_libdir}/cmake/FreeRDP-Shadow2
348 %{_libdir}/cmake/FreeRDP2
349 %{_libdir}/cmake/WinPR2
350 %{_libdir}/cmake/uwac0
This page took 0.0971 seconds and 3 git commands to generate.