]> git.pld-linux.org Git - packages/fpm-cookery.git/blob - fpm-cookery.spec
curl is used to fetch sources
[packages/fpm-cookery.git] / fpm-cookery.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        A tool for building software packages with fpm
6 Name:           fpm-cookery
7 Version:        0.29.0
8 Release:        0.1
9 License:        BSD
10 Group:          Development/Languages
11 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
12 # Source0-md5:  bd210d6acb6a0519f8d940200917eefe
13 URL:            https://github.com/bernd/fpm-cookery
14 BuildRequires:  rpm-rubyprov
15 BuildRequires:  rpmbuild(macros) >= 1.656
16 BuildRequires:  sed >= 4.0
17 %if %{with tests}
18 BuildRequires:  ruby-rake
19 BuildRequires:  ruby-rspec < 4
20 BuildRequires:  ruby-rspec >= 3.0
21 %endif
22 Requires:       curl
23 Requires:       fpm < 2
24 Requires:       fpm >= 1.1
25 Requires:       ruby-addressable
26 Requires:       ruby-facter
27 Requires:       ruby-puppet < 4
28 Requires:       ruby-puppet >= 3.4
29 Requires:       ruby-systemu
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 A tool for building software packages with fpm.
35
36 %prep
37 %setup -q
38 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
39
40 %build
41 # write .gemspec
42 %__gem_helper spec
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
47 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
48 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
49 cp -p %{name}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %attr(755,root,root) %{_bindir}/fpm-cook
57 %{ruby_vendorlibdir}/fpm/cookery
58 %{ruby_specdir}/%{name}-%{version}.gemspec
This page took 0.073214 seconds and 3 git commands to generate.