]> git.pld-linux.org Git - packages/foot.git/blob - foot.spec
disable pgo by default since it requires pty
[packages/foot.git] / foot.spec
1 #
2 # Conditional build:
3 %bcond_with     pgo             # disable profile guided optimizations
4
5 Summary:        A fast, lightweight and minimalistic Wayland terminal emulator
6 Name:           foot
7 Version:        1.11.0
8 Release:        3
9 License:        MIT
10 Group:          Applications/Terminal
11 Source0:        https://codeberg.org/dnkl/foot/archive/%{version}.tar.gz
12 # Source0-md5:  206a9daad2e2c86c34ba1be497ff2de6
13 Patch0:         x32.patch
14 URL:            https://codeberg.org/dnkl/foot/
15 BuildRequires:  fcft-devel < 4.0.0
16 BuildRequires:  fcft-devel >= 3.0.0
17 BuildRequires:  fontconfig-devel
18 BuildRequires:  libutf8proc-devel
19 BuildRequires:  meson >= 0.54.0
20 BuildRequires:  ninja
21 BuildRequires:  pixman-devel
22 BuildRequires:  pkgconfig
23 BuildRequires:  python3
24 BuildRequires:  rpm-build >= 4.6
25 BuildRequires:  rpmbuild(macros) >= 1.736
26 BuildRequires:  scdoc
27 BuildRequires:  tllist-devel >= 1.0.4
28 BuildRequires:  wayland-devel
29 BuildRequires:  wayland-protocols >= 1.21
30 BuildRequires:  xorg-lib-libxkbcommon-devel >= 1.0.0
31 %if %{with pgo}
32 BuildRequires:  cage
33 BuildRequires:  fonts-TTF-DejaVu
34 %endif
35 Requires(post,postun):  desktop-file-utils
36 Requires(post,postun):  gtk-update-icon-cache
37 Requires:       fcft < 4.0.0
38 Requires:       fcft >= 3.0.0
39 Requires:       hicolor-icon-theme
40 Requires:       terminfo >= 6.2.20210731
41 Requires:       xorg-lib-libxkbcommon >= 1.0.0
42 Obsoletes:      terminfo-foot < 1.10.3-2
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 A fast, lightweight and minimalistic Wayland terminal emulator.
47
48 %package -n bash-completion-foot
49 Summary:        Bash completion for foot command line
50 Group:          Applications/Shells
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       bash-completion >= 2.0
53 BuildArch:      noarch
54
55 %description -n bash-completion-foot
56 Bash completion for foot command line.
57
58 %package -n fish-completion-foot
59 Summary:        fish-completion for foot
60 Group:          Applications/Shells
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       fish
63 BuildArch:      noarch
64
65 %description -n fish-completion-foot
66 fish-completion for foot.
67
68 %description -n fish-completion-foot -l pl.UTF-8
69 Pakiet ten dostarcza uzupełnianie nazw w fish dla foot.
70
71 %package -n zsh-completion-foot
72 Summary:        ZSH completion for foot command line
73 Group:          Applications/Shells
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       zsh
76 BuildArch:      noarch
77
78 %description -n zsh-completion-foot
79 ZSH completion for foot command line.
80
81 %prep
82 %setup -q -n %{name}
83 %patch0 -p1
84
85 %build
86 %meson build \
87         %{?with_pgo:-Db_pgo=generate} \
88         -Dterminfo=disabled
89
90 %ninja_build -C build
91
92 %if %{with pgo}
93 %ninja_test -C build
94
95 ./pgo/full-headless-cage.sh . build
96
97 %__meson configure build \
98         -Db_pgo=use
99
100 %ninja_build -C build
101 %endif
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %ninja_install -C build
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 %update_desktop_database_post
113 %update_icon_cache hicolor
114
115 %postun
116 %update_desktop_database_postun
117 %update_icon_cache hicolor
118
119 %files
120 %defattr(644,root,root,755)
121 %doc CHANGELOG.md README.md
122 %attr(755,root,root) %{_bindir}/foot
123 %attr(755,root,root) %{_bindir}/footclient
124 %{_datadir}/foot
125 %{_desktopdir}/foot.desktop
126 %{_desktopdir}/foot-server.desktop
127 %{_desktopdir}/footclient.desktop
128 %{_iconsdir}/hicolor/*/apps/foot.png
129 %{_iconsdir}/hicolor/scalable/apps/foot.svg
130 %{_mandir}/man1/foot.1*
131 %{_mandir}/man1/footclient.1*
132 %{_mandir}/man5/foot.ini.5*
133 %{_mandir}/man7/foot-ctlseqs.7*
134
135 %files -n bash-completion-foot
136 %defattr(644,root,root,755)
137 %{bash_compdir}/foot
138 %{bash_compdir}/footclient
139
140 %files -n fish-completion-foot
141 %defattr(644,root,root,755)
142 %{fish_compdir}/foot.fish
143 %{fish_compdir}/footclient.fish
144
145 %files -n zsh-completion-foot
146 %defattr(644,root,root,755)
147 %{zsh_compdir}/_foot
148 %{zsh_compdir}/_footclient
This page took 0.093426 seconds and 3 git commands to generate.