]> git.pld-linux.org Git - packages/foot.git/blob - foot.spec
051cedaea70fe5336f21a49d4fdb024d93248669
[packages/foot.git] / foot.spec
1 #
2 # Conditional build:
3 %bcond_with     pgo             # disable profile guided optimizations
4
5 Summary:        A fast, lightweight and minimalistic Wayland terminal emulator
6 Name:           foot
7 Version:        1.13.0
8 Release:        1
9 License:        MIT
10 Group:          Applications/Terminal
11 Source0:        https://codeberg.org/dnkl/foot/archive/%{version}.tar.gz
12 # Source0-md5:  2b325683189e9c71ffc9d35c996d2ea0
13 Patch0:         x32.patch
14 URL:            https://codeberg.org/dnkl/foot/
15 BuildRequires:  fcft-devel < 4.0.0
16 BuildRequires:  fcft-devel >= 3.0.1
17 BuildRequires:  fontconfig-devel
18 BuildRequires:  libutf8proc-devel
19 BuildRequires:  meson >= 0.58.0
20 BuildRequires:  ninja
21 BuildRequires:  pixman-devel
22 BuildRequires:  pkgconfig
23 BuildRequires:  python3
24 BuildRequires:  rpm-build >= 4.6
25 BuildRequires:  rpmbuild(macros) >= 1.736
26 BuildRequires:  scdoc
27 BuildRequires:  systemd-devel
28 BuildRequires:  tllist-devel >= 1.0.4
29 BuildRequires:  wayland-devel
30 BuildRequires:  wayland-protocols >= 1.21
31 BuildRequires:  xorg-lib-libxkbcommon-devel >= 1.0.0
32 %if %{with pgo}
33 BuildRequires:  cage
34 BuildRequires:  fonts-TTF-DejaVu
35 %endif
36 Requires(post,postun):  desktop-file-utils
37 Requires(post,postun):  gtk-update-icon-cache
38 Requires:       fcft < 4.0.0
39 Requires:       fcft >= 3.0.1
40 Requires:       hicolor-icon-theme
41 Requires:       terminfo >= 6.2.20210731
42 Requires:       xorg-lib-libxkbcommon >= 1.0.0
43 Obsoletes:      terminfo-foot < 1.10.3-2
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 A fast, lightweight and minimalistic Wayland terminal emulator.
48
49 %package -n bash-completion-foot
50 Summary:        Bash completion for foot command line
51 Group:          Applications/Shells
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       bash-completion >= 1:2.0
54 BuildArch:      noarch
55
56 %description -n bash-completion-foot
57 Bash completion for foot command line.
58
59 %package -n fish-completion-foot
60 Summary:        fish-completion for foot
61 Group:          Applications/Shells
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       fish
64 BuildArch:      noarch
65
66 %description -n fish-completion-foot
67 fish-completion for foot.
68
69 %description -n fish-completion-foot -l pl.UTF-8
70 Pakiet ten dostarcza uzupełnianie nazw w fish dla foot.
71
72 %package -n zsh-completion-foot
73 Summary:        ZSH completion for foot command line
74 Group:          Applications/Shells
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       zsh
77 BuildArch:      noarch
78
79 %description -n zsh-completion-foot
80 ZSH completion for foot command line.
81
82 %prep
83 %setup -q -n %{name}
84 %patch0 -p1
85
86 %build
87 %meson build \
88         %{?with_pgo:-Db_pgo=generate} \
89         -Dterminfo=disabled
90
91 %ninja_build -C build
92
93 %if %{with pgo}
94 %ninja_test -C build
95
96 ./pgo/full-headless-cage.sh . build
97
98 %__meson configure build \
99         -Db_pgo=use
100
101 %ninja_build -C build
102 %endif
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %ninja_install -C build
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 %update_desktop_database_post
114 %update_icon_cache hicolor
115
116 %postun
117 %update_desktop_database_postun
118 %update_icon_cache hicolor
119
120 %files
121 %defattr(644,root,root,755)
122 %doc CHANGELOG.md README.md
123 %dir %{_sysconfdir}/xdg/foot
124 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/foot/foot.ini
125 %attr(755,root,root) %{_bindir}/foot
126 %attr(755,root,root) %{_bindir}/footclient
127 %{systemduserunitdir}/foot-server@.service
128 %{systemduserunitdir}/foot-server@.socket
129 %{_datadir}/foot
130 %{_desktopdir}/foot.desktop
131 %{_desktopdir}/foot-server.desktop
132 %{_desktopdir}/footclient.desktop
133 %{_iconsdir}/hicolor/*/apps/foot.png
134 %{_iconsdir}/hicolor/scalable/apps/foot.svg
135 %{_mandir}/man1/foot.1*
136 %{_mandir}/man1/footclient.1*
137 %{_mandir}/man5/foot.ini.5*
138 %{_mandir}/man7/foot-ctlseqs.7*
139
140 %files -n bash-completion-foot
141 %defattr(644,root,root,755)
142 %{bash_compdir}/foot
143 %{bash_compdir}/footclient
144
145 %files -n fish-completion-foot
146 %defattr(644,root,root,755)
147 %{fish_compdir}/foot.fish
148 %{fish_compdir}/footclient.fish
149
150 %files -n zsh-completion-foot
151 %defattr(644,root,root,755)
152 %{zsh_compdir}/_foot
153 %{zsh_compdir}/_footclient
This page took 0.063854 seconds and 2 git commands to generate.