]> git.pld-linux.org Git - packages/fontforge.git/blob - fontforge.spec
205402c5a707f79a21ba724f96f0d4bc80624bb8
[packages/fontforge.git] / fontforge.spec
1 #
2 # Conditional build:
3 %bcond_without  python          # Python (3) scripting and extension
4 %bcond_without  doc             # Sphinx documentation
5
6 Summary:        An outline font editor
7 Summary(pl.UTF-8):      Edytor fontów rysowanych
8 Name:           fontforge
9 Version:        20201107
10 Release:        3
11 License:        GPL v3+ with BSD parts
12 Group:          X11/Applications/Publishing
13 #Source0Download: https://github.com/fontforge/fontforge/releases
14 Source0:        https://github.com/fontforge/fontforge/releases/download/%{version}/%{name}-%{version}.tar.xz
15 # Source0-md5:  efc0b3c79ba576133de70d67ccadcf24
16 URL:            https://fontforge.org/
17 BuildRequires:  cairo-devel >= 1.6
18 BuildRequires:  cmake >= 3.5
19 BuildRequires:  freetype-devel >= 1:2.3.7
20 BuildRequires:  gettext-tools
21 BuildRequires:  gcc >= 5:3.2
22 BuildRequires:  giflib-devel
23 BuildRequires:  glib2-devel >= 1:2.6
24 BuildRequires:  gtk+3-devel >= 3.10
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libspiro-devel >= 1:0.6
28 BuildRequires:  libstdc++-devel >= 1:4.7
29 BuildRequires:  libtiff-devel >= 4
30 BuildRequires:  libltdl-devel >= 2:2
31 # 0.3
32 BuildRequires:  libuninameslist-devel >= 20130501
33 BuildRequires:  libxml2-devel >= 2.0
34 BuildRequires:  pango-devel >= 1:1.10
35 BuildRequires:  pkgconfig >= 1:0.25
36 BuildRequires:  python3-devel >= 1:3.3
37 BuildRequires:  python3-modules >= 1:3.3
38 BuildRequires:  readline-devel
39 BuildRequires:  tar >= 1:1.22
40 BuildRequires:  woff2-devel
41 BuildRequires:  xorg-lib-libX11-devel
42 BuildRequires:  xorg-lib-libXi-devel
43 BuildRequires:  xz
44 BuildRequires:  zlib-devel
45 Requires:       cairo >= 1.6
46 Requires:       freetype >= 1:2.3.7
47 Requires:       glib2 >= 1:2.6
48 Requires:       gtk+3 >= 3.10
49 Requires:       iconv
50 Requires:       libuninameslist >= 20130501
51 Requires:       pango >= 1:1.10
52 # API and plugins support withdrawn
53 Obsoletes:      fontforge-devel < 20190413
54 Obsoletes:      fontforge-static < 20190413
55 Obsoletes:      pfaedit < 040311
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 FontForge allows you to edit outline and bitmap fonts. You can create
60 new ones or modify old ones. It is also a font format converter and
61 can convert among PostScript (ASCII & binary Type 1, some Type 3s,
62 some Type 0s), TrueType, OpenType (Type2) and CID-keyed fonts.
63
64 FontForge used to be called PfaEdit.
65
66 %description -l pl.UTF-8
67 FontForge pozwala na edycję fontów rysowanych i bitmapowych. Można
68 tworzyć nowe lub modyfikować istniejące. Jest to także konwerter
69 między formatami fontów - potrafi obsługiwać fonty postscriptowe
70 (ASCII i binarne Type 1, część Type 3, część Type 0), TrueType,
71 OpenType (Type2) i fonty z kluczami CID.
72
73 FontForge wcześniej nazywał się PfaEdit.
74
75 %package devel
76 Summary:        Header files for FontForge libraries
77 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek FontForge
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       cairo-devel >= 1.6
81 Requires:       freetype-devel >= 1:2.3.7
82 Requires:       giflib-devel
83 Requires:       libjpeg-devel
84 Requires:       libltdl-devel
85 Requires:       libpng-devel
86 Requires:       libspiro-devel >= 1:0.6
87 Requires:       libtiff-devel >= 4
88 Requires:       libuninameslist-devel >= 20130501
89 Requires:       pango-devel >= 1:1.10
90 Requires:       xorg-lib-libX11-devel
91 Requires:       zlib-devel
92
93 %description devel
94 Header files for FontForge libraries.
95
96 %description devel -l pl.UTF-8
97 Pliki nagłówkowe bibliotek FontForge.
98
99 %package static
100 Summary:        Static FontForge libraries
101 Summary(pl.UTF-8):      Statyczne biblioteki FontForge
102 Group:          Development/Libraries
103 Requires:       %{name}-devel = %{version}-%{release}
104
105 %description static
106 Static FontForge libraries.
107
108 %description static -l pl.UTF-8
109 Statyczne biblioteki FontForge.
110
111 %package doc
112 Summary:        FontForge documentation
113 Summary(pl.UTF-8):      Dokumentacja do FontForge
114 Group:          Documentation
115
116 %description doc
117 FontForge documentation.
118
119 %description doc -l pl.UTF-8
120 Dokumentacja do FontForge.
121
122 %package -n python3-fontforge
123 Summary:        Python bindings for FontForge libraries
124 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek FontForge
125 Group:          Libraries/Python
126 Requires:       %{name} = %{version}-%{release}
127 Obsoletes:      python-fontforge < 20200314
128
129 %description -n python3-fontforge
130 Python bindings for FontForge libraries.
131
132 %description -n python3-fontforge -l pl.UTF-8
133 Wiązania Pythona do bibliotek FontForge.
134
135 %prep
136 %setup -q
137
138 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' \
139         pycontrib/svg2glyph/svg2glyph
140
141 %{__sed} -i -e '1s,/usr/bin/env fontforge,%{_bindir}/fontforge,' \
142         pycontrib/simple/expand-a.py \
143         pycontrib/simple/load-font-and-show-name.py
144
145 # make Sphinx warnings non-fatal
146 %{__sed} -i -e '/Sphinx_BUILD_BINARY/ s/ -W / /' doc/CMakeLists.txt
147 # missing?
148 touch doc/sphinx/contents.rst
149
150 %build
151 install -d build
152 cd build
153 %cmake .. \
154         -DCMAKE_INSTALL_DOCDIR=%{_docdir}/fontforge \
155         %{!?with_doc:-DENABLE_DOCS=OFF} \
156         -DENABLE_FONTFORGE_EXTRAS=ON \
157 %if %{without python}
158         -DENABLE_PYTHON_EXTENSION=OFF \
159         -DENABLE_PYTHON_SCRIPTING=OFF \
160 %endif
161         -DENABLE_WRITE_PFM=ON
162
163 %{__make}
164
165 %{__rm} doc/sphinx-docs/{.buildinfo,.nojekyll,objects.inv}
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169
170 %{__make} -C build install \
171         DESTDIR=$RPM_BUILD_ROOT
172
173 # API no longer exported
174 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfontforge.so
175
176 %{__mv} $RPM_BUILD_ROOT%{_localedir}/tr{_TR,}
177
178 %find_lang FontForge
179
180 %clean
181 rm -rf $RPM_BUILD_ROOT
182
183 %post   -p /sbin/ldconfig
184 %postun -p /sbin/ldconfig
185
186 %files -f FontForge.lang
187 %defattr(644,root,root,755)
188 %doc AUTHORS LICENSE README.md
189 %attr(755,root,root) %{_bindir}/fontforge
190 %attr(755,root,root) %{_bindir}/fontimage
191 %attr(755,root,root) %{_bindir}/fontlint
192 %attr(755,root,root) %{_bindir}/sfddiff
193 %attr(755,root,root) %{_libdir}/libfontforge.so.4
194 %{_datadir}/fontforge
195 %{_datadir}/metainfo/org.fontforge.FontForge.appdata.xml
196 %{_datadir}/mime/packages/fontforge.xml
197 %{_desktopdir}/org.fontforge.FontForge.desktop
198 %{_iconsdir}/hicolor/*x*/apps/org.fontforge.FontForge.png
199 %{_iconsdir}/hicolor/scalable/apps/org.fontforge.FontForge.svg
200 %{_pixmapsdir}/org.fontforge.FontForge.png
201 %{_pixmapsdir}/org.fontforge.FontForge.xpm
202 %{_mandir}/man1/fontforge.1*
203 %{_mandir}/man1/fontimage.1*
204 %{_mandir}/man1/fontlint.1*
205 %{_mandir}/man1/sfddiff.1*
206
207 %files doc
208 %defattr(644,root,root,755)
209 %dir %{_docdir}/fontforge
210 %{_docdir}/fontforge/_images
211 %{_docdir}/fontforge/_static
212 %{_docdir}/fontforge/appendices
213 %{_docdir}/fontforge/fontutils
214 %{_docdir}/fontforge/scripting
215 %{_docdir}/fontforge/techref
216 %{_docdir}/fontforge/tutorial
217 %{_docdir}/fontforge/ui
218 %dir %{_docdir}/fontforge/old
219 %lang(de) %{_docdir}/fontforge/old/de
220 %lang(ja) %{_docdir}/fontforge/old/ja
221 %{_docdir}/fontforge/*.html
222 %{_docdir}/fontforge/*.js
223
224 %files -n python3-fontforge
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{py3_sitedir}/fontforge.so
227 %attr(755,root,root) %{py3_sitedir}/psMat.so
This page took 0.095272 seconds and 2 git commands to generate.