]> git.pld-linux.org Git - packages/folks.git/blob - folks.spec
ef1e5570428da027b25a0e370882f39a58703f3b
[packages/folks.git] / folks.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs         # API documentation (broken install: HTML for devhelp part, sources+HTML for gtk-doc?)
4 %bcond_without  vala            # Vala API
5 %bcond_without  bluez           # Bluez backend
6 %bcond_without  evolution       # EDS (Evolution Data Server) backend
7 %bcond_without  ofono           # oFono backend
8 %bcond_with     sysprof         # sysprof based profiling
9 %bcond_without  telepathy       # Telepathy backend
10 %bcond_without  zeitgeist       # ` Zeitgeist support in Telepathy backend
11
12 %if %{without telepathy}
13 %undefine       with_zeitgeist
14 %endif
15 Summary:        GObject contact aggregation library
16 Summary(pl.UTF-8):      Biblioteka GObject do agregowania kontaktów
17 Name:           folks
18 Version:        0.15.6
19 Release:        1
20 License:        LGPL v2.1+
21 Group:          Libraries
22 Source0:        https://download.gnome.org/sources/folks/0.15/%{name}-%{version}.tar.xz
23 # Source0-md5:  04b6684031a463fb7a28d2d6f70b6d23
24 Patch0:         %{name}-meson.patch
25 URL:            https://wiki.gnome.org/Projects/Folks
26 BuildRequires:  dbus-devel
27 %{?with_telepathy:BuildRequires:        dbus-glib-devel}
28 %if %{with bluez} || %{with evolution} || %{with ofono}
29 # libebook for all; libebook-contacts, libedataserver, evolution-data-server for evolution
30 BuildRequires:  evolution-data-server-devel >= 3.38
31 %endif
32 BuildRequires:  gettext-tools
33 BuildRequires:  glib2-devel >= 1:2.58
34 BuildRequires:  gobject-introspection-devel >= 1.30.0
35 BuildRequires:  libgee-devel >= 0.8.4
36 BuildRequires:  libxml2-devel >= 2.0
37 BuildRequires:  meson >= 0.57
38 BuildRequires:  ncurses-devel
39 BuildRequires:  ninja >= 1.5
40 BuildRequires:  pkgconfig >= 1:0.21
41 BuildRequires:  python3 >= 1:3.2
42 %{?with_bluez:BuildRequires:    python3-dbusmock}
43 BuildRequires:  rpm-build >= 4.6
44 BuildRequires:  rpmbuild(macros) >= 1.736
45 BuildRequires:  readline-devel
46 %{?with_sysprof:BuildRequires:  sysprof-devel >= 3.38.0}
47 BuildRequires:  tar >= 1:1.22
48 %{?with_telepathy:BuildRequires:        telepathy-glib-devel >= 0.19.9}
49 %if %{with vala}
50 BuildRequires:  vala >= 2:0.22.1
51 %if %{with bluez} || %{with evolution} || %{with ofono}
52 BuildRequires:  vala-evolution-data-server >= 3.38
53 %endif
54 BuildRequires:  vala-libgee >= 0.8.4
55 %{?with_telepathy:BuildRequires:        vala-telepathy-glib >= 0.19.9}
56 %{?with_zeitgeist:BuildRequires:        vala-zeitgeist >= 0.9.14}
57 %endif
58 %{?with_apidocs:BuildRequires:  valadoc >= 0.3.1}
59 BuildRequires:  xz
60 %{?with_zeitgeist:BuildRequires:        zeitgeist-devel >= 0.9.14}
61 %if %{with bluez} || %{with evolution} || %{with ofono}
62 Requires:       evolution-data-server-libs >= 3.38
63 %endif
64 Requires:       glib2 >= 1:2.58
65 Requires:       libgee >= 0.8.4
66 %{?with_telepathy:Requires:     telepathy-glib >= 0.19.9}
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         abiver  26
70
71 %description
72 libfolks is a library that aggregates people from multiple sources
73 (e.g. Telepathy connection managers and eventually evolution data
74 server, Facebook, etc.) to create meta-contacts.
75
76 %description -l pl.UTF-8
77 libfolks to biblioteka gromadząca osoby z wielu źródeł (np. zarządców
78 połączeń Telepathy, serwera danych Evolution, Facebooka itp.), aby
79 utworzyć metakontakty.
80
81 %package devel
82 Summary:        Development files for folks libraries
83 Summary(pl.UTF-8):      Pliki programistyczne bibliotek folks
84 Group:          Development/Libraries
85 Requires:       %{name} = %{version}-%{release}
86 %if %{with bluez} || %{with evolution} || %{with ofono}
87 Requires:       evolution-data-server-devel >= 3.38
88 %endif
89 Requires:       glib2-devel >= 1:2.58
90 Requires:       libgee-devel >= 0.8.4
91 %{?with_telepathy:Requires:     telepathy-glib-devel >= 0.19.9}
92
93 %description devel
94 Development files for folks libraries.
95
96 %description devel -l pl.UTF-8
97 Pliki programistyczne bibliotek folks.
98
99 %package -n vala-folks
100 Summary:        folks API for Vala language
101 Summary(pl.UTF-8):      API folks dla języka Vala
102 Group:          Development/Libraries
103 Requires:       %{name}-devel = %{version}-%{release}
104 Requires:       vala >= 2:0.22.1
105 %if %{with bluez} || %{with evolution} || %{with ofono}
106 Requires:       vala-evolution-data-server >= 3.38
107 %endif
108 Requires:       vala-libgee >= 0.8.4
109 %{?with_telepathy:Requires:     vala-telepathy-glib >= 0.19.9}
110 BuildArch:      noarch
111
112 %description -n vala-folks
113 folks API for Vala language.
114
115 %description -n vala-folks -l pl.UTF-8
116 API folks dla języka Vala.
117
118 %prep
119 %setup -q
120 %patch0 -p1
121
122 %build
123 %meson build \
124         %{!?with_bluez:-Dbluez_backend=false} \
125         %{?with_apidocs:-Ddocs=true} \
126         %{!?with_evolution:-Deds_backend=false} \
127         %{!?with_ofono:-Dofono_backend=false} \
128         %{?with_sysprof:-Dprofiling=true} \
129         %{!?with_telepathy:-Dtelepathy_backend=false} \
130         %{?with_zeitgeist:-Dzeitgeist=true}
131
132 %ninja_build -C build
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %ninja_install -C build
138
139 %find_lang %{name}
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc AUTHORS NEWS README.md
150 %attr(755,root,root) %{_bindir}/folks-import
151 %attr(755,root,root) %{_bindir}/folks-inspect
152 %attr(755,root,root) %{_libdir}/libfolks.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/libfolks.so.26
154 %attr(755,root,root) %{_libdir}/libfolks-dummy.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libfolks-dummy.so.26
156 %{_libdir}/girepository-1.0/Folks-0.7.typelib
157 %{_libdir}/girepository-1.0/FolksDummy-0.7.typelib
158 %dir %{_libdir}/folks
159 %dir %{_libdir}/folks/%{abiver}
160 %dir %{_libdir}/folks/%{abiver}/backends
161 %dir %{_libdir}/folks/%{abiver}/backends/dummy
162 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/dummy/dummy.so
163 %dir %{_libdir}/folks/%{abiver}/backends/key-file
164 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/key-file/key-file.so
165 %if %{with bluez}
166 %dir %{_libdir}/folks/%{abiver}/backends/bluez
167 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/bluez/bluez.so
168 %endif
169 %if %{with ofono}
170 %dir %{_libdir}/folks/%{abiver}/backends/ofono
171 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/ofono/ofono.so
172 %endif
173 %if %{with evolution}
174 %attr(755,root,root) %{_libdir}/libfolks-eds.so.*.*.*
175 %attr(755,root,root) %ghost %{_libdir}/libfolks-eds.so.26
176 %{_libdir}/girepository-1.0/FolksEds-0.7.typelib
177 %dir %{_libdir}/folks/%{abiver}/backends/eds
178 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/eds/eds.so
179 %endif
180 %if %{with telepathy}
181 %attr(755,root,root) %{_libdir}/libfolks-telepathy.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libfolks-telepathy.so.26
183 %{_libdir}/girepository-1.0/FolksTelepathy-0.7.typelib
184 %dir %{_libdir}/folks/%{abiver}/backends/telepathy
185 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/telepathy/telepathy.so
186 %endif
187 %{_datadir}/GConf/gsettings/folks.convert
188 %{_datadir}/glib-2.0/schemas/org.freedesktop.folks.gschema.xml
189
190 %files devel
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/libfolks.so
193 %attr(755,root,root) %{_libdir}/libfolks-dummy.so
194 %{_datadir}/gir-1.0/Folks-0.7.gir
195 %{_datadir}/gir-1.0/FolksDummy-0.7.gir
196 %{_includedir}/folks
197 %{_pkgconfigdir}/folks.pc
198 %{_pkgconfigdir}/folks-dummy.pc
199 %if %{with evolution}
200 %attr(755,root,root) %{_libdir}/libfolks-eds.so
201 %{_datadir}/gir-1.0/FolksEds-0.7.gir
202 %{_pkgconfigdir}/folks-eds.pc
203 %endif
204 %if %{with telepathy}
205 %attr(755,root,root) %{_libdir}/libfolks-telepathy.so
206 %{_datadir}/gir-1.0/FolksTelepathy-0.7.gir
207 %{_pkgconfigdir}/folks-telepathy.pc
208 %endif
209
210 %if %{with vala}
211 %files -n vala-folks
212 %defattr(644,root,root,755)
213 %{_datadir}/vala/vapi/folks.deps
214 %{_datadir}/vala/vapi/folks.vapi
215 %{_datadir}/vala/vapi/folks-dummy.deps
216 %{_datadir}/vala/vapi/folks-dummy.vapi
217 %if %{with evolution}
218 %{_datadir}/vala/vapi/folks-eds.deps
219 %{_datadir}/vala/vapi/folks-eds.vapi
220 %endif
221 %if %{with telepathy}
222 %{_datadir}/vala/vapi/folks-telepathy.deps
223 %{_datadir}/vala/vapi/folks-telepathy.vapi
224 %endif
225 %endif
This page took 0.029763 seconds and 2 git commands to generate.