]> git.pld-linux.org Git - packages/folks.git/blob - folks.spec
0d6f8cf98e08ea79223075ff37c6009c42e8b0e9
[packages/folks.git] / folks.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs         # API documentation (broken install: HTML for devhelp part, sources+HTML for gtk-doc?)
4 %bcond_without  vala            # Vala API
5 %bcond_without  bluez           # Bluez backend
6 %bcond_without  evolution       # EDS (Evolution Data Server) backend
7 %bcond_without  ofono           # oFono backend
8 %bcond_without  telepathy       # Telepathy backend
9 %bcond_without  zeitgeist       # ` Zeitgeist support in Telepathy backend
10 %bcond_without  tracker         # Tracker backend
11
12 %if %{without telepathy}
13 %undefine       with_zeitgeist
14 %endif
15 Summary:        GObject contact aggregation library
16 Summary(pl.UTF-8):      Biblioteka GObject do agregowania kontaktów
17 Name:           folks
18 Version:        0.14.0
19 Release:        2
20 License:        LGPL v2.1+
21 Group:          Libraries
22 Source0:        http://ftp.gnome.org/pub/GNOME/sources/folks/0.14/%{name}-%{version}.tar.xz
23 # Source0-md5:  dc852fceab9e84362b675d5ffcd4803e
24 Patch0:         %{name}-meson.patch
25 Patch1:         %{name}-module.patch
26 Patch2:         %{name}-vala.patch
27 URL:            https://wiki.gnome.org/Projects/Folks
28 BuildRequires:  dbus-devel
29 %{?with_telepathy:BuildRequires:        dbus-glib-devel}
30 %if %{with bluez} || %{with evolution} || %{with ofono}
31 # libebook for all; libebook-contacts, libedataserver, evolution-data-server for evolution
32 BuildRequires:  evolution-data-server-devel >= 3.33.2
33 %endif
34 BuildRequires:  gettext-tools
35 BuildRequires:  glib2-devel >= 1:2.44
36 BuildRequires:  gobject-introspection-devel >= 1.30.0
37 BuildRequires:  libgee-devel >= 0.8.4
38 BuildRequires:  libxml2-devel >= 2.0
39 BuildRequires:  meson >= 0.51
40 BuildRequires:  ncurses-devel
41 BuildRequires:  ninja >= 1.5
42 BuildRequires:  pkgconfig >= 1:0.21
43 BuildRequires:  python3 >= 1:3.2
44 %{?with_bluez:BuildRequires:    python3-dbusmock}
45 BuildRequires:  rpmbuild(macros) >= 1.736
46 BuildRequires:  readline-devel
47 BuildRequires:  tar >= 1:1.22
48 %{?with_telepathy:BuildRequires:        telepathy-glib-devel >= 0.19.9}
49 %{?with_tracker:BuildRequires:  tracker-devel >= 2.0}
50 %if %{with vala}
51 BuildRequires:  vala >= 2:0.22.1
52 %if %{with bluez} || %{with evolution} || %{with ofono}
53 BuildRequires:  vala-evolution-data-server >= 3.33.2
54 %endif
55 BuildRequires:  vala-libgee >= 0.8.4
56 %{?with_telepathy:BuildRequires:        vala-telepathy-glib >= 0.19.9}
57 %{?with_tracker:BuildRequires:  vala-tracker >= 2.0}
58 %{?with_zeitgeist:BuildRequires:        vala-zeitgeist >= 0.9.14}
59 %endif
60 %{?with_apidocs:BuildRequires:  valadoc >= 0.3.1}
61 BuildRequires:  xz
62 %{?with_zeitgeist:BuildRequires:        zeitgeist-devel >= 0.9.14}
63 %if %{with bluez} || %{with evolution} || %{with ofono}
64 Requires:       evolution-data-server-libs >= 3.33.2
65 %endif
66 Requires:       glib2 >= 1:2.44
67 Requires:       libgee >= 0.8.4
68 %{?with_telepathy:Requires:     telepathy-glib >= 0.19.9}
69 %{?with_tracker:Requires:       tracker-libs >= 2.0}
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         abiver  46
73
74 %description
75 libfolks is a library that aggregates people from multiple sources
76 (e.g. Telepathy connection managers and eventually evolution data
77 server, Facebook, etc.) to create meta-contacts.
78
79 %description -l pl.UTF-8
80 libfolks to biblioteka gromadząca osoby z wielu źródeł (np. zarządców
81 połączeń Telepathy, serwera danych Evolution, Facebooka itp.), aby
82 utworzyć metakontakty.
83
84 %package devel
85 Summary:        Development files for folks libraries
86 Summary(pl.UTF-8):      Pliki programistyczne bibliotek folks
87 Group:          Development/Libraries
88 Requires:       %{name} = %{version}-%{release}
89 %if %{with bluez} || %{with evolution} || %{with ofono}
90 Requires:       evolution-data-server-devel >= 3.33.2
91 %endif
92 Requires:       glib2-devel >= 1:2.44
93 Requires:       libgee-devel >= 0.8.4
94 %{?with_telepathy:Requires:     telepathy-glib-devel >= 0.19.9}
95 %{?with_tracker:Requires:       tracker-devel >= 2.0}
96
97 %description devel
98 Development files for folks libraries.
99
100 %description devel -l pl.UTF-8
101 Pliki programistyczne bibliotek folks.
102
103 %package -n vala-folks
104 Summary:        folks API for Vala language
105 Summary(pl.UTF-8):      API folks dla języka Vala
106 Group:          Development/Libraries
107 Requires:       %{name}-devel = %{version}-%{release}
108 Requires:       vala >= 2:0.22.1
109 %if %{with bluez} || %{with evolution} || %{with ofono}
110 Requires:       vala-evolution-data-server >= 3.33.2
111 %endif
112 Requires:       vala-libgee >= 0.8.4
113 %{?with_telepathy:Requires:     vala-telepathy-glib >= 0.19.9}
114 %{?with_tracker:Requires:       vala-tracker >= 2.0}
115 BuildArch:      noarch
116
117 %description -n vala-folks
118 folks API for Vala language.
119
120 %description -n vala-folks -l pl.UTF-8
121 API folks dla języka Vala.
122
123 %prep
124 %setup -q
125 %patch0 -p1
126 %patch1 -p1
127 %patch2 -p1
128
129 %build
130 %meson build \
131         %{!?with_bluez:-Dbluez_backend=false} \
132         %{?with_apidocs:-Ddocs=true} \
133         %{!?with_evolution:-Deds_backend=false} \
134         %{!?with_ofono:-Dofono_backend=false} \
135         %{?with_tracker:-Dtracker_backend=true} \
136         %{!?with_telepathy:-Dtelepathy_backend=false} \
137         %{?with_zeitgeist:-Dzeitgeist=true}
138
139 %ninja_build -C build
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %ninja_install -C build
145
146 %find_lang %{name}
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files -f %{name}.lang
155 %defattr(644,root,root,755)
156 %doc AUTHORS MAINTAINERS NEWS README.md
157 %attr(755,root,root) %{_bindir}/folks-import
158 %attr(755,root,root) %{_bindir}/folks-inspect
159 %attr(755,root,root) %{_libdir}/libfolks.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libfolks.so.25
161 %attr(755,root,root) %{_libdir}/libfolks-dummy.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libfolks-dummy.so.25
163 %{_libdir}/girepository-1.0/Folks-0.6.typelib
164 %{_libdir}/girepository-1.0/FolksDummy-0.6.typelib
165 %dir %{_libdir}/folks
166 %dir %{_libdir}/folks/%{abiver}
167 %dir %{_libdir}/folks/%{abiver}/backends
168 %dir %{_libdir}/folks/%{abiver}/backends/dummy
169 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/dummy/dummy.so
170 %dir %{_libdir}/folks/%{abiver}/backends/key-file
171 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/key-file/key-file.so
172 %if %{with bluez}
173 %dir %{_libdir}/folks/%{abiver}/backends/bluez
174 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/bluez/bluez.so
175 %endif
176 %if %{with ofono}
177 %dir %{_libdir}/folks/%{abiver}/backends/ofono
178 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/ofono/ofono.so
179 %endif
180 %if %{with evolution}
181 %attr(755,root,root) %{_libdir}/libfolks-eds.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libfolks-eds.so.25
183 %{_libdir}/girepository-1.0/FolksEds-0.6.typelib
184 %dir %{_libdir}/folks/%{abiver}/backends/eds
185 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/eds/eds.so
186 %endif
187 %if %{with telepathy}
188 %attr(755,root,root) %{_libdir}/libfolks-telepathy.so.*.*.*
189 %attr(755,root,root) %ghost %{_libdir}/libfolks-telepathy.so.25
190 %{_libdir}/girepository-1.0/FolksTelepathy-0.6.typelib
191 %dir %{_libdir}/folks/%{abiver}/backends/telepathy
192 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/telepathy/telepathy.so
193 %endif
194 %if %{with tracker}
195 %attr(755,root,root) %{_libdir}/libfolks-tracker.so.*.*.*
196 %attr(755,root,root) %ghost %{_libdir}/libfolks-tracker.so.25
197 %{_libdir}/girepository-1.0/FolksTracker-0.6.typelib
198 %dir %{_libdir}/folks/%{abiver}/backends/tracker
199 %attr(755,root,root) %{_libdir}/folks/%{abiver}/backends/tracker/tracker.so
200 %endif
201 %{_datadir}/GConf/gsettings/folks.convert
202 %{_datadir}/glib-2.0/schemas/org.freedesktop.folks.gschema.xml
203
204 %files devel
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_libdir}/libfolks.so
207 %attr(755,root,root) %{_libdir}/libfolks-dummy.so
208 %{_datadir}/gir-1.0/Folks-0.6.gir
209 %{_datadir}/gir-1.0/FolksDummy-0.6.gir
210 %{_includedir}/folks
211 %{_pkgconfigdir}/folks.pc
212 %{_pkgconfigdir}/folks-dummy.pc
213 %if %{with evolution}
214 %attr(755,root,root) %{_libdir}/libfolks-eds.so
215 %{_datadir}/gir-1.0/FolksEds-0.6.gir
216 %{_pkgconfigdir}/folks-eds.pc
217 %endif
218 %if %{with telepathy}
219 %attr(755,root,root) %{_libdir}/libfolks-telepathy.so
220 %{_datadir}/gir-1.0/FolksTelepathy-0.6.gir
221 %{_pkgconfigdir}/folks-telepathy.pc
222 %endif
223 %if %{with tracker}
224 %attr(755,root,root) %{_libdir}/libfolks-tracker.so
225 %{_datadir}/gir-1.0/FolksTracker-0.6.gir
226 %{_pkgconfigdir}/folks-tracker.pc
227 %endif
228
229 %if %{with vala}
230 %files -n vala-folks
231 %defattr(644,root,root,755)
232 %{_datadir}/vala/vapi/folks.deps
233 %{_datadir}/vala/vapi/folks.vapi
234 %{_datadir}/vala/vapi/folks-dummy.deps
235 %{_datadir}/vala/vapi/folks-dummy.vapi
236 %if %{with evolution}
237 %{_datadir}/vala/vapi/folks-eds.deps
238 %{_datadir}/vala/vapi/folks-eds.vapi
239 %endif
240 %if %{with telepathy}
241 %{_datadir}/vala/vapi/folks-telepathy.deps
242 %{_datadir}/vala/vapi/folks-telepathy.vapi
243 %endif
244 %if %{with tracker}
245 %{_datadir}/vala/vapi/folks-tracker.deps
246 %{_datadir}/vala/vapi/folks-tracker.vapi
247 %endif
248 %endif
This page took 0.060693 seconds and 2 git commands to generate.